aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome/gconf_2.6.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/gnome/gconf_2.6.1.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/gnome/gconf_2.6.1.bb')
-rw-r--r--packages/gnome/gconf_2.6.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/gnome/gconf_2.6.1.bb b/packages/gnome/gconf_2.6.1.bb
index e69de29bb2..cb55d5b5c4 100644
--- a/packages/gnome/gconf_2.6.1.bb
+++ b/packages/gnome/gconf_2.6.1.bb
@@ -0,0 +1,32 @@
+LICENSE = LGPL
+SECTION = "x11/gnome"
+DESCRIPTION = "GNOME configuration database system"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/GConf/2.6/GConf-${PV}.tar.bz2 \
+ file://backends.patch;patch=1"
+DEPENDS = "orbit2 glib-2.0 libxml2"
+ORBIT_IDL_SRC = "${STAGING_BINDIR}/orbit-idl-2"
+
+FILES_${PN} += " ${libdir}/GConf/*"
+
+S = "${WORKDIR}/GConf-${PV}"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+inherit autotools pkgconfig gettext
+
+HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
+
+do_compile() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
+}
+
+do_stage() {
+ oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/gconf/2/gconf/
+ ( cd gconf; for i in ${HEADERS}; do install -m 0644 $i ${STAGING_INCDIR}/gconf/2/gconf/$i; done )
+ install -m 0644 gconf.m4 ${STAGING_DATADIR}/aclocal/gconf-2.m4
+}
+
+do_install() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
+}