aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome/libbonobo_2.6.0.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-01-23 13:04:36 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-01-23 13:04:36 +0000
commit1ff63759466fe74afe78a9c25a5f0eddc9427f73 (patch)
treec2eb8394817a682e6883eaaed62d19ff3139017c /packages/gnome/libbonobo_2.6.0.bb
parent3eeb3cc8e42f90464cf5e7c87010fc016b6270af (diff)
downloadopenembedded-1ff63759466fe74afe78a9c25a5f0eddc9427f73.tar.gz
remove errornous references to libtool class. patch courtesy Marc Singer
BKrev: 41f3a0e4EiUIg4lpy9yKpp_SK0vy8Q
Diffstat (limited to 'packages/gnome/libbonobo_2.6.0.bb')
-rw-r--r--packages/gnome/libbonobo_2.6.0.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/packages/gnome/libbonobo_2.6.0.bb b/packages/gnome/libbonobo_2.6.0.bb
index e69de29bb2..4f6dbfd332 100644
--- a/packages/gnome/libbonobo_2.6.0.bb
+++ b/packages/gnome/libbonobo_2.6.0.bb
@@ -0,0 +1,52 @@
+LICENSE = GPL
+SECTION = "x11/gnome"
+DESCRIPTION = "Bonobo CORBA interfaces library"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libbonobo/2.6/libbonobo-${PV}.tar.bz2 \
+ file://gtk-doc.m4 \
+ file://gtk-doc.make"
+DEPENDS = "glib-2.0 orbit2 intltool-native libxml2"
+ORBIT_IDL_SRC = "${STAGING_BINDIR}/orbit-idl-2"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ install -d m4
+ install ${WORKDIR}/gtk-doc.m4 m4/
+ install ${WORKDIR}/gtk-doc.make ./
+}
+
+ACTIVATION_HEADERS = "Bonobo_Unknown.h Bonobo_GenericFactory.h Bonobo_Activation_types.h \
+ bonobo-activation.h bonobo-activation-async.h bonobo-activation-activate.h \
+ bonobo-activation-init.h bonobo-activation-shlib.h bonobo-activation-register.h \
+ bonobo-activation-server-info.h bonobo-activation-version.h"
+
+BONOBO_HEADERS = "Bonobo.h bonobo-arg.h bonobo-context.h bonobo-event-source.h bonobo-exception.h \
+ bonobo-generic-factory.h bonobo-item-container.h bonobo-item-handler.h \
+ bonobo-listener.h bonobo-main.h bonobo-macros.h bonobo-moniker-extender.h \
+ bonobo-moniker-simple.h bonobo-moniker-util.h bonobo-moniker.h bonobo-object.h \
+ bonobo-foreign-object.h bonobo-persist-file.h bonobo-persist-stream.h \
+ bonobo-persist.h bonobo-persist-client.h bonobo-property-bag.h \
+ bonobo-property-bag-client.h bonobo-shlib-factory.h bonobo-storage.h \
+ bonobo-stream.h bonobo-stream-client.h bonobo-stream-memory.h \
+ bonobo-storage-memory.h bonobo-xobject.h bonobo-i18n.h bonobo-types.h \
+ bonobo-app-client.h bonobo-application.h"
+
+do_compile() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation
+ for i in ${ACTIVATION_HEADERS}; do install -m 0644 bonobo-activation/$i ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation/; done
+ install -d ${STAGING_INCDIR}/libbonobo-2.0/bonobo
+ for i in ${BONOBO_HEADERS}; do install -m 0644 bonobo/$i ${STAGING_INCDIR}/libbonobo-2.0/bonobo/; done
+ install -m 0644 libbonobo.h ${STAGING_INCDIR}/libbonobo-2.0/
+ install -d ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
+ install idl/*.idl ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
+ oe_libinstall -so -C bonobo libbonobo-2 ${STAGING_LIBDIR}
+ oe_libinstall -so -C bonobo-activation libbonobo-activation ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
+}