aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnuchess
diff options
context:
space:
mode:
authorDmitry Artamonow <mad_soft@inbox.ru>2008-05-26 14:30:39 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-05-26 14:30:39 +0000
commit5e83c12050f4e24f480ae6eef06b732997ce7ad2 (patch)
tree94ed1c9a2f9c2cdd1da60520ca2baf3c234987d6 /packages/gnuchess
parent8c75d047c55874827cd4aa3534472ae62638fa11 (diff)
downloadopenembedded-5e83c12050f4e24f480ae6eef06b732997ce7ad2.tar.gz
fltk-chess: new recipe. Partly closes 429.
* commit by Laibsch
Diffstat (limited to 'packages/gnuchess')
-rw-r--r--packages/gnuchess/files/.mtn2git_empty0
-rw-r--r--packages/gnuchess/files/fix_cast_error_and_gnuchess_exec.patch23
-rw-r--r--packages/gnuchess/files/fltk-chess.desktop7
-rw-r--r--packages/gnuchess/fltk-chess_0.5.bb33
4 files changed, 63 insertions, 0 deletions
diff --git a/packages/gnuchess/files/.mtn2git_empty b/packages/gnuchess/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gnuchess/files/.mtn2git_empty
diff --git a/packages/gnuchess/files/fix_cast_error_and_gnuchess_exec.patch b/packages/gnuchess/files/fix_cast_error_and_gnuchess_exec.patch
new file mode 100644
index 0000000000..8dba103dc3
--- /dev/null
+++ b/packages/gnuchess/files/fix_cast_error_and_gnuchess_exec.patch
@@ -0,0 +1,23 @@
+diff -Naur fltk-chess.orig/fltk-chess.cxx fltk-chess/fltk-chess.cxx
+--- fltk-chess.orig/fltk-chess.cxx 2005-08-25 01:42:28.000000000 +0400
++++ fltk-chess/fltk-chess.cxx 2008-05-17 19:26:57.000000000 +0400
+@@ -705,8 +705,8 @@
+
+ void cb_P(Fl_Widget * ob, void *p)
+ {
+-
+- changeP = (char) p;
++ int temp_p = (int) p;
++ changeP = (char) temp_p;
+ }
+
+
+@@ -881,7 +881,7 @@
+ // close(fdFrom[0]);
+ // close(fdFrom[1]);
+
+- execl("./gnuchess", NULL);
++ execl("/bin/sh", "/bin/sh", "-c", "exec gnuchess", NULL);
+
+ } else {
+
diff --git a/packages/gnuchess/files/fltk-chess.desktop b/packages/gnuchess/files/fltk-chess.desktop
new file mode 100644
index 0000000000..6c422659d6
--- /dev/null
+++ b/packages/gnuchess/files/fltk-chess.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=FLTK Chess
+Comment=FLTK frontend to GNUchess
+Exec=fltk-chess
+Type=Application
+Icon=fltk-chess
+Categories=Game;BoardGame;
diff --git a/packages/gnuchess/fltk-chess_0.5.bb b/packages/gnuchess/fltk-chess_0.5.bb
new file mode 100644
index 0000000000..fae7411329
--- /dev/null
+++ b/packages/gnuchess/fltk-chess_0.5.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "fltk-chess is a frontend for the Gnuchess chess playing engine."
+AUTHOR = "Andreas Holzer <a.holzer@cheese.at>"
+SECTION = "x11/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "fltk"
+RDEPENDS = "gnuchess"
+
+
+SRC_URI = "http://members.cheese.at/woody/fltk-chess/fltk-chess-${PV}.tgz \
+ file://fix_cast_error_and_gnuchess_exec.patch;patch=1 \
+ file://fltk-chess.desktop"
+S = "${WORKDIR}/fltk-chess/"
+
+
+do_compile() {
+ `fltk-config --cxx --cxxflags --ldflags --use-images` -o fltk-chess \
+ fltk-chess.cxx
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/pixmaps/fltk-chess/
+ install -d ${D}${datadir}/applications/
+ install -m 0755 ${S}/fltk-chess ${D}${bindir}
+ install -m 0644 ${S}/bitmaps/*.pnx ${D}${datadir}/pixmaps/fltk-chess/
+ install -m 0644 ${S}/bitmaps/{user,computer}.png \
+ ${D}${datadir}/pixmaps/fltk-chess/
+ install -m 0644 ${S}/bitmaps/fltk-chess.png ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/fltk-chess.desktop ${D}${datadir}/applications/
+}
+
+