aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnutls
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-02 19:40:07 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-02 19:40:07 +0000
commit8ae84e84e7520caa1542ea77c27e6b316481c54a (patch)
treeb55329d369ce231614b7a2542ec735cd04693c2d /packages/gnutls
parent58e96e5d71da1193c88cd5392e91a55f0a37d21e (diff)
downloadopenembedded-8ae84e84e7520caa1542ea77c27e6b316481c54a.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/02 19:07:31+00:00 nexus.co.uk!pb build sylpheed with gnutls support 2005/01/02 19:00:27+00:00 nexus.co.uk!pb improve gnutls packaging granularity, and add patch for extended OpenSSL functionality (SSL_peek, etc) BKrev: 41d84e17Jb-QAOb_o_VQ4vKu7cO4pw
Diffstat (limited to 'packages/gnutls')
-rw-r--r--packages/gnutls/gnutls-1.0.23/gnutls-openssl.patch0
-rw-r--r--packages/gnutls/gnutls_1.0.23.bb26
2 files changed, 26 insertions, 0 deletions
diff --git a/packages/gnutls/gnutls-1.0.23/gnutls-openssl.patch b/packages/gnutls/gnutls-1.0.23/gnutls-openssl.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gnutls/gnutls-1.0.23/gnutls-openssl.patch
diff --git a/packages/gnutls/gnutls_1.0.23.bb b/packages/gnutls/gnutls_1.0.23.bb
index e69de29bb2..d2453b5056 100644
--- a/packages/gnutls/gnutls_1.0.23.bb
+++ b/packages/gnutls/gnutls_1.0.23.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GNU Transport Layer Security Library"
+DEPENDS = "zlib libgcrypt"
+PR = "r2"
+
+LICENSE = "LGPL"
+
+SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.gz \
+ file://gnutls-openssl.patch;patch=1"
+
+inherit autotools
+
+PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
+FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
+FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
+FILES_${PN} = "${libdir}/libgnutls.so.*"
+FILES_${PN}-bin = "${bindir}/gnutls-serv ${bindir}/gnutls-cli \
+ ${bindir}/srptool ${bindir}/certtool ${bindir}/gnutls-srpcrypt"
+FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
+
+do_stage() {
+ oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
+ autotools_stage_includes
+}
+