aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnutls
diff options
context:
space:
mode:
authorJoseph Cole <jnc@unknown.openembedded.org>2006-02-26 04:16:51 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-26 04:16:51 +0000
commitba1f81ba6dea91931c8da3399f522a421b812ae3 (patch)
tree86fd9519059f5da487b356e1f610ea3d50e827e4 /packages/gnutls
parentc60a1399f380c03d1210cf463af23628bd855602 (diff)
downloadopenembedded-ba1f81ba6dea91931c8da3399f522a421b812ae3.tar.gz
Introduce experimental wpa-supplicant linked against GNU/tls library.
Diffstat (limited to 'packages/gnutls')
-rw-r--r--packages/gnutls/gnutls_1.3.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/gnutls/gnutls_1.3.4.bb b/packages/gnutls/gnutls_1.3.4.bb
new file mode 100644
index 0000000000..0c02f4bd0f
--- /dev/null
+++ b/packages/gnutls/gnutls_1.3.4.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "GNU Transport Layer Security Library"
+DEPENDS = "zlib libgcrypt lzo"
+
+LICENSE = "LGPL"
+
+SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/devel/gnutls-${PV}.tar.bz2"
+
+inherit autotools
+inherit binconfig
+
+PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
+FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
+FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
+FILES_${PN} = "${libdir}/libgnutls.so.*"
+FILES_${PN}-bin = "${bindir}/gnutls-serv ${bindir}/gnutls-cli \
+ ${bindir}/srptool ${bindir}/certtool ${bindir}/gnutls-srpcrypt"
+FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
+
+EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1"
+
+do_stage() {
+ oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
+ autotools_stage_includes
+}
+