aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnutls
diff options
context:
space:
mode:
authorJoseph Cole <jnc@unknown.openembedded.org>2006-02-25 20:40:17 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-25 20:40:17 +0000
commitc60a1399f380c03d1210cf463af23628bd855602 (patch)
tree17d92532be424b6b8bc5367ec937409bd55095d0 /packages/gnutls
parent61a3cd252d44716cbabfbabbe91059d7b3d60ee0 (diff)
downloadopenembedded-c60a1399f380c03d1210cf463af23628bd855602.tar.gz
Version bump. Plays nice with new wpa-supplicant, hopefully.
Diffstat (limited to 'packages/gnutls')
-rw-r--r--packages/gnutls/gnutls_1.2.10.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/gnutls/gnutls_1.2.10.bb b/packages/gnutls/gnutls_1.2.10.bb
new file mode 100644
index 0000000000..7227dfdcae
--- /dev/null
+++ b/packages/gnutls/gnutls_1.2.10.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "GNU Transport Layer Security Library"
+DEPENDS = "zlib libgcrypt lzo"
+
+LICENSE = "LGPL"
+
+SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2"
+
+inherit autotools
+inherit binconfig
+
+PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
+FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
+FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
+FILES_${PN} = "${libdir}/libgnutls.so.*"
+FILES_${PN}-bin = "${bindir}/gnutls-serv ${bindir}/gnutls-cli \
+ ${bindir}/srptool ${bindir}/certtool ${bindir}/gnutls-srpcrypt"
+FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
+
+EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1"
+
+do_stage() {
+ oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
+ autotools_stage_includes
+}
+