aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-session-scripts
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2005-08-25 16:52:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-25 16:52:53 +0000
commitc70043e30f03cae08f675034f754b702dbb47807 (patch)
tree36f56b53147054273af432e40204ca98d40186a3 /packages/gpe-session-scripts
parentdc7bc07d35283af13f89bcc9c1bb4cc1b3f68bcf (diff)
downloadopenembedded-c70043e30f03cae08f675034f754b702dbb47807.tar.gz
New release of gpe-session-scripts.
Diffstat (limited to 'packages/gpe-session-scripts')
-rw-r--r--packages/gpe-session-scripts/gpe-session-scripts_0.64.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/gpe-session-scripts/gpe-session-scripts_0.64.bb b/packages/gpe-session-scripts/gpe-session-scripts_0.64.bb
new file mode 100644
index 0000000000..cf62a9a2d0
--- /dev/null
+++ b/packages/gpe-session-scripts/gpe-session-scripts_0.64.bb
@@ -0,0 +1,31 @@
+LICENSE = "GPL"
+PR = "r0"
+
+inherit gpe
+
+DESCRIPTION = "GPE session startup scripts"
+SECTION = "gpe"
+PRIORITY = "optional"
+MAINTAINER = "Philip Blundell <pb@handhelds.org>"
+RDEPENDS_${PN} = "matchbox gpe-session-starter gpe-bluetooth xstroke xtscal gpe-question gpe-clock matchbox-applet-inputmanager xrandr xmodmap xdpyinfo x11-common"
+# more rdepends: keylaunch ipaq-sleep apmd blueprobe
+DEPENDS = "matchbox-wm matchbox-panel gpe-bluetooth xstroke xtscal gpe-question matchbox-applet-inputmanager gpe-clock xrandr xmodmap xdpyinfo x11-common"
+
+SRC_URI += "file://matchbox-session \
+ file://disable-composite.xsettings \
+ file://remove-x11-common-files.patch;patch=1"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/gpe/xsettings-default.d
+ if [ "${GUI_MACHINE_CLASS}" != "bigscreen" ]; then
+ echo "Gtk/ToolbarStyle:S:icons" > ${D}${sysconfdir}/gpe/xsettings-default.d/toolbar
+ fi
+ install -d ${D}${sysconfdir}/matchbox
+ install ${WORKDIR}/matchbox-session ${D}${sysconfdir}/matchbox/session
+
+ install -d ${D}${sysconfdir}/gpe/xsettings-default.d
+ install -m 0644 ${WORKDIR}/disable-composite.xsettings ${D}${sysconfdir}/gpe/xsettings-default.d/disable-composite
+}
+
+# This makes use of GUI_MACHINE_CLASS, so set PACKAGE_ARCH appropriately
+PACKAGE_ARCH = "${MACHINE_ARCH}"