aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpsd
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2008-01-01 15:20:03 +0000
committerMatthias Hentges <oe@hentges.net>2008-01-01 15:20:03 +0000
commit65bf158e2f48dcaf562046580e0a958466ae61e4 (patch)
treed51eec2549a2c2681122471245116c35bed6a77b /packages/gpsd
parent0159197c45f5296fbdc29ff180d787e7bb19879d (diff)
downloadopenembedded-65bf158e2f48dcaf562046580e0a958466ae61e4.tar.gz
gpsd: Provide working default configuration and init-script for fic-gta01. This makes gpsd device-specific for gta01, please check the feeds.
Diffstat (limited to 'packages/gpsd')
-rw-r--r--packages/gpsd/files/fic-gta01/.mtn2git_empty0
-rwxr-xr-xpackages/gpsd/files/fic-gta01/gpsd105
-rw-r--r--packages/gpsd/files/fic-gta01/gpsd-default3
-rw-r--r--packages/gpsd/gpsd_2.34.bb2
4 files changed, 109 insertions, 1 deletions
diff --git a/packages/gpsd/files/fic-gta01/.mtn2git_empty b/packages/gpsd/files/fic-gta01/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpsd/files/fic-gta01/.mtn2git_empty
diff --git a/packages/gpsd/files/fic-gta01/gpsd b/packages/gpsd/files/fic-gta01/gpsd
new file mode 100755
index 0000000000..113f43dd20
--- /dev/null
+++ b/packages/gpsd/files/fic-gta01/gpsd
@@ -0,0 +1,105 @@
+#!/bin/sh
+#
+# gpsd This shell script starts and stops gpsd.
+#
+# chkconfig: 345 90 40
+# description: Gpsd manages access to a serial- or USB-connected GPS
+# processname: gpsd
+
+# Source function library.
+#. /etc/rc.d/init.d/functions
+
+RETVAL=0
+prog="gpsd"
+
+test -f /etc/default/$prog && . /etc/default/$prog
+
+start() {
+ # Start daemons.
+ echo -n "Starting $prog: "
+ # We don't use the daemon function here because of a known bug
+ # in initlog -- it spuriously returns a nonzero status when
+ # starting daemons that fork themselves. See
+ # http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=130629
+ # for discussion. Fortunately:
+ #
+ # 1. gpsd startup can't fail, or at least not in the absence of
+ # much larger resource-exhaustion problems that would be very obvious.
+ #
+ # 2. We don't need all the logging crud that daemon/initlog sets
+ # up -- gpsd does its own syslog calls.
+ #
+
+ if test -e /home/root/gllin/gllin
+ then
+ /home/root/gllin/gllin >/var/log/gllin.log 2>&1 &
+ else
+ echo -e "\n\ngllin GPS driver for Neo1973 not found,"
+ echo "please install the gllin package from"
+ echo "http://3rdparty.downloads.openmoko.org/gllin/"
+ echo ""
+ exit 1
+ fi
+
+ if [ -e "${GPS_DEV}" ]
+ then
+ gpsd ${GPSD_OPTS} -p ${GPS_DEV}
+ echo "success"
+ else
+ # User needs to symlink ${GPS_DEV} to the right thing
+ echo "No ${GPS_DEV} GPS device, aborting gpsd startup. Check /etc/default/$prog"
+ fi
+ RETVAL=$?
+ echo
+ [ $RETVAL -eq 0 ] && touch /var/lock/subsys/gpsd
+ return $RETVAL
+}
+
+stop() {
+ # Stop daemons.
+ echo -n "Shutting down $prog: "
+
+ gllin_PIDs="`ps ax | grep "/home/root/gllin" | grep -v grep | awk '{print $1}'`"
+ test -n "$gllin_PIDs" && kill $gllin_PIDs
+
+ killall gpsd
+ killproc gpsd
+ RETVAL=$?
+ echo
+ if [ $RETVAL -eq 0 ]
+ then
+ rm -f /var/lock/subsys/gpsd;
+ fi
+ return $RETVAL
+}
+
+# See how we were called.
+case "$1" in
+ start)
+ start
+ ;;
+ stop)
+ stop
+ ;;
+ restart|reload)
+ stop
+ start
+ RETVAL=$?
+ ;;
+ condrestart)
+ if [ -f /var/lock/subsys/gpsd ]; then
+ stop
+ start
+ RETVAL=$?
+ fi
+ ;;
+ status)
+# status gpsd
+# RETVAL=$?
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|condrestart|status}"
+ exit 1
+esac
+
+exit $RETVAL
diff --git a/packages/gpsd/files/fic-gta01/gpsd-default b/packages/gpsd/files/fic-gta01/gpsd-default
new file mode 100644
index 0000000000..abd35927e5
--- /dev/null
+++ b/packages/gpsd/files/fic-gta01/gpsd-default
@@ -0,0 +1,3 @@
+# If you must specify a non-NMEA driver, uncomment and modify the next line
+#GPSD_OPTS=
+GPS_DEV="/tmp/nmeaNP"
diff --git a/packages/gpsd/gpsd_2.34.bb b/packages/gpsd/gpsd_2.34.bb
index 32cb4b925d..8472eb1c15 100644
--- a/packages/gpsd/gpsd_2.34.bb
+++ b/packages/gpsd/gpsd_2.34.bb
@@ -1,4 +1,4 @@
require gpsd.inc
-PR = "r5"
+PR = "r6"