aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gputty
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-04-12 13:56:16 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-04-12 13:56:16 +0000
commit355a2db6fca210601c7b0c77473f94ee44416286 (patch)
treead43ce9c2144e337a8c4c3f9cfe5a4887b6abc4f /packages/gputty
parent6af08008e6019bbabc462fa624d3851124d4a4bd (diff)
downloadopenembedded-355a2db6fca210601c7b0c77473f94ee44416286.tar.gz
misc. SECTION fixes
BKrev: 425bd380QeEURzDMDNXwEK5qgFFICg
Diffstat (limited to 'packages/gputty')
-rw-r--r--packages/gputty/gputty_0.9.8.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/gputty/gputty_0.9.8.bb b/packages/gputty/gputty_0.9.8.bb
index e69de29bb2..5e1ed06357 100644
--- a/packages/gputty/gputty_0.9.8.bb
+++ b/packages/gputty/gputty_0.9.8.bb
@@ -0,0 +1,27 @@
+# OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "GPuTTY is a PuTTY clone using the Gnome environment"
+HOMEPAGE = "http://www.defora.org/index.php?page=gputty"
+LICENSE = "GPL"
+SECTION = "network"
+PR = "r0"
+
+SRC_URI = "http://people.defora.org/~khorben/projects/gputty/gputty-${PV}.tar.gz \
+ file://gputty"
+
+do_compile() {
+ oe_runmake -C src
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ oe_runmake -C src BINDIR="${bindir}" DESTDIR="${D}" install
+ install -d ${D}${sysconfdir}/
+ install -m 0644 ${WORKDIR}/gputty ${D}${sysconfdir}/
+}
+
+# Save the configuration file in the package
+FILES_${PN} += " /etc/gputty"
+