aboutsummaryrefslogtreecommitdiffstats
path: root/packages/grub
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-11-18 16:55:13 +0000
committerHolger Freyther <zecke@selfish.org>2006-11-18 16:55:13 +0000
commit56b7d78a034187f66e08f3b3e2de55bd878cf9b5 (patch)
treed6f4033c0064f41c2205502d10c651e8710c96aa /packages/grub
parent9e61974759ef6e4ff9538a33bab0e82b1b4381dd (diff)
downloadopenembedded-56b7d78a034187f66e08f3b3e2de55bd878cf9b5.tar.gz
Micro-Optimisation decreasing initial parsing time by 10%
python () {} and python __anonymous () {} are as the same says functions without a name. They get executed when the main bb file is completely parsed. This is used to set information like FILESDIR. This is a python method so it gets evaled which means compiled and executed a lot of times. By moving the code of the anonfunc into a proper method this is only compiled once. The result is is the 10% speed up when parsing. Reindent anonfuncs and new defs without tabs and four spaces
Diffstat (limited to 'packages/grub')
-rw-r--r--packages/grub/grub_0.97.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/packages/grub/grub_0.97.bb b/packages/grub/grub_0.97.bb
index d0dddd0189..051296a31a 100644
--- a/packages/grub/grub_0.97.bb
+++ b/packages/grub/grub_0.97.bb
@@ -8,10 +8,10 @@ S = "${WORKDIR}/grub-${PV}"
inherit autotools
python __anonymous () {
- import re
- host = bb.data.getVar('HOST_SYS', d, 1)
- if not re.match('i.86.*-linux', host):
- raise bb.parse.SkipPackage("incompatible with host %s" % host)
+ import re
+ host = bb.data.getVar('HOST_SYS', d, 1)
+ if not re.match('i.86.*-linux', host):
+ raise bb.parse.SkipPackage("incompatible with host %s" % host)
}
do_install_append_vmware() {