aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gstreamer
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2005-03-02 19:55:58 +0000
committerPhil Blundell <philb@gnu.org>2005-03-02 19:55:58 +0000
commit0702ac92e45a9d65bd232fada81eb9c2403fd54d (patch)
treeb485f6fe14a9abf4c3ed19a456c0f1bd65b5ebbe /packages/gstreamer
parent7ac9b941333a812c41dc5d3af7e57b09296e1407 (diff)
downloadopenembedded-0702ac92e45a9d65bd232fada81eb9c2403fd54d.tar.gz
apply patch from Jamey Hicks to add httpsrc plugin
BKrev: 42261a4exA9rC2cuVMF8s2dh_eB6EQ
Diffstat (limited to 'packages/gstreamer')
-rw-r--r--packages/gstreamer/gst-plugins/gst-plugins-0.8.7-httpsrc1.patch0
-rw-r--r--packages/gstreamer/gst-plugins_0.8.7.bb55
2 files changed, 55 insertions, 0 deletions
diff --git a/packages/gstreamer/gst-plugins/gst-plugins-0.8.7-httpsrc1.patch b/packages/gstreamer/gst-plugins/gst-plugins-0.8.7-httpsrc1.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gstreamer/gst-plugins/gst-plugins-0.8.7-httpsrc1.patch
diff --git a/packages/gstreamer/gst-plugins_0.8.7.bb b/packages/gstreamer/gst-plugins_0.8.7.bb
index e69de29bb2..117ec033e9 100644
--- a/packages/gstreamer/gst-plugins_0.8.7.bb
+++ b/packages/gstreamer/gst-plugins_0.8.7.bb
@@ -0,0 +1,55 @@
+LICENSE = GPL
+DESCRIPTION = "Plugins for GStreamer"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+PR = "r1"
+
+DEPENDS = "gstreamer libmikmod libmad libogg tremor libvorbis libid3tag gpe-soundserver gconf"
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/gst-plugins/gst-plugins-${PV}.tar.bz2 \
+ file://gst-plugins-0.8.7-httpsrc1.patch;patch=1 \
+ file://try-esdsink.patch;patch=1"
+
+EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --disable-aalib --disable-arts \
+ --disable-artsc --disable-libfame --disable-sdl --disable-shout2 \
+ --disable-gnome_vfs --disable-gconf --disable-libcaca"
+
+inherit autotools pkgconfig gconf
+
+acpaths = "-I ${S}/common/m4 -I ${S}/m4"
+
+LIBV = "0.8"
+
+plugin_postinst() {
+ if [ x"$D" = "x" ]; then
+ gst-register --gst-registry=/var/cache/gstreamer-0.8/registry.xml
+ fi
+}
+
+python populate_packages_prepend () {
+ gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d)
+ postinst = bb.data.getVar('plugin_postinst', d, 1)
+
+ do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst)
+ do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)')
+}
+
+do_stage() {
+ autotools_stage_includes
+ while read a b; do
+ oe_libinstall -C gst-libs/gst/$a -so libgst$b ${STAGING_LIBDIR}
+ done <<EOF
+. interfaces-0.8
+audio audio
+audio audiofilter
+gconf gconf-0.8
+idct idct
+media-info media-info-0.8
+play play-0.8
+resample resample
+riff riff
+video video
+xwindowlistener xwindowlistener
+EOF
+}