aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gstreamer
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-08-10 18:32:14 +0000
committerKoen Kooi <koen@openembedded.org>2008-08-10 18:32:14 +0000
commitbbc89341cb44077e0dd7a1f78d1b3d7f5d73b31a (patch)
treebf862c3aba954a9903ae3dec7259235fccbc6168 /packages/gstreamer
parente3374f4da06c04a1503bd9e27126cde55e1075e2 (diff)
downloadopenembedded-bbc89341cb44077e0dd7a1f78d1b3d7f5d73b31a.tar.gz
gst-plugins: fix do_split_packages bogus dependency addition
gst-plguins-good: fix gconfelements plugin
Diffstat (limited to 'packages/gstreamer')
-rw-r--r--packages/gstreamer/gst-plugins-good_0.10.7.bb7
-rw-r--r--packages/gstreamer/gst-plugins.inc4
2 files changed, 8 insertions, 3 deletions
diff --git a/packages/gstreamer/gst-plugins-good_0.10.7.bb b/packages/gstreamer/gst-plugins-good_0.10.7.bb
index fb551f5176..ac3a5e73c5 100644
--- a/packages/gstreamer/gst-plugins-good_0.10.7.bb
+++ b/packages/gstreamer/gst-plugins-good_0.10.7.bb
@@ -1,5 +1,10 @@
require gst-plugins.inc
-PR = "r1"
+PR = "r2"
+
+inherit gconf
EXTRA_OECONF += "--with-check=no"
DEPENDS += "gst-plugins-base esound"
+
+PACKAGES =+ "gst-plugin-gconfelements"
+FILES_gst-plugin-gconfelements += "${sysconfdir}/gconf"
diff --git a/packages/gstreamer/gst-plugins.inc b/packages/gstreamer/gst-plugins.inc
index eaba8343f3..177585340d 100644
--- a/packages/gstreamer/gst-plugins.inc
+++ b/packages/gstreamer/gst-plugins.inc
@@ -19,8 +19,8 @@ python populate_packages_prepend () {
gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d)
postinst = bb.data.getVar('plugin_postinst', d, 1)
- do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst)
- do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)')
+ do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst, extra_depends='')
+ do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)', extra_depends='')
}
ALLOW_EMPTY = "1"