aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk+
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-06-12 15:11:51 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-06-12 15:11:51 +0000
commit4bb292958ea6afe63213f5584ee8d6f5bada3b55 (patch)
tree0e152f13d54153e95613773b2597db0d0e23470b /packages/gtk+
parentb1f4d34f8541f039d72d423223c91e32540a2fc5 (diff)
downloadopenembedded-4bb292958ea6afe63213f5584ee8d6f5bada3b55.tar.gz
gtk+: Add patch to fix file selector segfault contributed by HEXaBYTE.
Diffstat (limited to 'packages/gtk+')
-rw-r--r--packages/gtk+/files/filesel-fix-segfault.patch19
-rw-r--r--packages/gtk+/gtk+_2.10.12.bb3
-rw-r--r--packages/gtk+/gtk+_2.6.10.bb6
3 files changed, 25 insertions, 3 deletions
diff --git a/packages/gtk+/files/filesel-fix-segfault.patch b/packages/gtk+/files/filesel-fix-segfault.patch
new file mode 100644
index 0000000000..7b37d4bb2e
--- /dev/null
+++ b/packages/gtk+/files/filesel-fix-segfault.patch
@@ -0,0 +1,19 @@
+--- gtk+-2.10.12_/gtk/gtkfilesel.c 2007-06-12 14:00:38.000000000 +0200
++++ gtk+-2.10.12/gtk/gtkfilesel.c 2007-06-12 14:40:32.000000000 +0200
+@@ -2444,9 +2444,13 @@
+
+ if (!is_file)
+ {
+- gtk_file_selection_dir_activate (tree_view, path,
+- gtk_tree_view_get_column (tree_view, DIR_COLUMN),
+- user_data);
++ fs->last_selected = g_strdup (g_ptr_array_index (new_names, index));
++ gtk_file_selection_dir_activate (tree_view, path,
++ gtk_tree_view_get_column (tree_view, DIR_COLUMN),
++ user_data);
++ gtk_tree_path_free (path);
++ return;
++
+ }
+
+ gtk_tree_path_free (path);
diff --git a/packages/gtk+/gtk+_2.10.12.bb b/packages/gtk+/gtk+_2.10.12.bb
index 3756d85062..895d10e4f3 100644
--- a/packages/gtk+/gtk+_2.10.12.bb
+++ b/packages/gtk+/gtk+_2.10.12.bb
@@ -1,6 +1,6 @@
require gtk-2.10.inc
-PR = "r0"
+PR = "r1"
# disable per default - untested and not all patches included.
DEFAULT_PREFERENCE = "-1"
@@ -21,6 +21,7 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
file://single-click.patch;patch=1 \
file://spinbutton.patch;patch=1 \
file://gtk+-handhelds.patch;patch=1 \
+ file://filesel-fix-segfault.patch;patch=1 \
"
#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
diff --git a/packages/gtk+/gtk+_2.6.10.bb b/packages/gtk+/gtk+_2.6.10.bb
index ed2d9aea80..cab18db85c 100644
--- a/packages/gtk+/gtk+_2.6.10.bb
+++ b/packages/gtk+/gtk+_2.6.10.bb
@@ -5,7 +5,7 @@ SECTION = "libs"
LICENSE = "LGPL"
PRIORITY = "optional"
DEPENDS = "glib-2.0 pango atk jpeg libpng libxext libxcursor gtk-doc libgcrypt"
-PR = "r10"
+PR = "r11"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
file://help.patch;patch=1 \
@@ -33,7 +33,9 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
file://gtk.keynav.gtktextview.patch;patch=1;pnum=0 \
file://gtk.keynav.gtktreeview.patch;patch=1;pnum=0 \
file://gtk.keynav.gtkwidget.patch;patch=1;pnum=0 \
- file://gtk+-2.6.10-bg.patch;patch=1"
+ file://gtk+-2.6.10-bg.patch;patch=1 \
+ file://filesel-fix-segfault.patch;patch=1 \
+ "
inherit autotools pkgconfig