aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk+
diff options
context:
space:
mode:
authorShane Volpe <shanevolpe@gmail.com>2007-03-19 17:36:12 +0000
committerShane Volpe <shanevolpe@gmail.com>2007-03-19 17:36:12 +0000
commit5a7a2b17fe987077d43dadaaacf8070bc6b90ca6 (patch)
treed25b923ce560027c5f425293969ced0ebf76168e /packages/gtk+
parent56536dd4abeb5d4500ca9d2be1bb2b3bb5f5d452 (diff)
downloadopenembedded-5a7a2b17fe987077d43dadaaacf8070bc6b90ca6.tar.gz
gtk+-directfb-2.10.9 r0: Added directfb support to gtk+
modified gtk-2.10.inc to work with gtk+-directfb
Diffstat (limited to 'packages/gtk+')
-rw-r--r--packages/gtk+/gtk+-directfb_2.10.9.bb38
-rw-r--r--packages/gtk+/gtk-2.10.inc6
2 files changed, 42 insertions, 2 deletions
diff --git a/packages/gtk+/gtk+-directfb_2.10.9.bb b/packages/gtk+/gtk+-directfb_2.10.9.bb
new file mode 100644
index 0000000000..f8062f33f7
--- /dev/null
+++ b/packages/gtk+/gtk+-directfb_2.10.9.bb
@@ -0,0 +1,38 @@
+require gtk-2.10.inc
+
+PR = "r0"
+
+# disable per default - untested and not all patches included.
+DEFAULT_PREFERENCE = "-1"
+S = "${WORKDIR}/gtk+-${PV}"
+
+LDFLAGS_append += " -ldirectfb"
+CFLAGS_append += " -I${STAGING_INCDIR}/directfb"
+
+SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
+ file://no-xwc.patch;patch=1 \
+ file://automake-lossage.patch;patch=1 \
+ file://disable-tooltips.patch;patch=1 \
+ file://gtklabel-resize-patch;patch=1 \
+ file://menu-deactivate.patch;patch=1 \
+ file://xsettings.patch;patch=1 \
+ file://scroll-timings.patch;patch=1 \
+ file://small-gtkfilesel.patch;patch=1 \
+ file://migration.patch;patch=1;pnum=0 \
+ file://run-iconcache.patch;patch=1 \
+ file://hardcoded_libtool.patch;patch=1 \
+ file://no-demos.patch;patch=1 \
+ file://single-click.patch;patch=1 \
+ file://spinbutton.patch;patch=1 \
+ file://gtk+-handhelds.patch;patch=1 \
+ file://directfb_pixbuf_deprecated_fix.patch;patch=1 \
+# file://gtk-doc.patch;patch=1 \
+"
+EXTRA_OECONF =" \
+ --prefix=${STAGING_DIR} \
+ --with-gdktarget=directfb \
+ --without-x \
+ --without-libtiff \
+ "
+GDKTARGET="directfb"
+
diff --git a/packages/gtk+/gtk-2.10.inc b/packages/gtk+/gtk-2.10.inc
index 0a5860f01a..6f9035055b 100644
--- a/packages/gtk+/gtk-2.10.inc
+++ b/packages/gtk+/gtk-2.10.inc
@@ -33,11 +33,13 @@ RRECOMMENDS_${PN}_openzaurus = "glibc-gconv-iso8859-1 ttf-dejavu-sans gdk-pixbuf
EXTRA_OECONF = "--without-libtiff --disable-xkb --disable-glibtest --enable-display-migration"
+export GDKTARGET="x11"
+
LIBV = "2.10.0"
do_stage () {
- oe_libinstall -so -C gtk libgtk-x11-2.0 ${STAGING_LIBDIR}
- oe_libinstall -so -C gdk libgdk-x11-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gtk libgtk-$GDKTARGET-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gdk libgdk-$GDKTARGET-2.0 ${STAGING_LIBDIR}
oe_libinstall -so -C contrib/gdk-pixbuf-xlib libgdk_pixbuf_xlib-2.0 ${STAGING_LIBDIR}
oe_libinstall -so -C gdk-pixbuf libgdk_pixbuf-2.0 ${STAGING_LIBDIR}