aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk+
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-01-27 14:24:46 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-01-27 14:24:46 +0000
commitbccc702aacd2f82030baae66b3d80358820574f7 (patch)
tree37202ea568e53b369436ccf54e8e96959eabbcaa /packages/gtk+
parent33c52495f6a3defd15779b714cf05a7a1d5349f5 (diff)
downloadopenembedded-bccc702aacd2f82030baae66b3d80358820574f7.tar.gz
gtk+-2.6.10: patch GtkStatusBar .c|.h to work w/ glib >= 2.9.x
Diffstat (limited to 'packages/gtk+')
-rw-r--r--packages/gtk+/gtk+-2.6.10/compile-against-newer-glib.patch59
-rw-r--r--packages/gtk+/gtk+_2.6.10.bb5
2 files changed, 62 insertions, 2 deletions
diff --git a/packages/gtk+/gtk+-2.6.10/compile-against-newer-glib.patch b/packages/gtk+/gtk+-2.6.10/compile-against-newer-glib.patch
new file mode 100644
index 0000000000..c92070c7aa
--- /dev/null
+++ b/packages/gtk+/gtk+-2.6.10/compile-against-newer-glib.patch
@@ -0,0 +1,59 @@
+===================================================================
+RCS file: /cvs/gnome/gtk+/gtk/gtkstatusbar.h,v
+retrieving revision 1.17
+retrieving revision 1.17.2.1
+diff -u -r1.17 -r1.17.2.1
+--- gtkstatusbar.h 2005/03/20 07:01:22 1.17
++++ gtkstatusbar.h 2005/12/06 14:25:30 1.17.2.1
+@@ -65,7 +65,7 @@
+ {
+ GtkHBoxClass parent_class;
+
+- GMemChunk *messages_mem_chunk;
++ gpointer messages_mem_chunk;
+
+ void (*text_pushed) (GtkStatusbar *statusbar,
+ guint context_id,
+===================================================================
+RCS file: /cvs/gnome/gtk+/gtk/gtkstatusbar.c,v
+retrieving revision 1.56
+retrieving revision 1.56.2.1
+diff -u -r1.56 -r1.56.2.1
+--- gtkstatusbar.c 2005/07/21 19:10:48 1.56
++++ gtkstatusbar.c 2005/12/06 14:25:30 1.56.2.1
+@@ -302,7 +302,7 @@
+ g_return_val_if_fail (text != NULL, 0);
+
+ class = GTK_STATUSBAR_GET_CLASS (statusbar);
+- msg = g_chunk_new (GtkStatusbarMsg, class->messages_mem_chunk);
++ msg = g_chunk_new (GtkStatusbarMsg, (GMemChunk *)class->messages_mem_chunk);
+ msg->text = g_strdup (text);
+ msg->context_id = context_id;
+ msg->message_id = statusbar->seq_message_id++;
+@@ -343,7 +343,7 @@
+ statusbar->messages = g_slist_remove_link (statusbar->messages,
+ list);
+ g_free (msg->text);
+- g_mem_chunk_free (class->messages_mem_chunk, msg);
++ g_mem_chunk_free ((GMemChunk *)class->messages_mem_chunk, msg);
+ g_slist_free_1 (list);
+ break;
+ }
+@@ -394,7 +394,7 @@
+ class = GTK_STATUSBAR_GET_CLASS (statusbar);
+ statusbar->messages = g_slist_remove_link (statusbar->messages, list);
+ g_free (msg->text);
+- g_mem_chunk_free (class->messages_mem_chunk, msg);
++ g_mem_chunk_free ((GMemChunk *)class->messages_mem_chunk, msg);
+ g_slist_free_1 (list);
+
+ break;
+@@ -459,7 +459,7 @@
+
+ msg = list->data;
+ g_free (msg->text);
+- g_mem_chunk_free (class->messages_mem_chunk, msg);
++ g_mem_chunk_free ((GMemChunk *)class->messages_mem_chunk, msg);
+ }
+ g_slist_free (statusbar->messages);
+ statusbar->messages = NULL;
diff --git a/packages/gtk+/gtk+_2.6.10.bb b/packages/gtk+/gtk+_2.6.10.bb
index 8230515f3b..9af2dba568 100644
--- a/packages/gtk+/gtk+_2.6.10.bb
+++ b/packages/gtk+/gtk+_2.6.10.bb
@@ -5,7 +5,7 @@ SECTION = "libs"
LICENSE = "LGPL"
PRIORITY = "optional"
DEPENDS = "glib-2.0 pango atk jpeg libpng libxext libxcursor gtk-doc libgcrypt"
-PR = "r5"
+PR = "r6"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
file://help.patch;patch=1 \
@@ -23,7 +23,8 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
file://small-gtkfilesel.patch;patch=1 \
file://migration.patch;patch=1;pnum=0 \
file://single-click.patch;patch=1 \
- file://menu-styling.patch;patch=1"
+ file://menu-styling.patch;patch=1 \
+ file://compile-against-newer-glib.patch;patch=1"
inherit autotools pkgconfig