aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk+
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/gtk+
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/gtk+')
-rw-r--r--packages/gtk+/gtk+-1.2_1.2.10.bb57
-rw-r--r--packages/gtk+/gtk+-native-1.2_1.2.10.bb2
-rw-r--r--packages/gtk+/gtk+_2.2.4.bb76
-rw-r--r--packages/gtk+/gtk+_2.4.13.bb2
-rw-r--r--packages/gtk+/gtk+_2.4.4.bb86
-rw-r--r--packages/gtk+/gtk+_2.6.0.bb2
-rw-r--r--packages/gtk+/gtk+_2.6.1.bb2
-rw-r--r--packages/gtk+/gtk+_2.6.2.bb2
8 files changed, 224 insertions, 5 deletions
diff --git a/packages/gtk+/gtk+-1.2_1.2.10.bb b/packages/gtk+/gtk+-1.2_1.2.10.bb
index e69de29bb2..089f13e996 100644
--- a/packages/gtk+/gtk+-1.2_1.2.10.bb
+++ b/packages/gtk+/gtk+-1.2_1.2.10.bb
@@ -0,0 +1,57 @@
+LICENSE = LGPL
+DESCRIPTION = "GTK+1.2 is a deprecated library provided for running programs not yet converted to GTK+2.0"
+HOMEPAGE = "http://www.gtk.org"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Rob Taylor <robtaylor@fastmail.fm>"
+DEPENDS = "glib-1.2 jpeg libpng xext"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v1.2/gtk+-${PV}.tar.gz \
+ file://gtk+1.2-reconf-fix;patch=1 \
+ file://no-xwc;patch=1"
+S = "${WORKDIR}/gtk+-${PV}"
+
+inherit autotools pkgconfig flow-lossage
+
+do_configure_prepend() {
+ install -d m4
+ rm -f ltconfig libtool ltmain.sh aclocal.m4
+}
+
+FILES_${PN} += "${datadir}/themes"
+FILES_${PN}-dev += "${datadir}/gtk-1.2/include ${libdir}/gtk-1.2/include"
+
+
+EXTRA_OECONF = "--enable-debug=no --disable-glibtest --disable-xim"
+# --disable-cruft
+
+LIBV = "1.2.10"
+
+gtk_include = "fnmatch.h gtk.h gtkaccelgroup.h gtkaccellabel.h gtkadjustment.h gtkalignment.h gtkarg.h gtkarrow.h gtkaspectframe.h gtkbbox.h gtkbin.h gtkbindings.h gtkbox.h gtkbutton.h gtkcalendar.h gtkcheckbutton.h gtkcheckmenuitem.h gtkclist.h gtkcolorsel.h gtkcombo.h gtkcompat.h gtkcontainer.h gtkctree.h gtkcurve.h gtkdata.h gtkdebug.h gtkdialog.h gtkdnd.h gtkdrawingarea.h gtkeditable.h gtkentry.h gtkenums.h gtkeventbox.h gtkfeatures.h gtkfilesel.h gtkfixed.h gtkfontsel.h gtkframe.h gtkgamma.h gtkgc.h gtkhandlebox.h gtkhbbox.h gtkhbox.h gtkhpaned.h gtkhruler.h gtkhscale.h gtkhscrollbar.h gtkhseparator.h gtkimage.h gtkinputdialog.h gtkintl.h gtkinvisible.h gtkitem.h gtkitemfactory.h gtklabel.h gtklayout.h gtklist.h gtklistitem.h gtkmain.h gtkmarshal.h gtkmenu.h gtkmenubar.h gtkmenufactory.h gtkmenuitem.h gtkmenushell.h gtkmisc.h gtknotebook.h gtkobject.h gtkoptionmenu.h gtkpacker.h gtkpaned.h gtkpixmap.h gtkplug.h gtkpreview.h gtkprivate.h gtkprogress.h gtkprogressbar.h gtkradiobutton.h gtkradiomenuitem.h gtkrange.h gtkrc.h gtkruler.h gtkscale.h gtkscrollbar.h gtkscrolledwindow.h gtkselection.h gtkseparator.h gtksignal.h gtksocket.h gtkspinbutton.h gtkstatusbar.h gtkstyle.h gtktable.h gtktearoffmenuitem.h gtktext.h gtkthemes.h gtktipsquery.h gtktogglebutton.h gtktoolbar.h gtktooltips.h gtktree.h gtktreeitem.h gtktypebuiltins.h gtktypeutils.h gtkvbbox.h gtkvbox.h gtkviewport.h gtkvpaned.h gtkvruler.h gtkvscale.h gtkvscrollbar.h gtkvseparator.h gtkwidget.h gtkwindow.h makeenums.h stamp-gtkmarshal.h stamp-gtktypebuiltins.h"
+gdk_include = "MwmUtil.h gdk.h gdkcursors.h gdki18n.h gdkinput.h gdkinputcommon.h gdkinputgxi.h gdkinputnone.h gdkinputxfree.h gdkkeysyms.h gdkprivate.h gdkrgb.h gdktypes.h gdkx.h gxid_lib.h gxid_proto.h"
+
+do_stage () {
+ oe_libinstall -so -C gtk libgtk ${STAGING_LIBDIR}
+ oe_libinstall -so -C gdk libgdk ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gtk-1.2/gtk
+ for i in ${gtk_include}; do
+ install -m 0644 gtk/$i ${STAGING_INCDIR}/gtk-1.2/gtk/$i
+ done
+
+ mkdir -p ${STAGING_INCDIR}/gtk-1.2/gdk
+ for i in ${gdk_include}; do
+ install -m 0644 gdk/$i ${STAGING_INCDIR}/gtk-1.2/gdk/$i
+ done
+
+ mkdir -p ${STAGING_LIBDIR}/gtk-1.2/include
+
+ install -m 0644 gtk.m4 ${STAGING_DATADIR}/aclocal/
+ install -m 0755 gtk-config ${STAGING_BINDIR}
+}
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/gtk-1.2
+}
+
diff --git a/packages/gtk+/gtk+-native-1.2_1.2.10.bb b/packages/gtk+/gtk+-native-1.2_1.2.10.bb
index a51872de7b..3d37fda14d 100644
--- a/packages/gtk+/gtk+-native-1.2_1.2.10.bb
+++ b/packages/gtk+/gtk+-native-1.2_1.2.10.bb
@@ -52,6 +52,6 @@ do_stage () {
}
do_install_append () {
- install -d ${D}/etc/gtk-1.2
+ install -d ${D}/${sysconfdir}/gtk-1.2
}
diff --git a/packages/gtk+/gtk+_2.2.4.bb b/packages/gtk+/gtk+_2.2.4.bb
index e69de29bb2..3eff8adf27 100644
--- a/packages/gtk+/gtk+_2.2.4.bb
+++ b/packages/gtk+/gtk+_2.2.4.bb
@@ -0,0 +1,76 @@
+LICENSE = LGPL
+DESCRIPTION = "GTK+ is a multi-platform toolkit for creating graphical user interfaces. Offering a complete \
+set of widgets, GTK+ is suitable for projects ranging from small one-off projects to complete application suites."
+HOMEPAGE = "http://www.gtk.org"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Philip Blundell <pb@handhelds.org>"
+DEPENDS = "pango atk jpeg libpng xext"
+
+SRC_URI = "http://ftp.gnome.org/pub/gnome/sources/gtk+/2.2/gtk+-${PV}.tar.bz2 \
+ http://handhelds.org/packages/gtk-2.0/gtk+-2.2.4.diff.bz2;patch=1;pnum=1 \
+ file://automake-lossage.patch;patch=1;pnum=0 \
+ file://configure-lossage.patch;patch=1;pnum=0 \
+ file://no-demos.patch;patch=1 \
+ file://libtool-lossage.patch;patch=1;pnum=0 \
+ file://no-xwc.patch;patch=1;pnum=0 \
+ file://glib-2.0.m4 \
+ file://glib-gettext.m4"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ install -d m4
+ install ${WORKDIR}/glib-2.0.m4 m4/
+ install ${WORKDIR}/glib-gettext.m4 m4/
+}
+
+EXTRA_OECONF = "--without-libtiff --enable-debug=no --disable-cruft"
+
+LIBV = "2.2.0"
+
+gtk_include = "gtk.h gtkaccelgroup.h gtkaccellabel.h gtkaccelmap.h gtkaccessible.h gtkadjustment.h gtkalignment.h gtkarrow.h gtkaspectframe.h gtkbbox.h gtkbin.h gtkbindings.h gtkbox.h gtkbutton.h gtkcalendar.h gtkcelleditable.h gtkcellrenderer.h gtkcellrendererpixbuf.h gtkcellrenderertext.h gtkcellrenderertoggle.h gtkcheckbutton.h gtkcheckmenuitem.h gtkclipboard.h gtkclist.h gtkcolorsel.h gtkcolorseldialog.h gtkcombo.h gtkcontainer.h gtkctree.h gtkcurve.h gtkdebug.h gtkdialog.h gtkdnd.h gtkdrawingarea.h gtkeditable.h gtkentry.h gtkenums.h gtkeventbox.h gtkfilesel.h gtkfixed.h gtkfontsel.h gtkframe.h gtkgamma.h gtkgc.h gtkhandlebox.h gtkhbbox.h gtkhbox.h gtkhpaned.h gtkhruler.h gtkhscale.h gtkhscrollbar.h gtkhseparator.h gtkiconfactory.h gtkimage.h gtkimagemenuitem.h gtkimcontext.h gtkimcontextsimple.h gtkimmodule.h gtkimmulticontext.h gtkinputdialog.h gtkinvisible.h gtkitem.h gtkitemfactory.h gtklabel.h gtklayout.h gtklist.h gtklistitem.h gtkliststore.h gtkmain.h gtkmarshal.h gtkmenu.h gtkmenubar.h gtkmenuitem.h gtkmenushell.h gtkmessagedialog.h gtkmisc.h gtknotebook.h gtkobject.h gtkoldeditable.h gtkoptionmenu.h gtkpaned.h gtkpixmap.h gtkplug.h gtkpreview.h gtkprivate.h gtkprogress.h gtkprogressbar.h gtkradiobutton.h gtkradiomenuitem.h gtkrange.h gtkrc.h gtkruler.h gtkscale.h gtkscrollbar.h gtkscrolledwindow.h gtkselection.h gtkseparator.h gtkseparatormenuitem.h gtksettings.h gtksignal.h gtksizegroup.h gtksocket.h gtkspinbutton.h gtkstatusbar.h gtkstock.h gtkstyle.h gtktable.h gtktearoffmenuitem.h gtktext.h gtktextbuffer.h gtktextchild.h gtktextdisplay.h gtktextiter.h gtktextlayout.h gtktextmark.h gtktexttag.h gtktexttagtable.h gtktextview.h gtktipsquery.h gtktogglebutton.h gtktoolbar.h gtktooltips.h gtktree.h gtktreednd.h gtktreeitem.h gtktreemodel.h gtktreemodelsort.h gtktreeselection.h gtktreesortable.h gtktreestore.h gtktreeview.h gtktreeviewcolumn.h gtktypebuiltins.h gtktypeutils.h gtkvbbox.h gtkvbox.h gtkversion.h gtkviewport.h gtkvpaned.h gtkvruler.h gtkvscale.h gtkvscrollbar.h gtkvseparator.h gtkwidget.h gtkwindow.h"
+gdk_include = "gdk.h gdkcolor.h gdkcursor.h gdkdisplay.h gdkdisplaymanager.h gdkdnd.h gdkdrawable.h gdkenumtypes.h gdkevents.h gdkfont.h gdkgc.h gdki18n.h gdkimage.h gdkinput.h gdkkeys.h gdkkeysyms.h gdkpango.h gdkpixbuf.h gdkpixmap.h gdkprivate.h gdkproperty.h gdkregion.h gdkrgb.h gdkscreen.h gdkselection.h gdktypes.h gdkvisual.h gdkwindow.h x11/gdkx.h"
+gdk_pixbuf_include = "gdk-pixbuf-animation.h gdk-pixbuf-enum-types.h gdk-pixbuf-features.h gdk-pixbuf-io.h gdk-pixbuf-loader.h gdk-pixbuf-marshal.h gdk-pixbuf.h gdk-pixdata.h"
+
+do_stage () {
+ oe_libinstall -so -C gtk libgtk-x11-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gdk libgdk-x11-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C contrib/gdk-pixbuf-xlib libgdk_pixbuf_xlib-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gdk-pixbuf libgdk_pixbuf-2.0 ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gtk-2.0/gtk
+ for i in ${gtk_include}; do
+ install -m 0644 gtk/$i ${STAGING_INCDIR}/gtk-2.0/gtk/$i
+ done
+
+ mkdir -p ${STAGING_INCDIR}/gtk-2.0/gdk
+ for i in ${gdk_include}; do
+ install -m 0644 gdk/$i ${STAGING_INCDIR}/gtk-2.0/gdk/`basename $i`
+ done
+
+ mkdir -p ${STAGING_INCDIR}/gtk-2.0/gdk-pixbuf
+ for i in ${gdk_pixbuf_include}; do
+ install -m 0644 gdk-pixbuf/$i ${STAGING_INCDIR}/gtk-2.0/gdk-pixbuf/$i
+ done
+
+ mkdir -p ${STAGING_LIBDIR}/gtk-2.0/include
+ install -m 0644 gdk/gdkconfig.h ${STAGING_LIBDIR}/gtk-2.0/include/gdkconfig.h
+
+ install -m 0644 m4macros/gtk-2.0.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/gtk-2.0
+}
+
+python populate_packages_prepend () {
+ import os.path
+
+ gtk_libdir = bb.data.expand('${libdir}/gtk-2.0/${LIBV}', d)
+ loaders_root = os.path.join(gtk_libdir, 'loaders')
+ immodules_root = os.path.join(gtk_libdir, 'immodules')
+
+ do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s', 'gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders')
+ do_split_packages(d, immodules_root, '^im-(.*)\.so$', 'gtk-immodule-%s', 'GTK input module for %s', 'gtk-query-immodules > /etc/gtk-2.0/gtk.immodules')
+}
diff --git a/packages/gtk+/gtk+_2.4.13.bb b/packages/gtk+/gtk+_2.4.13.bb
index d8a0aa107b..968851d951 100644
--- a/packages/gtk+/gtk+_2.4.13.bb
+++ b/packages/gtk+/gtk+_2.4.13.bb
@@ -59,7 +59,7 @@ do_stage () {
}
do_install_append () {
- install -d ${D}/etc/gtk-2.0
+ install -d ${D}/${sysconfdir}/gtk-2.0
}
python populate_packages_prepend () {
diff --git a/packages/gtk+/gtk+_2.4.4.bb b/packages/gtk+/gtk+_2.4.4.bb
index e69de29bb2..7830c759c9 100644
--- a/packages/gtk+/gtk+_2.4.4.bb
+++ b/packages/gtk+/gtk+_2.4.4.bb
@@ -0,0 +1,86 @@
+LICENSE = LGPL
+DESCRIPTION = "GTK+ is a multi-platform toolkit for creating graphical user interfaces. Offering a complete \
+set of widgets, GTK+ is suitable for projects ranging from small one-off projects to complete application suites."
+HOMEPAGE = "http://www.gtk.org"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Philip Blundell <pb@handhelds.org>"
+DEPENDS = "glib-2.0 pango atk jpeg libpng xext libxcursor"
+PR = "r7"
+
+SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.4/gtk+-${PV}.tar.bz2 \
+ file://no-demos.patch;patch=1 \
+ file://no-xwc.patch;patch=1;pnum=0 \
+ file://automake-lossage.patch;patch=1 \
+ file://single-click.patch;patch=1 \
+ file://gtk+-handhelds.patch;patch=1 \
+ file://hardcoded_libtool.patch;patch=1 \
+ file://spinbutton.patch;patch=1 \
+ file://disable-tooltips.patch;patch=1 \
+ file://gtklabel-resize-patch;patch=1 \
+ file://gtk-doc.m4 \
+ file://small-gtkfilesel.patch;patch=1"
+
+inherit autotools pkgconfig flow-lossage
+
+do_configure_prepend() {
+ install -d m4
+ install ${WORKDIR}/gtk-doc.m4 m4/
+}
+
+FILES_${PN} += "${datadir}/themes"
+FILES_${PN}-dev += "${datadir}/gtk-2.0/include ${libdir}/gtk-2.0/include"
+
+EXTRA_OECONF = "--without-libtiff --enable-debug=no --disable-xkb --disable-glibtest"
+# --disable-cruft
+
+LIBV = "2.4.0"
+
+gtk_include = "gtk.h gtkaccelgroup.h gtkaccellabel.h gtkaccelmap.h gtkaccessible.h gtkadjustment.h gtkalignment.h gtkarrow.h gtkaspectframe.h gtkbbox.h gtkbin.h gtkbindings.h gtkbox.h gtkbutton.h gtkcalendar.h gtkcelleditable.h gtkcellrenderer.h gtkcellrendererpixbuf.h gtkcellrenderertext.h gtkcellrenderertoggle.h gtkcheckbutton.h gtkcheckmenuitem.h gtkclipboard.h gtkclist.h gtkcolorsel.h gtkcolorseldialog.h gtkcombo.h gtkcontainer.h gtkctree.h gtkcurve.h gtkdebug.h gtkdialog.h gtkdnd.h gtkdrawingarea.h gtkeditable.h gtkentry.h gtkenums.h gtkeventbox.h gtkfilesel.h gtkfixed.h gtkfontsel.h gtkframe.h gtkgamma.h gtkgc.h gtkhandlebox.h gtkhbbox.h gtkhbox.h gtkhpaned.h gtkhruler.h gtkhscale.h gtkhscrollbar.h gtkhseparator.h gtkiconfactory.h gtkimage.h gtkimagemenuitem.h gtkimcontext.h gtkimcontextsimple.h gtkimmodule.h gtkimmulticontext.h gtkinputdialog.h gtkinvisible.h gtkitem.h gtkitemfactory.h gtklabel.h gtklayout.h gtklist.h gtklistitem.h gtkliststore.h gtkmain.h gtkmarshal.h gtkmenu.h gtkmenubar.h gtkmenuitem.h gtkmenushell.h gtkmessagedialog.h gtkmisc.h gtknotebook.h gtkobject.h gtkoldeditable.h gtkoptionmenu.h gtkpaned.h gtkpixmap.h gtkplug.h gtkpreview.h gtkprivate.h gtkprogress.h gtkprogressbar.h gtkradiobutton.h gtkradiomenuitem.h gtkrange.h gtkrc.h gtkruler.h gtkscale.h gtkscrollbar.h gtkscrolledwindow.h gtkselection.h gtkseparator.h gtkseparatormenuitem.h gtksettings.h gtksignal.h gtksizegroup.h gtksocket.h gtkspinbutton.h gtkstatusbar.h gtkstock.h gtkstyle.h gtktable.h gtktearoffmenuitem.h gtktext.h gtktextbuffer.h gtktextchild.h gtktextdisplay.h gtktextiter.h gtktextlayout.h gtktextmark.h gtktexttag.h gtktexttagtable.h gtktextview.h gtktipsquery.h gtktogglebutton.h gtktoolbar.h gtktooltips.h gtktree.h gtktreednd.h gtktreeitem.h gtktreemodel.h gtktreemodelsort.h gtktreeselection.h gtktreesortable.h gtktreestore.h gtktreeview.h gtktreeviewcolumn.h gtktypebuiltins.h gtktypeutils.h gtkvbbox.h gtkvbox.h gtkversion.h gtkviewport.h gtkvpaned.h gtkvruler.h gtkvscale.h gtkvscrollbar.h gtkvseparator.h gtkwidget.h gtkwindow.h gtkentrycompletion.h gtkcomboboxentry.h gtkcolorbutton.h gtkcombobox.h gtkcelllayout.h gtkactiongroup.h gtkaction.h gtkexpander.h gtkfilechooserdialog.h gtkfilechooserwidget.h gtkfontbutton.h gtkicontheme.h gtkradioaction.h gtkradiotoolbutton.h gtkseparatortoolitem.h gtktoggleaction.h gtktoggletoolbutton.h gtktoolitem.h gtkuimanager.h gtktreemodelfilter.h gtktoolbutton.h gtkfilechooser.h gtkfilefilter.h gtkfilesystem.h"
+gdk_include = "gdk.h gdkcolor.h gdkcursor.h gdkdisplay.h gdkdisplaymanager.h gdkdnd.h gdkdrawable.h gdkenumtypes.h gdkevents.h gdkfont.h gdkgc.h gdki18n.h gdkimage.h gdkinput.h gdkkeys.h gdkkeysyms.h gdkpango.h gdkpixbuf.h gdkpixmap.h gdkprivate.h gdkproperty.h gdkregion.h gdkrgb.h gdkscreen.h gdkselection.h gdktypes.h gdkvisual.h gdkwindow.h x11/gdkx.h gdkspawn.h"
+gdk_pixbuf_include = "gdk-pixbuf-animation.h gdk-pixbuf-enum-types.h gdk-pixbuf-features.h gdk-pixbuf-io.h gdk-pixbuf-loader.h gdk-pixbuf-marshal.h gdk-pixbuf.h gdk-pixdata.h"
+
+do_stage () {
+ oe_libinstall -so -C gtk libgtk-x11-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gdk libgdk-x11-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C contrib/gdk-pixbuf-xlib libgdk_pixbuf_xlib-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gdk-pixbuf libgdk_pixbuf-2.0 ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gtk-2.0/gtk
+ for i in ${gtk_include}; do
+ install -m 0644 gtk/$i ${STAGING_INCDIR}/gtk-2.0/gtk/$i
+ done
+
+ mkdir -p ${STAGING_INCDIR}/gtk-2.0/gdk
+ for i in ${gdk_include}; do
+ install -m 0644 gdk/$i ${STAGING_INCDIR}/gtk-2.0/gdk/`basename $i`
+ done
+
+ mkdir -p ${STAGING_INCDIR}/gtk-2.0/gdk-pixbuf
+ for i in ${gdk_pixbuf_include}; do
+ install -m 0644 gdk-pixbuf/$i ${STAGING_INCDIR}/gtk-2.0/gdk-pixbuf/$i
+ done
+
+ mkdir -p ${STAGING_LIBDIR}/gtk-2.0/include
+ install -m 0644 gdk/gdkconfig.h ${STAGING_LIBDIR}/gtk-2.0/include/gdkconfig.h
+
+ install -m 0644 m4macros/gtk-2.0.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/gtk-2.0
+}
+
+python populate_packages_prepend () {
+ import os.path
+
+ gtk_libdir = bb.data.expand('${libdir}/gtk-2.0/${LIBV}', d)
+ loaders_root = os.path.join(gtk_libdir, 'loaders')
+ immodules_root = os.path.join(gtk_libdir, 'immodules')
+
+ do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s', 'gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders')
+ do_split_packages(d, immodules_root, '^im-(.*)\.so$', 'gtk-immodule-%s', 'GTK input module for %s', 'gtk-query-immodules > /etc/gtk-2.0/gtk.immodules')
+
+ if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
+ bb.data.setVar('PKG_${PN}', 'libgtk-2.0', d)
+}
diff --git a/packages/gtk+/gtk+_2.6.0.bb b/packages/gtk+/gtk+_2.6.0.bb
index e25a9b4b85..bc6c4e27d7 100644
--- a/packages/gtk+/gtk+_2.6.0.bb
+++ b/packages/gtk+/gtk+_2.6.0.bb
@@ -53,7 +53,7 @@ do_stage () {
}
do_install_append () {
- install -d ${D}/etc/gtk-2.0
+ install -d ${D}/${sysconfdir}/gtk-2.0
}
python populate_packages_prepend () {
diff --git a/packages/gtk+/gtk+_2.6.1.bb b/packages/gtk+/gtk+_2.6.1.bb
index 7e910768c1..20a6bf3d7a 100644
--- a/packages/gtk+/gtk+_2.6.1.bb
+++ b/packages/gtk+/gtk+_2.6.1.bb
@@ -54,7 +54,7 @@ do_stage () {
}
do_install_append () {
- install -d ${D}/etc/gtk-2.0
+ install -d ${D}/${sysconfdir}/gtk-2.0
}
python populate_packages_prepend () {
diff --git a/packages/gtk+/gtk+_2.6.2.bb b/packages/gtk+/gtk+_2.6.2.bb
index 32833a8aba..b84425217f 100644
--- a/packages/gtk+/gtk+_2.6.2.bb
+++ b/packages/gtk+/gtk+_2.6.2.bb
@@ -53,7 +53,7 @@ do_stage () {
}
do_install_append () {
- install -d ${D}/etc/gtk-2.0
+ install -d ${D}/${sysconfdir}/gtk-2.0
}
python populate_packages_prepend () {