aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk+
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-11-30 00:02:40 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-11-30 00:02:40 +0000
commit7f97e457b29051299b7dff3151c910ee714494d7 (patch)
treed7409fde81fb4f1b016d7165ac928a969c3d6067 /packages/gtk+
parent893391922a439ff9b2695d2e9e91c6060348bc41 (diff)
downloadopenembedded-7f97e457b29051299b7dff3151c910ee714494d7.tar.gz
gdk-pixbuf-2.10.14: Trimmed down, replace plugins by built-in.
Diffstat (limited to 'packages/gtk+')
-rw-r--r--packages/gtk+/gdk-pixbuf_2.10.14.bb41
1 files changed, 12 insertions, 29 deletions
diff --git a/packages/gtk+/gdk-pixbuf_2.10.14.bb b/packages/gtk+/gdk-pixbuf_2.10.14.bb
index 5b5482d1a8..ecd2d51d49 100644
--- a/packages/gtk+/gdk-pixbuf_2.10.14.bb
+++ b/packages/gtk+/gdk-pixbuf_2.10.14.bb
@@ -1,14 +1,14 @@
-DESCRIPTION = "GDK PixBuf is a pixelmap image support library from the GTK+ \
-multi-platform toolkit for creating graphical user interfaces."
+DESCRIPTION = "Stand-alone libpixbuf, a pixelmap image i/o library from the \
+GTK+ multi-platform toolkit for creating graphical user interfaces."
HOMEPAGE = "http://www.gtk.org/"
SECTION = "libs"
LICENSE = "LGPL"
PRIORITY = "optional"
-DEPENDS = "jpeg libpng gettext glib-2.0"
+DEPENDS = "libpng gettext glib-2.0"
+PR = "r1"
S = "${WORKDIR}/gtk+-${PV}"
FILESPATH = "${FILE_DIRNAME}/gdk-pixbuf-csource:${FILE_DIRNAME}/gtk+-${PV}:${FILE_DIRNAME}/files"
-PR = "r0"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
file://automake-lossage.patch;patch=1 \
@@ -35,12 +35,10 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
# file://treeview-checkbox-size.patch;patch=1;pnum=0 \
# file://cell-renderer-edit-focus.patch;patch=1;pnum=0 \
-# check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
-require gtk-fpu.inc
-EXTRA_OECONF += "${@get_gtk_fpu_setting(bb, d)}"
-
inherit autotools pkgconfig
+LIBV = "2.10.0"
+
FILES_${PN} = "${bindir}/gdk-pixbuf-query-loaders \
${bindir}/gtk-update-icon-cache \
${libdir}/lib*.so.*"
@@ -59,11 +57,15 @@ EXTRA_OECONF = "\
--without-x \
--with-gdktarget=linux-fb \
--without-libtiff \
- --with-libjpeg \
+ --without-libjpeg \
--with-libpng \
"
-LIBV = "2.10.0"
+EXTRA_OECONF += "--disable-modules --with-included-loaders=png,tga"
+
+# check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
+require gtk-fpu.inc
+EXTRA_OECONF += "${@get_gtk_fpu_setting(bb, d)}"
do_compile() {
cd gdk-pixbuf && oe_runmake
@@ -82,22 +84,3 @@ do_install() {
cd gdk-pixbuf && oe_runmake install DESTDIR=${D}
}
-postinst_prologue() {
-if [ "x$D" != "x" ]; then
- exit 1
-fi
-}
-
-PACKAGES_DYNAMIC = "gdk-pixbuf-loader-*"
-
-python populate_packages_prepend () {
- import os.path
-
- prologue = bb.data.getVar("postinst_prologue", d, 1)
-
- gtk_libdir = bb.data.expand('${libdir}/gtk-2.0/${LIBV}', d)
- loaders_root = os.path.join(gtk_libdir, 'loaders')
- do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s', prologue + 'gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders')
- if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
- bb.data.setVar('PKG_${PN}', 'libgtk-2.0', d)
-}