aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk-webcore/files
diff options
context:
space:
mode:
authorPhilippe De Swert <philippedeswert@scarlet.be>2007-04-01 22:05:02 +0000
committerPhilippe De Swert <philippedeswert@scarlet.be>2007-04-01 22:05:02 +0000
commit4037db271b9b183d88e10c675ee0efde0d73f93d (patch)
tree0e01189b6c160f377ac8ab104274bdb46e870379 /packages/gtk-webcore/files
parent476e3ca683aa352acf1bc4b4eb5affb7f437ef27 (diff)
downloadopenembedded-4037db271b9b183d88e10c675ee0efde0d73f93d.tar.gz
packages/gtk-webcore/osb-nrcore_svn
* Update svn build information because of major changes * added patch to correct build and silence gtk-webcore console output * packages/gtk-webcore/files/build_silence.patch
Diffstat (limited to 'packages/gtk-webcore/files')
-rw-r--r--packages/gtk-webcore/files/build_silence.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/gtk-webcore/files/build_silence.patch b/packages/gtk-webcore/files/build_silence.patch
new file mode 100644
index 0000000000..bcef3954ee
--- /dev/null
+++ b/packages/gtk-webcore/files/build_silence.patch
@@ -0,0 +1,32 @@
+Index: configure.in
+===================================================================
+--- configure.in (revision 46)
++++ configure.in (working copy)
+@@ -134,9 +134,9 @@
+ AC_SUBST(LIBCURL_LIBS) #needed by the osb-nrcore.pc.in
+
+
+-CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti -nostdinc++"
++CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti -nostdinc++ -DLOG_DISABLED"
+
+-CPPFLAGS="$CPPFLAGS -include \"\$(top_srcdir)/WebCorePrefix.h\" $PACKAGE_CFLAGS $X_CFLAGS $JSCORE_CFLAGS $DEFINES"
++CPPFLAGS="$CPPFLAGS -include \"\$(top_srcdir)/WebCorePrefix.h\" $PACKAGE_CFLAGS $X_CFLAGS $JSCORE_CFLAGS $DEFINES -DLOG_DISABLED"
+ LDFLAGS="$LDFLAGS $PACKAGE_LIBS $X_LIBS $JSCORE_LIBS \
+ -nodefaultlibs -lgcc -lc"
+
+Index: kwiq/KWQEvent.cpp
+===================================================================
+--- kwiq/KWQEvent.cpp (revision 46)
++++ kwiq/KWQEvent.cpp (working copy)
+@@ -759,10 +759,10 @@
+ #if 0
+ if (state & GDK_MOD1_MASK)
+ qstate |= Qt::AltButton;
+-#endif
+
+ if (state & GDK_META_MASK)
+ qstate |= Qt::MetaButton;
++#endif
+
+ if (isKeypadEvent(event))
+ qstate |= Qt::Keypad;