aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk-webcore/files
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/gtk-webcore/files
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/gtk-webcore/files')
-rw-r--r--packages/gtk-webcore/files/.mtn2git_empty0
-rw-r--r--packages/gtk-webcore/files/gdk-colorspace.diff25
-rw-r--r--packages/gtk-webcore/files/libm.patch13
-rw-r--r--packages/gtk-webcore/files/no-pedantic.patch11
4 files changed, 49 insertions, 0 deletions
diff --git a/packages/gtk-webcore/files/.mtn2git_empty b/packages/gtk-webcore/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gtk-webcore/files/.mtn2git_empty
diff --git a/packages/gtk-webcore/files/gdk-colorspace.diff b/packages/gtk-webcore/files/gdk-colorspace.diff
index e69de29bb2..f225bc937d 100644
--- a/packages/gtk-webcore/files/gdk-colorspace.diff
+++ b/packages/gtk-webcore/files/gdk-colorspace.diff
@@ -0,0 +1,25 @@
+Index: src/ImageRenderer.cpp
+===================================================================
+RCS file: /cvsroot/gtk-webcore/NRCit/src/ImageRenderer.cpp,v
+retrieving revision 1.1.1.1
+diff -u -r1.1.1.1 ImageRenderer.cpp
+--- NRCit.orig/src/ImageRenderer.cpp 16 Feb 2005 09:33:16 -0000 1.1.1.1
++++ NRCit/src/ImageRenderer.cpp 27 May 2005 23:36:28 -0000
+@@ -297,7 +297,7 @@
+ wantedSize.height,
+ GDK_INTERP_BILINEAR);
+
+- gdk_pixbuf_render_pixmap_and_mask(scaledbuf, &pixmap, &alpha, 100);
++ gdk_pixbuf_render_pixmap_and_mask_for_colormap(scaledbuf,gdk_colormap_get_system(), &pixmap, &alpha, 100);
+
+ buf = scaledbuf;
+ if (iter) {
+@@ -312,7 +312,7 @@
+ } else {
+
+ //correct size
+- gdk_pixbuf_render_pixmap_and_mask(buf, &pixmap, &alpha, 100);
++ gdk_pixbuf_render_pixmap_and_mask_for_colormap(buf, gdk_colormap_get_system(),&pixmap, &alpha, 100);
+ }
+
+ assert(gdk_pixbuf_get_has_alpha(buf) == (alpha != NULL));
diff --git a/packages/gtk-webcore/files/libm.patch b/packages/gtk-webcore/files/libm.patch
index e69de29bb2..b0c0cc6af2 100644
--- a/packages/gtk-webcore/files/libm.patch
+++ b/packages/gtk-webcore/files/libm.patch
@@ -0,0 +1,13 @@
+Index: osb-jscore-0.5.0/configure.in
+===================================================================
+--- osb-jscore-0.5.0.orig/configure.in 2004-10-18 11:39:43.000000000 -0400
++++ osb-jscore-0.5.0/configure.in 2005-02-02 17:36:36.551550088 -0500
+@@ -18,6 +18,8 @@
+ AC_CHECK_HEADERS(string.h strings.h float.h)
+
+
++# isnan & friends generally come from libm, so link to it if its available
++AC_CHECK_LIB(m, sin)
+
+ AC_CHECK_FUNCS(isnan,[
+ AC_DEFINE(HAVE_FUNC_ISNAN,[],[Define to 1 if you have isnan function.])
diff --git a/packages/gtk-webcore/files/no-pedantic.patch b/packages/gtk-webcore/files/no-pedantic.patch
index e69de29bb2..faabbbf15f 100644
--- a/packages/gtk-webcore/files/no-pedantic.patch
+++ b/packages/gtk-webcore/files/no-pedantic.patch
@@ -0,0 +1,11 @@
+--- osb-browser-0.5.0.orig/configure.in 2004-10-18 17:40:28.000000000 +0200
++++ osb-browser-0.5.0/configure.in 2004-10-24 01:23:26.000000000 +0200
+@@ -54,7 +54,7 @@
+ if test "x$GCC" = "xyes"; then
+ case " $CFLAGS " in
+ *[\ \ ]-Wall[\ \ ]*) ;;
+- *) CFLAGS="$CFLAGS -Wall -Werror -ansi -pedantic" ;;
++ *) CFLAGS="$CFLAGS -Wall -Werror -ansi" ;;
+ esac
+ fi
+ changequote([,])dnl