aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hostap
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2005-08-03 22:22:03 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-03 22:22:03 +0000
commita40e5dff63a60c40c47c7155650440a3b37e999b (patch)
tree123d401670d3e55e7e2307caaacf2797f6c16c3a /packages/hostap
parentfaa3ea865bbec5433bcc950fae04d7554de7ba33 (diff)
downloadopenembedded-a40e5dff63a60c40c47c7155650440a3b37e999b.tar.gz
hostap: Fix this to work with the latest kernels
Diffstat (limited to 'packages/hostap')
-rw-r--r--packages/hostap/hostap-modules-0.3.7/add_event.patch28
-rw-r--r--packages/hostap/hostap-modules_0.3.7.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/packages/hostap/hostap-modules-0.3.7/add_event.patch b/packages/hostap/hostap-modules-0.3.7/add_event.patch
new file mode 100644
index 0000000000..d5f2a10e86
--- /dev/null
+++ b/packages/hostap/hostap-modules-0.3.7/add_event.patch
@@ -0,0 +1,28 @@
+Index: hostap-driver-0.3.7/driver/modules/hostap_cs.c
+===================================================================
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-08-03 17:05:53.000000000 +0100
++++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-08-03 17:07:59.000000000 +0100
+@@ -526,11 +526,13 @@
+ dev_list = link;
+ client_reg.dev_info = &dev_info;
+ client_reg.Attributes = INFO_IO_CLIENT;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13))
+ client_reg.EventMask = CS_EVENT_CARD_INSERTION |
+ CS_EVENT_CARD_REMOVAL |
+ CS_EVENT_RESET_PHYSICAL | CS_EVENT_CARD_RESET |
+ CS_EVENT_PM_SUSPEND | CS_EVENT_PM_RESUME;
+ client_reg.event_handler = &prism2_event;
++#endif
+ client_reg.Version = 0x0210;
+ client_reg.event_callback_args.client_data = link;
+ ret = pcmcia_register_client(&link->handle, &client_reg);
+@@ -913,6 +915,9 @@
+ .name = "hostap_cs",
+ },
+ .attach = prism2_attach,
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++ .event = prism2_event,
++#endif
+ .detach = prism2_detach,
+ .owner = THIS_MODULE,
+ };
diff --git a/packages/hostap/hostap-modules_0.3.7.bb b/packages/hostap/hostap-modules_0.3.7.bb
index 81091bf2d8..7e9ea6e13c 100644
--- a/packages/hostap/hostap-modules_0.3.7.bb
+++ b/packages/hostap/hostap-modules_0.3.7.bb
@@ -8,6 +8,7 @@ PR = "r2"
SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
file://hostap_cs.conf \
file://Makefile.patch;patch=1 \
+ file://add_event.patch;patch=1 \
file://hostap-utsname.patch;patch=1"
SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"