aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hostap
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2005-07-25 13:12:26 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-25 13:12:26 +0000
commit17398449fd8a30f93718e21e608181c0db8b0df3 (patch)
treecff647188a5acafb0d0d8a0d1fe3cb6da7b9e1ab /packages/hostap
parent3e833680c4ddc927d37efc23150645af35187903 (diff)
downloadopenembedded-17398449fd8a30f93718e21e608181c0db8b0df3.tar.gz
hostap-modules: kernel 2.6.13-rc3-mm1 has made changes that make the
KERNEL_VERSION macro not available to hostap without explicitly including the utsname.h file. This patch should be harmless for other kernel versions but includes the needed file if using 2.6.13-rc3-mm1
Diffstat (limited to 'packages/hostap')
-rw-r--r--packages/hostap/hostap-modules-0.3.7/hostap-utsname.patch77
-rw-r--r--packages/hostap/hostap-modules_0.3.7.bb5
2 files changed, 80 insertions, 2 deletions
diff --git a/packages/hostap/hostap-modules-0.3.7/hostap-utsname.patch b/packages/hostap/hostap-modules-0.3.7/hostap-utsname.patch
new file mode 100644
index 0000000000..c29cc8d2c9
--- /dev/null
+++ b/packages/hostap/hostap-modules-0.3.7/hostap-utsname.patch
@@ -0,0 +1,77 @@
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap.c hostap-driver-0.3.7/driver/modules/hostap.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap.c 2005-07-25 09:14:01.995965088 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap.c 2005-07-25 09:13:22.301999488 +0000
+@@ -25,6 +25,7 @@
+ #include <linux/if_arp.h>
+ #include <linux/delay.h>
+ #include <linux/random.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:13:22.302999336 +0000
+@@ -19,6 +19,7 @@
+ #include <linux/netdevice.h>
+ #include <linux/if_ether.h>
+ #include <linux/if_arp.h>
++#include <linux/utsname.h>
+ #include <asm/string.h>
+
+ #include "hostap_crypt.h"
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:13:22.302999336 +0000
+@@ -19,6 +19,7 @@
+ #include <linux/netdevice.h>
+ #include <linux/if_ether.h>
+ #include <linux/if_arp.h>
++#include <linux/utsname.h>
+ #include <asm/string.h>
+
+ #include "hostap_crypt.h"
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c 2005-07-25 09:13:22.302999336 +0000
+@@ -15,6 +15,7 @@
+ #include <linux/init.h>
+ #include <linux/slab.h>
+ #include <linux/random.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c hostap-driver-0.3.7/driver/modules/hostap_cs.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-07-25 09:13:22.302999336 +0000
+@@ -12,6 +12,7 @@
+ #include <linux/timer.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c hostap-driver-0.3.7/driver/modules/hostap_pci.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_pci.c 2005-07-25 09:13:22.303999184 +0000
+@@ -11,6 +11,7 @@
+ #include <linux/if.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c hostap-driver-0.3.7/driver/modules/hostap_plx.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_plx.c 2005-07-25 09:13:22.303999184 +0000
+@@ -14,6 +14,7 @@
+ #include <linux/if.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
diff --git a/packages/hostap/hostap-modules_0.3.7.bb b/packages/hostap/hostap-modules_0.3.7.bb
index 4597451369..81091bf2d8 100644
--- a/packages/hostap/hostap-modules_0.3.7.bb
+++ b/packages/hostap/hostap-modules_0.3.7.bb
@@ -3,11 +3,12 @@ SECTION = "kernel/modules"
PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
file://hostap_cs.conf \
- file://Makefile.patch;patch=1"
+ file://Makefile.patch;patch=1 \
+ file://hostap-utsname.patch;patch=1"
SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 "