aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hostap
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-08-25 16:59:09 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-25 16:59:09 +0000
commit33a576ad0908d5e3378beeea66a436ca98f17399 (patch)
tree6e9b9d80c1cb031b2449e634cef3285bb135cd87 /packages/hostap
parent24ab336bfed235fc4c47b194bd697dd38465d267 (diff)
downloadopenembedded-33a576ad0908d5e3378beeea66a436ca98f17399.tar.gz
added hostap-daemon 0.4.4 (development version)
Diffstat (limited to 'packages/hostap')
-rw-r--r--packages/hostap/hostap-daemon-0.4.4/.mtn2git_empty0
-rw-r--r--packages/hostap/hostap-daemon-0.4.4/defconfig66
-rw-r--r--packages/hostap/hostap-daemon-0.4.4/init39
-rw-r--r--packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff12
-rw-r--r--packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff26
-rw-r--r--packages/hostap/hostap-daemon-0.4.4/mtx-1/.mtn2git_empty0
-rw-r--r--packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig66
-rw-r--r--packages/hostap/hostap-daemon_0.4.4.bb31
8 files changed, 240 insertions, 0 deletions
diff --git a/packages/hostap/hostap-daemon-0.4.4/.mtn2git_empty b/packages/hostap/hostap-daemon-0.4.4/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.4.4/.mtn2git_empty
diff --git a/packages/hostap/hostap-daemon-0.4.4/defconfig b/packages/hostap/hostap-daemon-0.4.4/defconfig
new file mode 100644
index 0000000000..d0e22f2586
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.4.4/defconfig
@@ -0,0 +1,66 @@
+# Example hostapd build time configuration
+#
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cass, these lines should use += in order not
+# to override previous values of the variables.
+
+# Driver interface for Host AP driver
+CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for wired authenticator
+CONFIG_DRIVER_WIRED=y
+
+# Driver interface for madwifi driver
+#CONFIG_DRIVER_MADWIFI=y
+#CFLAGS += -I../head # change to reflect local setup; directory for madwifi src
+
+# Driver interface for Prism54 driver
+CONFIG_DRIVER_PRISM54=y
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+#CONFIG_DRIVER_BSD=y
+#CFLAGS += -I/usr/local/include
+#LIBS += -L/usr/local/lib
+
+# IEEE 802.11F/IAPP
+CONFIG_IAPP=y
+
+# WPA2/IEEE 802.11i RSN pre-authentication
+CONFIG_RSN_PREAUTH=y
+
+# Integrated EAP authenticator
+CONFIG_EAP=y
+
+# EAP-MD5 for the integrated EAP authenticator
+CONFIG_EAP_MD5=y
+
+# EAP-TLS for the integrated EAP authenticator
+CONFIG_EAP_TLS=y
+
+# EAP-MSCHAPv2 for the integrated EAP authenticator
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-PEAP for the integrated EAP authenticator
+CONFIG_EAP_PEAP=y
+
+# EAP-GTC for the integrated EAP authenticator
+CONFIG_EAP_GTC=y
+
+# EAP-TTLS for the integrated EAP authenticator
+CONFIG_EAP_TTLS=y
+
+# EAP-SIM for the integrated EAP authenticator
+#CONFIG_EAP_SIM=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# RADIUS authentication server. This provides access to the integrated EAP
+# authenticator from external hosts using RADIUS.
+CONFIG_RADIUS_SERVER=y
diff --git a/packages/hostap/hostap-daemon-0.4.4/init b/packages/hostap/hostap-daemon-0.4.4/init
new file mode 100644
index 0000000000..b0736c0baa
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.4.4/init
@@ -0,0 +1,39 @@
+#!/bin/sh
+DAEMON=/usr/sbin/hostapd
+NAME=httpd
+DESC="HOSTAP Daemon"
+ARGS="/etc/hostapd.conf"
+
+test -f $DAEMON || exit 0
+
+set -e
+
+case "$1" in
+ start)
+ echo -n "starting $DESC: $NAME... "
+ start-stop-daemon -S -b -n $NAME -a $DAEMON -- $ARGS
+ echo "done."
+ ;;
+ stop)
+ echo -n "stopping $DESC: $NAME... "
+ start-stop-daemon -K -n $NAME
+ echo "done."
+ ;;
+ restart)
+ echo "restarting $DESC: $NAME... "
+ $0 stop
+ $0 start
+ echo "done."
+ ;;
+ reload)
+ echo -n "reloading $DESC: $NAME... "
+ killall -HUP $(basename ${DAEMON})
+ echo "done."
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff b/packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff
new file mode 100644
index 0000000000..d9dab26a15
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff
@@ -0,0 +1,12 @@
+--- driver_madwifi.c.orig 2005-03-18 15:12:53.392793216 +0100
++++ driver_madwifi.c 2005-03-18 15:13:09.246383104 +0100
+@@ -21,7 +21,8 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+
+-#include <include/compat.h>
++#include <net80211/compat.h>
++#include <net80211/_ieee80211.h>
+ #include <net80211/ieee80211.h>
+ #include <net80211/ieee80211_crypto.h>
+ #include <net80211/ieee80211_ioctl.h>
diff --git a/packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff b/packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff
new file mode 100644
index 0000000000..25d2ca34bb
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff
@@ -0,0 +1,26 @@
+--- Makefile.orig 2005-03-18 14:34:27.274376504 +0100
++++ Makefile 2005-03-18 14:35:56.609795456 +0100
+@@ -1,7 +1,9 @@
+-CC=gcc
++CC?=gcc
+ DIR_WPA_SUPPLICANT=.
+ DIR_HOSTAP=.
+
++TARGET_PREFIX ?= /usr/local/bin/
++
+ ifndef CFLAGS
+ CFLAGS = -MMD -O2 -Wall -g
+ endif
+@@ -170,10 +172,10 @@
+ fi
+
+ install: all
+- for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
++ for i in $(ALL); do cp $$i $(TARGET_PREFIX)/$$i; done
+
+ hostapd: $(OBJS)
+- $(CC) -o hostapd $(OBJS) $(LIBS)
++ $(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS)
+
+ driver_conf.c: Makefile .config
+ rm -f driver_conf.c
diff --git a/packages/hostap/hostap-daemon-0.4.4/mtx-1/.mtn2git_empty b/packages/hostap/hostap-daemon-0.4.4/mtx-1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.4.4/mtx-1/.mtn2git_empty
diff --git a/packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig b/packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig
new file mode 100644
index 0000000000..8c3065c3b9
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig
@@ -0,0 +1,66 @@
+# Example hostapd build time configuration
+#
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cass, these lines should use += in order not
+# to override previous values of the variables.
+
+# Driver interface for Host AP driver
+CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for wired authenticator
+CONFIG_DRIVER_WIRED=y
+
+# Driver interface for madwifi driver
+CONFIG_DRIVER_MADWIFI=y
+#CFLAGS += -I../head # change to reflect local setup; directory for madwifi src
+
+# Driver interface for Prism54 driver
+CONFIG_DRIVER_PRISM54=y
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+#CONFIG_DRIVER_BSD=y
+#CFLAGS += -I/usr/local/include
+#LIBS += -L/usr/local/lib
+
+# IEEE 802.11F/IAPP
+CONFIG_IAPP=y
+
+# WPA2/IEEE 802.11i RSN pre-authentication
+CONFIG_RSN_PREAUTH=y
+
+# Integrated EAP authenticator
+CONFIG_EAP=y
+
+# EAP-MD5 for the integrated EAP authenticator
+CONFIG_EAP_MD5=y
+
+# EAP-TLS for the integrated EAP authenticator
+CONFIG_EAP_TLS=y
+
+# EAP-MSCHAPv2 for the integrated EAP authenticator
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-PEAP for the integrated EAP authenticator
+CONFIG_EAP_PEAP=y
+
+# EAP-GTC for the integrated EAP authenticator
+CONFIG_EAP_GTC=y
+
+# EAP-TTLS for the integrated EAP authenticator
+CONFIG_EAP_TTLS=y
+
+# EAP-SIM for the integrated EAP authenticator
+#CONFIG_EAP_SIM=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# RADIUS authentication server. This provides access to the integrated EAP
+# authenticator from external hosts using RADIUS.
+CONFIG_RADIUS_SERVER=y
diff --git a/packages/hostap/hostap-daemon_0.4.4.bb b/packages/hostap/hostap-daemon_0.4.4.bb
new file mode 100644
index 0000000000..9363a10d91
--- /dev/null
+++ b/packages/hostap/hostap-daemon_0.4.4.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "hostap-modules (${PV}) hostap-utils (${PV})"
+DEPENDS_mtx-1_append = "madwifi-modules"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
+ file://makefile-cross.diff;patch=1;pnum=0 \
+ file://madwifi-bsd-fix.diff;patch=1;pnum=0 \
+ file://defconfig \
+ file://init"
+
+S = "${WORKDIR}/hostapd-${PV}"
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}
+
+do_compile() {
+ CFLAGS='${CFLAGS}' CC='${CC}' make
+}
+
+do_install() {
+ install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
+ make TARGET_PREFIX=${D}${sbindir} install
+ install -m 0644 hostapd.conf ${D}${sysconfdir}
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
+}