aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hostap
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-08-05 12:44:47 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-05 12:44:47 +0000
commit3801493a4c9a2f09bed30fad0b1209bd50f5c642 (patch)
treefd9b774df16b2195ae821752b6be98f7c9f7c2d8 /packages/hostap
parent89914292284234eee244aefacbd936ac0d90a1cd (diff)
downloadopenembedded-3801493a4c9a2f09bed30fad0b1209bd50f5c642.tar.gz
added hostap-modules 0.3.9
Diffstat (limited to 'packages/hostap')
-rw-r--r--packages/hostap/hostap-modules-0.3.9/.mtn2git_empty0
-rw-r--r--packages/hostap/hostap-modules-0.3.9/Makefile.patch11
-rw-r--r--packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch77
-rw-r--r--packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch11
-rw-r--r--packages/hostap/hostap-modules-0.3.9/mtx_compat.diff20
-rw-r--r--packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff81
-rw-r--r--packages/hostap/hostap-modules_0.3.9.bb44
7 files changed, 244 insertions, 0 deletions
diff --git a/packages/hostap/hostap-modules-0.3.9/.mtn2git_empty b/packages/hostap/hostap-modules-0.3.9/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hostap/hostap-modules-0.3.9/.mtn2git_empty
diff --git a/packages/hostap/hostap-modules-0.3.9/Makefile.patch b/packages/hostap/hostap-modules-0.3.9/Makefile.patch
new file mode 100644
index 0000000000..2fc5e9ed4b
--- /dev/null
+++ b/packages/hostap/hostap-modules-0.3.9/Makefile.patch
@@ -0,0 +1,11 @@
+--- hostap-driver-0.2.4/Makefile.old 2004-07-31 10:35:50.000000000 +0100
++++ hostap-driver-0.2.4/Makefile 2004-07-31 10:35:56.000000000 +0100
+@@ -51,7 +51,7 @@
+
+ VERFILE := $(KERNEL_PATH)/include/linux/version.h
+ KERNELRELEASE := $(shell if [ -r $(VERFILE) ]; \
+- then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -1 | xargs echo; \
++ then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -n 1 | xargs echo; \
+ else uname -r; fi)
+ KERNELVER := $(shell echo "$(KERNELRELEASE)" | \
+ sed "s/\([0-9]*\.[0-9]*\.[0-9]*\).*/\1/")
diff --git a/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch b/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch
new file mode 100644
index 0000000000..c29cc8d2c9
--- /dev/null
+++ b/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch
@@ -0,0 +1,77 @@
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap.c hostap-driver-0.3.7/driver/modules/hostap.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap.c 2005-07-25 09:14:01.995965088 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap.c 2005-07-25 09:13:22.301999488 +0000
+@@ -25,6 +25,7 @@
+ #include <linux/if_arp.h>
+ #include <linux/delay.h>
+ #include <linux/random.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:13:22.302999336 +0000
+@@ -19,6 +19,7 @@
+ #include <linux/netdevice.h>
+ #include <linux/if_ether.h>
+ #include <linux/if_arp.h>
++#include <linux/utsname.h>
+ #include <asm/string.h>
+
+ #include "hostap_crypt.h"
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:13:22.302999336 +0000
+@@ -19,6 +19,7 @@
+ #include <linux/netdevice.h>
+ #include <linux/if_ether.h>
+ #include <linux/if_arp.h>
++#include <linux/utsname.h>
+ #include <asm/string.h>
+
+ #include "hostap_crypt.h"
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c 2005-07-25 09:13:22.302999336 +0000
+@@ -15,6 +15,7 @@
+ #include <linux/init.h>
+ #include <linux/slab.h>
+ #include <linux/random.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c hostap-driver-0.3.7/driver/modules/hostap_cs.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-07-25 09:13:22.302999336 +0000
+@@ -12,6 +12,7 @@
+ #include <linux/timer.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c hostap-driver-0.3.7/driver/modules/hostap_pci.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_pci.c 2005-07-25 09:13:22.303999184 +0000
+@@ -11,6 +11,7 @@
+ #include <linux/if.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c hostap-driver-0.3.7/driver/modules/hostap_plx.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_plx.c 2005-07-25 09:13:22.303999184 +0000
+@@ -14,6 +14,7 @@
+ #include <linux/if.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
diff --git a/packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch b/packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch
new file mode 100644
index 0000000000..b139ef38f1
--- /dev/null
+++ b/packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch
@@ -0,0 +1,11 @@
+--- hostap-driver-0.3.7/driver/modules/hostap_compat.h.old 2005-04-17 09:12:38.304421464 +0100
++++ hostap-driver-0.3.7/driver/modules/hostap_compat.h 2005-04-17 09:13:04.413452288 +0100
+@@ -5,7 +5,7 @@
+ #define NEW_MODULE_CODE
+ #endif
+
+-#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44)) && !defined(CONFIG_IPAQ_HANDHELD)
+
+ #define HOSTAP_QUEUE struct tq_struct
+
diff --git a/packages/hostap/hostap-modules-0.3.9/mtx_compat.diff b/packages/hostap/hostap-modules-0.3.9/mtx_compat.diff
new file mode 100644
index 0000000000..c2d6662d69
--- /dev/null
+++ b/packages/hostap/hostap-modules-0.3.9/mtx_compat.diff
@@ -0,0 +1,20 @@
+--- driver/modules/hostap_compat.h.orig 2004-08-09 16:16:48.359929856 +0200
++++ driver/modules/hostap_compat.h 2004-08-09 16:17:12.383277752 +0200
+@@ -13,7 +13,7 @@
+ MOD_INC_USE_COUNT; \
+ if (schedule_task((q)) == 0) \
+ MOD_DEC_USE_COUNT;
+-
++/*
+ static inline void flush_scheduled_work(void)
+ {
+ flush_scheduled_tasks();
+@@ -27,7 +27,7 @@
+ tq->routine = routine;
+ tq->data = data;
+ }
+-
++*/
+ #else /* kernel < 2.5.44 */
+
+ #define HOSTAP_QUEUE struct work_struct
diff --git a/packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff b/packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff
new file mode 100644
index 0000000000..e979b72d93
--- /dev/null
+++ b/packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff
@@ -0,0 +1,81 @@
+--- driver/modules/hostap_pci.c.orig 2004-11-30 06:41:48.000000000 +0100
++++ driver/modules/hostap_pci.c 2005-01-17 19:47:33.710400496 +0100
+@@ -50,6 +50,13 @@
+ };
+
+
++#define DEFERRED_IRQ_INITIALIZATION
++
++#ifdef DEFERRED_IRQ_INITIALIZATION
++struct net_device *devb[MAX_PARM_DEVICES];
++#endif
++
++
+ #ifdef PRISM2_IO_DEBUG
+
+ static inline void hfa384x_outb_debug(struct net_device *dev, int a, u8 v)
+@@ -280,6 +287,10 @@
+
+ pci_set_drvdata(pdev, dev);
+
++#ifdef DEFERRED_IRQ_INITIALIZATION
++ printk("%s: deferred initialization of IRQs\n", dev_info);
++ devb[cards_found-1] = dev;
++#else
+ if (request_irq(dev->irq, prism2_interrupt, SA_SHIRQ, dev->name,
+ dev)) {
+ printk(KERN_WARNING "%s: request_irq failed\n", dev->name);
+@@ -295,7 +306,7 @@
+
+ printk(KERN_INFO "%s: Intersil Prism2.5 PCI: "
+ "mem=0x%lx, irq=%d\n", dev->name, phymem, dev->irq);
+-
++#endif
+ return hostap_hw_ready(dev);
+
+ fail:
+@@ -399,18 +410,43 @@
+ };
+
+
++#ifdef DEFERRED_IRQ_INITIALIZATION
++static void deferred_init(int num_devices)
++{
++ int n;
++ for (n=0; n<num_devices && n<MAX_PARM_DEVICES; n++)
++ {
++ if (request_irq(devb[n]->irq, prism2_interrupt, SA_SHIRQ, devb[n]->name,
++ devb[n])) {
++ printk(KERN_WARNING "%s: request_irq failed\n", devb[n]->name);
++ }
++ if (prism2_hw_config(devb[n], 1)) {
++ printk(KERN_DEBUG "%s: hardware initialization failed\n", devb[n]->name)
++;
++ }
++ printk(KERN_INFO "%s: Intersil Prism2.5 PCI: irq=%d\n", devb[n]->name, devb[n]->
++irq);
++ }
++}
++#endif
++
+ static int __init init_prism2_pci(void)
+ {
+ printk(KERN_INFO "%s: %s\n", dev_info, version);
+
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,10))
+- if (pci_register_driver(&prism2_pci_drv_id) <= 0) {
++ int n;
++ if ((n=pci_register_driver(&prism2_pci_drv_id)) <= 0) {
+ printk("hostap_pci: No devices found, driver not "
+ "installed.\n");
+ pci_unregister_driver(&prism2_pci_drv_id);
+ return -ENODEV;
+ }
+
++#ifdef DEFERRED_IRQ_INITIALIZATION
++ deferred_init(n);
++#endif
++
+ return 0;
+ #else
+ return pci_register_driver(&prism2_pci_drv_id);
diff --git a/packages/hostap/hostap-modules_0.3.9.bb b/packages/hostap/hostap-modules_0.3.9.bb
new file mode 100644
index 0000000000..81091bf2d8
--- /dev/null
+++ b/packages/hostap/hostap-modules_0.3.9.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
+ file://hostap_cs.conf \
+ file://Makefile.patch;patch=1 \
+ file://hostap-utsname.patch;patch=1"
+SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
+ file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
+SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 "
+
+S = "${WORKDIR}/hostap-driver-${PV}"
+
+inherit module
+
+# Hack Alert :D
+ARCH_mipsel = "mips"
+MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
+
+NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \
+ ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
+ ${D}${sysconfdir}/pcmcia
+ for i in ${NET_MODULES}
+ do
+ install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
+ done
+ install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
+ cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
+}
+
+PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
+FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
+FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci${KERNEL_OBJECT_SUFFIX}"
+FILES_hostap-modules = "/lib/modules/"
+RDEPENDS_hostap-modules-cs = "hostap-modules"
+RDEPENDS_hostap-modules-pci = "hostap-modules"