aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hostap
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-03-20 19:19:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-20 19:19:33 +0000
commit3edaa17db5ea6b4500ea34660c74b79fcd5f262e (patch)
tree1decbf693fac8a98b99786810ee86f788cdcec25 /packages/hostap
parentea8b801288d870fea3c5137e8bda9e4bb9942329 (diff)
downloadopenembedded-3edaa17db5ea6b4500ea34660c74b79fcd5f262e.tar.gz
hostap-utils: move common part to .inc
Diffstat (limited to 'packages/hostap')
-rw-r--r--packages/hostap/hostap-utils.inc24
-rw-r--r--packages/hostap/hostap-utils_0.3.7.bb25
-rw-r--r--packages/hostap/hostap-utils_0.4.0.bb25
3 files changed, 28 insertions, 46 deletions
diff --git a/packages/hostap/hostap-utils.inc b/packages/hostap/hostap-utils.inc
new file mode 100644
index 0000000000..c5c5d5b3f9
--- /dev/null
+++ b/packages/hostap/hostap-utils.inc
@@ -0,0 +1,24 @@
+DESCRIPTION = "User mode helpers for the hostap driver"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RRECOMMENDS = "virtual/kernel-hostap"
+PR = "r3"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
+ file://hostap-fw-load.patch;patch=1"
+S = "${WORKDIR}/hostap-utils-${PV}"
+
+BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
+ hostap_rid prism2_param prism2_srec split_combined_hex"
+
+do_install() {
+ install -d ${D}${sbindir}/
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${sbindir}/
+ done
+}
+
diff --git a/packages/hostap/hostap-utils_0.3.7.bb b/packages/hostap/hostap-utils_0.3.7.bb
index c5c5d5b3f9..ad06cd3d6d 100644
--- a/packages/hostap/hostap-utils_0.3.7.bb
+++ b/packages/hostap/hostap-utils_0.3.7.bb
@@ -1,24 +1,3 @@
-DESCRIPTION = "User mode helpers for the hostap driver"
-HOMEPAGE = "http://hostap.epitest.fi"
-SECTION = "kernel/userland"
-PRIORITY = "optional"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-LICENSE = "GPL"
-RRECOMMENDS = "virtual/kernel-hostap"
-PR = "r3"
-
-SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
- file://hostap-fw-load.patch;patch=1"
-S = "${WORKDIR}/hostap-utils-${PV}"
-
-BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
- hostap_rid prism2_param prism2_srec split_combined_hex"
-
-do_install() {
- install -d ${D}${sbindir}/
- for f in ${BINARIES}
- do
- install -m 0755 $f ${D}${sbindir}/
- done
-}
+include hostap-utils.inc
+PR = "r3"
diff --git a/packages/hostap/hostap-utils_0.4.0.bb b/packages/hostap/hostap-utils_0.4.0.bb
index c5c5d5b3f9..ad06cd3d6d 100644
--- a/packages/hostap/hostap-utils_0.4.0.bb
+++ b/packages/hostap/hostap-utils_0.4.0.bb
@@ -1,24 +1,3 @@
-DESCRIPTION = "User mode helpers for the hostap driver"
-HOMEPAGE = "http://hostap.epitest.fi"
-SECTION = "kernel/userland"
-PRIORITY = "optional"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-LICENSE = "GPL"
-RRECOMMENDS = "virtual/kernel-hostap"
-PR = "r3"
-
-SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
- file://hostap-fw-load.patch;patch=1"
-S = "${WORKDIR}/hostap-utils-${PV}"
-
-BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
- hostap_rid prism2_param prism2_srec split_combined_hex"
-
-do_install() {
- install -d ${D}${sbindir}/
- for f in ${BINARIES}
- do
- install -m 0755 $f ${D}${sbindir}/
- done
-}
+include hostap-utils.inc
+PR = "r3"