aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hostap
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/hostap
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/hostap')
-rw-r--r--packages/hostap/hostap-modules_0.1.3.bb10
-rw-r--r--packages/hostap/hostap-modules_0.2.6.bb12
-rw-r--r--packages/hostap/hostap-modules_0.3.5.bb42
-rw-r--r--packages/hostap/hostap-modules_0.3.7.bb42
4 files changed, 95 insertions, 11 deletions
diff --git a/packages/hostap/hostap-modules_0.1.3.bb b/packages/hostap/hostap-modules_0.1.3.bb
index cb288631ad..d88da7e971 100644
--- a/packages/hostap/hostap-modules_0.1.3.bb
+++ b/packages/hostap/hostap-modules_0.1.3.bb
@@ -14,12 +14,12 @@ inherit module
MAKE_TARGETS = "hostap pccard"
do_install() {
- install -d ${D}/lib/modules/${KERNEL_VERSION}/net \
- ${D}/lib/modules/${KERNEL_VERSION}/pcmcia \
+ install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net \
+ ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
${D}/${sysconfdir}/pcmcia
- install -m 0755 driver/modules/hostap_crypt_wep${KERNEL_OBJECT_SUFFIX} ${D}/lib/modules/${KERNEL_VERSION}/net/
- install -m 0755 driver/modules/hostap${KERNEL_OBJECT_SUFFIX} ${D}/lib/modules/${KERNEL_VERSION}/net/
- install -m 0755 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}/lib/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0755 driver/modules/hostap_crypt_wep${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net/
+ install -m 0755 driver/modules/hostap${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net/
+ install -m 0755 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
diff --git a/packages/hostap/hostap-modules_0.2.6.bb b/packages/hostap/hostap-modules_0.2.6.bb
index 902d4d1a47..6b4007425d 100644
--- a/packages/hostap/hostap-modules_0.2.6.bb
+++ b/packages/hostap/hostap-modules_0.2.6.bb
@@ -21,20 +21,20 @@ MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
do_install() {
- install -d ${D}/lib/modules/${KERNEL_VERSION}/net \
- ${D}/lib/modules/${KERNEL_VERSION}/pcmcia \
+ install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net \
+ ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
${D}/${sysconfdir}/pcmcia
for i in ${NET_MODULES}
do
- install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}/lib/modules/${KERNEL_VERSION}/net/
+ install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net/
done
- install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}/lib/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
if [ "${MACHINE}" = "mtx-1" ]; then
- install -d ${D}/etc/modutils
- echo "hostap_pci" > ${D}/etc/modutils/hostap
+ install -d ${D}/${sysconfdir}/modutils
+ echo "hostap_pci" > ${D}/${sysconfdir}/modutils/hostap
fi
}
diff --git a/packages/hostap/hostap-modules_0.3.5.bb b/packages/hostap/hostap-modules_0.3.5.bb
index e69de29bb2..6db38c4f35 100644
--- a/packages/hostap/hostap-modules_0.3.5.bb
+++ b/packages/hostap/hostap-modules_0.3.5.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r3"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
+ file://hostap_cs.conf \
+ file://Makefile.patch;patch=1"
+SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
+ file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
+
+S = "${WORKDIR}/hostap-driver-${PV}"
+
+inherit module
+
+# Hack Alert :D
+ARCH_mipsel = "mips"
+MAKE_TARGETS = "KERNEL_PATH=${KERNEL_SOURCE} MAKE='make -e'"
+
+NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
+
+do_install() {
+ install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net \
+ ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
+ ${D}/${sysconfdir}/pcmcia
+ for i in ${NET_MODULES}
+ do
+ install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net/
+ done
+ install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+ cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+}
+
+PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
+FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
+FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci${KERNEL_OBJECT_SUFFIX}"
+FILES_hostap-modules = "/lib/modules/"
+RDEPENDS_hostap-modules-cs = "hostap-modules"
+RDEPENDS_hostap-modules-pci = "hostap-modules"
diff --git a/packages/hostap/hostap-modules_0.3.7.bb b/packages/hostap/hostap-modules_0.3.7.bb
index e69de29bb2..a68d8b959b 100644
--- a/packages/hostap/hostap-modules_0.3.7.bb
+++ b/packages/hostap/hostap-modules_0.3.7.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
+ file://hostap_cs.conf \
+ file://Makefile.patch;patch=1"
+SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
+ file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
+
+S = "${WORKDIR}/hostap-driver-${PV}"
+
+inherit module
+
+# Hack Alert :D
+ARCH_mipsel = "mips"
+MAKE_TARGETS = "KERNEL_PATH=${KERNEL_SOURCE} MAKE='make -e'"
+
+NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
+
+do_install() {
+ install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net \
+ ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
+ ${D}/${sysconfdir}/pcmcia
+ for i in ${NET_MODULES}
+ do
+ install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net/
+ done
+ install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+ cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+}
+
+PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
+FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
+FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci${KERNEL_OBJECT_SUFFIX}"
+FILES_hostap-modules = "/lib/modules/"
+RDEPENDS_hostap-modules-cs = "hostap-modules"
+RDEPENDS_hostap-modules-pci = "hostap-modules"