aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hostap
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/hostap
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/hostap')
-rw-r--r--packages/hostap/.mtn2git_empty0
-rw-r--r--packages/hostap/files/.mtn2git_empty0
-rw-r--r--packages/hostap/files/hostap-fw-load.patch20
-rw-r--r--packages/hostap/hostap-daemon-0.3.7/.mtn2git_empty0
-rw-r--r--packages/hostap/hostap-daemon-0.3.7/defconfig66
-rwxr-xr-x[-rw-r--r--]packages/hostap/hostap-daemon-0.3.7/init39
-rw-r--r--packages/hostap/hostap-daemon-0.3.7/madwifi-bsd-fix.diff12
-rw-r--r--packages/hostap/hostap-daemon-0.3.7/makefile-cross.diff26
-rw-r--r--packages/hostap/hostap-daemon-0.3.7/mtx-1/.mtn2git_empty0
-rw-r--r--packages/hostap/hostap-daemon-0.3.7/mtx-1/defconfig66
-rw-r--r--packages/hostap/hostap-daemon_0.3.7.bb31
-rw-r--r--packages/hostap/hostap-modules-0.3.7/.mtn2git_empty0
-rw-r--r--packages/hostap/hostap-modules-0.3.7/Makefile.patch11
-rw-r--r--packages/hostap/hostap-modules-0.3.7/ipaq_compat.patch11
-rw-r--r--packages/hostap/hostap-modules-0.3.7/mtx_compat.diff20
-rw-r--r--packages/hostap/hostap-modules-0.3.7/mtx_hostap_deferred_irq.diff81
16 files changed, 383 insertions, 0 deletions
diff --git a/packages/hostap/.mtn2git_empty b/packages/hostap/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hostap/.mtn2git_empty
diff --git a/packages/hostap/files/.mtn2git_empty b/packages/hostap/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hostap/files/.mtn2git_empty
diff --git a/packages/hostap/files/hostap-fw-load.patch b/packages/hostap/files/hostap-fw-load.patch
index e69de29bb2..107636290e 100644
--- a/packages/hostap/files/hostap-fw-load.patch
+++ b/packages/hostap/files/hostap-fw-load.patch
@@ -0,0 +1,20 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- hostap-utils-0.2.4/hostap_fw_load~hostap-fw-load
++++ hostap-utils-0.2.4/hostap_fw_load
+@@ -6,9 +6,9 @@
+ # Firmware images for the card
+ # TODO: could try to select correct firmware type automatically
+
+-PRI=/etc/pcmcia/PM010102.HEX
+-STA=/etc/pcmcia/RF010802.HEX
+-PRISM2_SREC=/usr/local/bin/prism2_srec
++PRI=/etc/pcmcia/pm010102.hex
++STA=/etc/pcmcia/rf010803.hex
++PRISM2_SREC=/usr/sbin/prism2_srec
+
+ set -e
+
diff --git a/packages/hostap/hostap-daemon-0.3.7/.mtn2git_empty b/packages/hostap/hostap-daemon-0.3.7/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.3.7/.mtn2git_empty
diff --git a/packages/hostap/hostap-daemon-0.3.7/defconfig b/packages/hostap/hostap-daemon-0.3.7/defconfig
index e69de29bb2..d0e22f2586 100644
--- a/packages/hostap/hostap-daemon-0.3.7/defconfig
+++ b/packages/hostap/hostap-daemon-0.3.7/defconfig
@@ -0,0 +1,66 @@
+# Example hostapd build time configuration
+#
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cass, these lines should use += in order not
+# to override previous values of the variables.
+
+# Driver interface for Host AP driver
+CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for wired authenticator
+CONFIG_DRIVER_WIRED=y
+
+# Driver interface for madwifi driver
+#CONFIG_DRIVER_MADWIFI=y
+#CFLAGS += -I../head # change to reflect local setup; directory for madwifi src
+
+# Driver interface for Prism54 driver
+CONFIG_DRIVER_PRISM54=y
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+#CONFIG_DRIVER_BSD=y
+#CFLAGS += -I/usr/local/include
+#LIBS += -L/usr/local/lib
+
+# IEEE 802.11F/IAPP
+CONFIG_IAPP=y
+
+# WPA2/IEEE 802.11i RSN pre-authentication
+CONFIG_RSN_PREAUTH=y
+
+# Integrated EAP authenticator
+CONFIG_EAP=y
+
+# EAP-MD5 for the integrated EAP authenticator
+CONFIG_EAP_MD5=y
+
+# EAP-TLS for the integrated EAP authenticator
+CONFIG_EAP_TLS=y
+
+# EAP-MSCHAPv2 for the integrated EAP authenticator
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-PEAP for the integrated EAP authenticator
+CONFIG_EAP_PEAP=y
+
+# EAP-GTC for the integrated EAP authenticator
+CONFIG_EAP_GTC=y
+
+# EAP-TTLS for the integrated EAP authenticator
+CONFIG_EAP_TTLS=y
+
+# EAP-SIM for the integrated EAP authenticator
+#CONFIG_EAP_SIM=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# RADIUS authentication server. This provides access to the integrated EAP
+# authenticator from external hosts using RADIUS.
+CONFIG_RADIUS_SERVER=y
diff --git a/packages/hostap/hostap-daemon-0.3.7/init b/packages/hostap/hostap-daemon-0.3.7/init
index e69de29bb2..b0736c0baa 100644..100755
--- a/packages/hostap/hostap-daemon-0.3.7/init
+++ b/packages/hostap/hostap-daemon-0.3.7/init
@@ -0,0 +1,39 @@
+#!/bin/sh
+DAEMON=/usr/sbin/hostapd
+NAME=httpd
+DESC="HOSTAP Daemon"
+ARGS="/etc/hostapd.conf"
+
+test -f $DAEMON || exit 0
+
+set -e
+
+case "$1" in
+ start)
+ echo -n "starting $DESC: $NAME... "
+ start-stop-daemon -S -b -n $NAME -a $DAEMON -- $ARGS
+ echo "done."
+ ;;
+ stop)
+ echo -n "stopping $DESC: $NAME... "
+ start-stop-daemon -K -n $NAME
+ echo "done."
+ ;;
+ restart)
+ echo "restarting $DESC: $NAME... "
+ $0 stop
+ $0 start
+ echo "done."
+ ;;
+ reload)
+ echo -n "reloading $DESC: $NAME... "
+ killall -HUP $(basename ${DAEMON})
+ echo "done."
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/hostap/hostap-daemon-0.3.7/madwifi-bsd-fix.diff b/packages/hostap/hostap-daemon-0.3.7/madwifi-bsd-fix.diff
index e69de29bb2..d9dab26a15 100644
--- a/packages/hostap/hostap-daemon-0.3.7/madwifi-bsd-fix.diff
+++ b/packages/hostap/hostap-daemon-0.3.7/madwifi-bsd-fix.diff
@@ -0,0 +1,12 @@
+--- driver_madwifi.c.orig 2005-03-18 15:12:53.392793216 +0100
++++ driver_madwifi.c 2005-03-18 15:13:09.246383104 +0100
+@@ -21,7 +21,8 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+
+-#include <include/compat.h>
++#include <net80211/compat.h>
++#include <net80211/_ieee80211.h>
+ #include <net80211/ieee80211.h>
+ #include <net80211/ieee80211_crypto.h>
+ #include <net80211/ieee80211_ioctl.h>
diff --git a/packages/hostap/hostap-daemon-0.3.7/makefile-cross.diff b/packages/hostap/hostap-daemon-0.3.7/makefile-cross.diff
index e69de29bb2..25d2ca34bb 100644
--- a/packages/hostap/hostap-daemon-0.3.7/makefile-cross.diff
+++ b/packages/hostap/hostap-daemon-0.3.7/makefile-cross.diff
@@ -0,0 +1,26 @@
+--- Makefile.orig 2005-03-18 14:34:27.274376504 +0100
++++ Makefile 2005-03-18 14:35:56.609795456 +0100
+@@ -1,7 +1,9 @@
+-CC=gcc
++CC?=gcc
+ DIR_WPA_SUPPLICANT=.
+ DIR_HOSTAP=.
+
++TARGET_PREFIX ?= /usr/local/bin/
++
+ ifndef CFLAGS
+ CFLAGS = -MMD -O2 -Wall -g
+ endif
+@@ -170,10 +172,10 @@
+ fi
+
+ install: all
+- for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
++ for i in $(ALL); do cp $$i $(TARGET_PREFIX)/$$i; done
+
+ hostapd: $(OBJS)
+- $(CC) -o hostapd $(OBJS) $(LIBS)
++ $(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS)
+
+ driver_conf.c: Makefile .config
+ rm -f driver_conf.c
diff --git a/packages/hostap/hostap-daemon-0.3.7/mtx-1/.mtn2git_empty b/packages/hostap/hostap-daemon-0.3.7/mtx-1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.3.7/mtx-1/.mtn2git_empty
diff --git a/packages/hostap/hostap-daemon-0.3.7/mtx-1/defconfig b/packages/hostap/hostap-daemon-0.3.7/mtx-1/defconfig
index e69de29bb2..8c3065c3b9 100644
--- a/packages/hostap/hostap-daemon-0.3.7/mtx-1/defconfig
+++ b/packages/hostap/hostap-daemon-0.3.7/mtx-1/defconfig
@@ -0,0 +1,66 @@
+# Example hostapd build time configuration
+#
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cass, these lines should use += in order not
+# to override previous values of the variables.
+
+# Driver interface for Host AP driver
+CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for wired authenticator
+CONFIG_DRIVER_WIRED=y
+
+# Driver interface for madwifi driver
+CONFIG_DRIVER_MADWIFI=y
+#CFLAGS += -I../head # change to reflect local setup; directory for madwifi src
+
+# Driver interface for Prism54 driver
+CONFIG_DRIVER_PRISM54=y
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+#CONFIG_DRIVER_BSD=y
+#CFLAGS += -I/usr/local/include
+#LIBS += -L/usr/local/lib
+
+# IEEE 802.11F/IAPP
+CONFIG_IAPP=y
+
+# WPA2/IEEE 802.11i RSN pre-authentication
+CONFIG_RSN_PREAUTH=y
+
+# Integrated EAP authenticator
+CONFIG_EAP=y
+
+# EAP-MD5 for the integrated EAP authenticator
+CONFIG_EAP_MD5=y
+
+# EAP-TLS for the integrated EAP authenticator
+CONFIG_EAP_TLS=y
+
+# EAP-MSCHAPv2 for the integrated EAP authenticator
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-PEAP for the integrated EAP authenticator
+CONFIG_EAP_PEAP=y
+
+# EAP-GTC for the integrated EAP authenticator
+CONFIG_EAP_GTC=y
+
+# EAP-TTLS for the integrated EAP authenticator
+CONFIG_EAP_TTLS=y
+
+# EAP-SIM for the integrated EAP authenticator
+#CONFIG_EAP_SIM=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# RADIUS authentication server. This provides access to the integrated EAP
+# authenticator from external hosts using RADIUS.
+CONFIG_RADIUS_SERVER=y
diff --git a/packages/hostap/hostap-daemon_0.3.7.bb b/packages/hostap/hostap-daemon_0.3.7.bb
index e69de29bb2..9363a10d91 100644
--- a/packages/hostap/hostap-daemon_0.3.7.bb
+++ b/packages/hostap/hostap-daemon_0.3.7.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "hostap-modules (${PV}) hostap-utils (${PV})"
+DEPENDS_mtx-1_append = "madwifi-modules"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
+ file://makefile-cross.diff;patch=1;pnum=0 \
+ file://madwifi-bsd-fix.diff;patch=1;pnum=0 \
+ file://defconfig \
+ file://init"
+
+S = "${WORKDIR}/hostapd-${PV}"
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}
+
+do_compile() {
+ CFLAGS='${CFLAGS}' CC='${CC}' make
+}
+
+do_install() {
+ install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
+ make TARGET_PREFIX=${D}${sbindir} install
+ install -m 0644 hostapd.conf ${D}${sysconfdir}
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
+}
diff --git a/packages/hostap/hostap-modules-0.3.7/.mtn2git_empty b/packages/hostap/hostap-modules-0.3.7/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hostap/hostap-modules-0.3.7/.mtn2git_empty
diff --git a/packages/hostap/hostap-modules-0.3.7/Makefile.patch b/packages/hostap/hostap-modules-0.3.7/Makefile.patch
index e69de29bb2..2fc5e9ed4b 100644
--- a/packages/hostap/hostap-modules-0.3.7/Makefile.patch
+++ b/packages/hostap/hostap-modules-0.3.7/Makefile.patch
@@ -0,0 +1,11 @@
+--- hostap-driver-0.2.4/Makefile.old 2004-07-31 10:35:50.000000000 +0100
++++ hostap-driver-0.2.4/Makefile 2004-07-31 10:35:56.000000000 +0100
+@@ -51,7 +51,7 @@
+
+ VERFILE := $(KERNEL_PATH)/include/linux/version.h
+ KERNELRELEASE := $(shell if [ -r $(VERFILE) ]; \
+- then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -1 | xargs echo; \
++ then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -n 1 | xargs echo; \
+ else uname -r; fi)
+ KERNELVER := $(shell echo "$(KERNELRELEASE)" | \
+ sed "s/\([0-9]*\.[0-9]*\.[0-9]*\).*/\1/")
diff --git a/packages/hostap/hostap-modules-0.3.7/ipaq_compat.patch b/packages/hostap/hostap-modules-0.3.7/ipaq_compat.patch
index e69de29bb2..b139ef38f1 100644
--- a/packages/hostap/hostap-modules-0.3.7/ipaq_compat.patch
+++ b/packages/hostap/hostap-modules-0.3.7/ipaq_compat.patch
@@ -0,0 +1,11 @@
+--- hostap-driver-0.3.7/driver/modules/hostap_compat.h.old 2005-04-17 09:12:38.304421464 +0100
++++ hostap-driver-0.3.7/driver/modules/hostap_compat.h 2005-04-17 09:13:04.413452288 +0100
+@@ -5,7 +5,7 @@
+ #define NEW_MODULE_CODE
+ #endif
+
+-#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44)) && !defined(CONFIG_IPAQ_HANDHELD)
+
+ #define HOSTAP_QUEUE struct tq_struct
+
diff --git a/packages/hostap/hostap-modules-0.3.7/mtx_compat.diff b/packages/hostap/hostap-modules-0.3.7/mtx_compat.diff
index e69de29bb2..c2d6662d69 100644
--- a/packages/hostap/hostap-modules-0.3.7/mtx_compat.diff
+++ b/packages/hostap/hostap-modules-0.3.7/mtx_compat.diff
@@ -0,0 +1,20 @@
+--- driver/modules/hostap_compat.h.orig 2004-08-09 16:16:48.359929856 +0200
++++ driver/modules/hostap_compat.h 2004-08-09 16:17:12.383277752 +0200
+@@ -13,7 +13,7 @@
+ MOD_INC_USE_COUNT; \
+ if (schedule_task((q)) == 0) \
+ MOD_DEC_USE_COUNT;
+-
++/*
+ static inline void flush_scheduled_work(void)
+ {
+ flush_scheduled_tasks();
+@@ -27,7 +27,7 @@
+ tq->routine = routine;
+ tq->data = data;
+ }
+-
++*/
+ #else /* kernel < 2.5.44 */
+
+ #define HOSTAP_QUEUE struct work_struct
diff --git a/packages/hostap/hostap-modules-0.3.7/mtx_hostap_deferred_irq.diff b/packages/hostap/hostap-modules-0.3.7/mtx_hostap_deferred_irq.diff
index e69de29bb2..e979b72d93 100644
--- a/packages/hostap/hostap-modules-0.3.7/mtx_hostap_deferred_irq.diff
+++ b/packages/hostap/hostap-modules-0.3.7/mtx_hostap_deferred_irq.diff
@@ -0,0 +1,81 @@
+--- driver/modules/hostap_pci.c.orig 2004-11-30 06:41:48.000000000 +0100
++++ driver/modules/hostap_pci.c 2005-01-17 19:47:33.710400496 +0100
+@@ -50,6 +50,13 @@
+ };
+
+
++#define DEFERRED_IRQ_INITIALIZATION
++
++#ifdef DEFERRED_IRQ_INITIALIZATION
++struct net_device *devb[MAX_PARM_DEVICES];
++#endif
++
++
+ #ifdef PRISM2_IO_DEBUG
+
+ static inline void hfa384x_outb_debug(struct net_device *dev, int a, u8 v)
+@@ -280,6 +287,10 @@
+
+ pci_set_drvdata(pdev, dev);
+
++#ifdef DEFERRED_IRQ_INITIALIZATION
++ printk("%s: deferred initialization of IRQs\n", dev_info);
++ devb[cards_found-1] = dev;
++#else
+ if (request_irq(dev->irq, prism2_interrupt, SA_SHIRQ, dev->name,
+ dev)) {
+ printk(KERN_WARNING "%s: request_irq failed\n", dev->name);
+@@ -295,7 +306,7 @@
+
+ printk(KERN_INFO "%s: Intersil Prism2.5 PCI: "
+ "mem=0x%lx, irq=%d\n", dev->name, phymem, dev->irq);
+-
++#endif
+ return hostap_hw_ready(dev);
+
+ fail:
+@@ -399,18 +410,43 @@
+ };
+
+
++#ifdef DEFERRED_IRQ_INITIALIZATION
++static void deferred_init(int num_devices)
++{
++ int n;
++ for (n=0; n<num_devices && n<MAX_PARM_DEVICES; n++)
++ {
++ if (request_irq(devb[n]->irq, prism2_interrupt, SA_SHIRQ, devb[n]->name,
++ devb[n])) {
++ printk(KERN_WARNING "%s: request_irq failed\n", devb[n]->name);
++ }
++ if (prism2_hw_config(devb[n], 1)) {
++ printk(KERN_DEBUG "%s: hardware initialization failed\n", devb[n]->name)
++;
++ }
++ printk(KERN_INFO "%s: Intersil Prism2.5 PCI: irq=%d\n", devb[n]->name, devb[n]->
++irq);
++ }
++}
++#endif
++
+ static int __init init_prism2_pci(void)
+ {
+ printk(KERN_INFO "%s: %s\n", dev_info, version);
+
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,10))
+- if (pci_register_driver(&prism2_pci_drv_id) <= 0) {
++ int n;
++ if ((n=pci_register_driver(&prism2_pci_drv_id)) <= 0) {
+ printk("hostap_pci: No devices found, driver not "
+ "installed.\n");
+ pci_unregister_driver(&prism2_pci_drv_id);
+ return -ENODEV;
+ }
+
++#ifdef DEFERRED_IRQ_INITIALIZATION
++ deferred_init(n);
++#endif
++
+ return 0;
+ #else
+ return pci_register_driver(&prism2_pci_drv_id);