aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hostap
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-06 18:40:06 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-06 18:40:06 +0000
commit5e49eb31580e6b9374f9a0ad00df69f31a727077 (patch)
treef79b87f8accb97aee5105e8d74fd18d8e052a479 /packages/hostap
parent75e594b7b877f39be78bd78f159faccfb88ee972 (diff)
downloadopenembedded-5e49eb31580e6b9374f9a0ad00df69f31a727077.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/06 12:24:56-06:00 ti.com!kergoth Merge siasl.dyndns.org:code/openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/01/06 12:22:04-06:00 ti.com!kergoth Bump PR on the hostap-modules packages per timh's recent cset. 2005/01/06 12:18:42-06:00 ti.com!kergoth Merge 2005/01/06 12:42:21-05:00 handhelds.org!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into handhelds.org:/home/kergoth/code/openembedded 2005/01/06 12:41:20-05:00 handhelds.org!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into handhelds.org:/home/kergoth/code/openembedded 2005/01/06 11:47:26+00:00 kano.org.uk!timh Added a new WiFi card 2005/01/05 20:18:45-05:00 handhelds.org!kergoth Make coreutils emitted packages Provides and Replaces textutils, fileutils, and shellutils. BKrev: 41dd8606AD0jGEVkdtDpg1D7F0OmuA
Diffstat (limited to 'packages/hostap')
-rw-r--r--packages/hostap/files/hostap_cs.conf4
-rw-r--r--packages/hostap/hostap-modules_0.1.3.bb26
-rw-r--r--packages/hostap/hostap-modules_0.2.0.bb25
-rw-r--r--packages/hostap/hostap-modules_0.2.6.bb59
-rw-r--r--packages/hostap/hostap-modules_0.3.3.bb44
5 files changed, 158 insertions, 0 deletions
diff --git a/packages/hostap/files/hostap_cs.conf b/packages/hostap/files/hostap_cs.conf
index 0863052ca5..0b1bcf1a58 100644
--- a/packages/hostap/files/hostap_cs.conf
+++ b/packages/hostap/files/hostap_cs.conf
@@ -96,6 +96,10 @@ card "MELCO WLI-PCM-L11G"
version "BUFFALO", "WLI-PCM-L11G"
bind "hostap_cs"
+card "Buffalo WLI2-CF-S11"
+ version "BUFFALO", "WLI2-CF-S11"
+ bind "hostap_cs"
+
card "NETGEAR MA701 Wireless CF Card"
manfid 0xd601, 0x0002
bind "hostap_cs"
diff --git a/packages/hostap/hostap-modules_0.1.3.bb b/packages/hostap/hostap-modules_0.1.3.bb
index e69de29bb2..244c7f94ad 100644
--- a/packages/hostap/hostap-modules_0.1.3.bb
+++ b/packages/hostap/hostap-modules_0.1.3.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
+ file://hostap_cs.conf"
+S = "${WORKDIR}/hostap-driver-${PV}"
+
+inherit module
+
+MAKE_TARGETS = "hostap pccard"
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/net \
+ ${D}/lib/modules/${KERNEL_VERSION}/pcmcia \
+ ${D}/${sysconfdir}/pcmcia
+ install -m 0755 driver/modules/hostap_crypt_wep.o ${D}/lib/modules/${KERNEL_VERSION}/net/
+ install -m 0755 driver/modules/hostap.o ${D}/lib/modules/${KERNEL_VERSION}/net/
+ install -m 0755 driver/modules/hostap_cs.o ${D}/lib/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+ cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+
+}
diff --git a/packages/hostap/hostap-modules_0.2.0.bb b/packages/hostap/hostap-modules_0.2.0.bb
index e69de29bb2..86aed7fe5e 100644
--- a/packages/hostap/hostap-modules_0.2.0.bb
+++ b/packages/hostap/hostap-modules_0.2.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
+ file://hostap_cs.conf"
+S = "${WORKDIR}/hostap-driver-${PV}"
+
+inherit module
+
+MAKE_TARGETS = "hostap pccard"
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/net \
+ ${D}/lib/modules/${KERNEL_VERSION}/pcmcia \
+ ${D}/${sysconfdir}/pcmcia
+ install -m 0644 driver/modules/hostap_crypt_wep.o ${D}/lib/modules/${KERNEL_VERSION}/net/
+ install -m 0644 driver/modules/hostap.o ${D}/lib/modules/${KERNEL_VERSION}/net/
+ install -m 0644 driver/modules/hostap_cs.o ${D}/lib/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+ cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+}
diff --git a/packages/hostap/hostap-modules_0.2.6.bb b/packages/hostap/hostap-modules_0.2.6.bb
index e69de29bb2..de1b4ffeaf 100644
--- a/packages/hostap/hostap-modules_0.2.6.bb
+++ b/packages/hostap/hostap-modules_0.2.6.bb
@@ -0,0 +1,59 @@
+DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r7"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
+ file://hostap_cs.conf \
+ file://Makefile.patch;patch=1"
+SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
+ file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
+
+S = "${WORKDIR}/hostap-driver-${PV}"
+
+inherit module
+
+EXTRA_OEMAKE = "EXTRA_CFLAGS='-DPRISM2_NON_VOLATILE_DOWNLOAD'"
+MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
+NET_MODULES = "hostap.o hostap_pci.o hostap_crypt_ccmp.o hostap_crypt_tkip.o hostap_crypt_wep.o"
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/net \
+ ${D}/lib/modules/${KERNEL_VERSION}/pcmcia \
+ ${D}/${sysconfdir}/pcmcia
+ for i in ${NET_MODULES}
+ do
+ install -m 0644 driver/modules/$i ${D}/lib/modules/${KERNEL_VERSION}/net/
+ done
+ install -m 0644 driver/modules/hostap_cs.o ${D}/lib/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+ cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+
+ if [ "${MACHINE}" = "mtx-1" ]; then
+ install -d ${D}/etc/modutils
+ echo "hostap_pci" > ${D}/etc/modutils/hostap
+ fi
+}
+
+pkg_postinst_hostap-modules-pci() {
+#!/bin/sh
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+update-modules || true
+}
+
+pkg_postrm_hostap-modules-pci() {
+#!/bin/sh
+update-modules || true
+}
+
+PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
+FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
+FILES_hostap-modules-pci = "/etc/modutils /lib/modules/${KERNEL_VERSION}/net/hostap_pci.o"
+FILES_hostap-modules = "/lib/modules/"
+RDEPENDS_hostap-modules-cs = "hostap-modules"
+RDEPENDS_hostap-modules-pci = "hostap-modules"
diff --git a/packages/hostap/hostap-modules_0.3.3.bb b/packages/hostap/hostap-modules_0.3.3.bb
index e69de29bb2..08c15b0275 100644
--- a/packages/hostap/hostap-modules_0.3.3.bb
+++ b/packages/hostap/hostap-modules_0.3.3.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r2"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
+ file://hostap_cs.conf \
+ file://Makefile.patch;patch=1"
+SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
+ file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
+
+S = "${WORKDIR}/hostap-driver-${PV}"
+
+inherit module
+
+# Hack Alert :D
+ARCH_mipsel = "mips"
+MAKE_TARGETS = "KERNEL_PATH=${KERNEL_SOURCE} MAKE='make -e'"
+
+NET_MODULES = "hostap.o hostap_pci.o hostap_crypt_ccmp.o hostap_crypt_tkip.o hostap_crypt_wep.o"
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/net \
+ ${D}/lib/modules/${KERNEL_VERSION}/pcmcia \
+ ${D}/${sysconfdir}/pcmcia
+ for i in ${NET_MODULES}
+ do
+ install -m 0644 driver/modules/$i ${D}/lib/modules/${KERNEL_VERSION}/net/
+ done
+ install -m 0644 driver/modules/hostap_cs.o ${D}/lib/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+ cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+}
+
+PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
+FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
+FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci.o"
+FILES_hostap-modules = "/lib/modules/"
+RDEPENDS_hostap-modules-cs = "hostap-modules"
+RDEPENDS_hostap-modules-pci = "hostap-modules"