aboutsummaryrefslogtreecommitdiffstats
path: root/packages/howl
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-05-24 17:40:07 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-05-24 17:40:07 +0000
commit1ee2bff5e2df9d863c1b74d2a9a5af8b6688ec1e (patch)
treea9d72c4e2e66631116ac86433a21fb44627a9226 /packages/howl
parent85d7678173d4819fce44a24dee2f7f32400184d6 (diff)
downloadopenembedded-1ee2bff5e2df9d863c1b74d2a9a5af8b6688ec1e.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/05/24 18:00:40+01:00 reciva.com!pb improve howl packaging BKrev: 429366f7YSGF1ysfBpteBV5NMhVVlQ
Diffstat (limited to 'packages/howl')
-rw-r--r--packages/howl/files/mdnsresponder.init0
-rw-r--r--packages/howl/howl_1.0.0.bb28
2 files changed, 28 insertions, 0 deletions
diff --git a/packages/howl/files/mdnsresponder.init b/packages/howl/files/mdnsresponder.init
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/howl/files/mdnsresponder.init
diff --git a/packages/howl/howl_1.0.0.bb b/packages/howl/howl_1.0.0.bb
index e69de29bb2..9acc33018c 100644
--- a/packages/howl/howl_1.0.0.bb
+++ b/packages/howl/howl_1.0.0.bb
@@ -0,0 +1,28 @@
+SRC_URI = "http://www.porchdogsoft.com/download/howl-${PV}.tar.gz \
+ file://posix.patch;patch=1;pnum=0 \
+ file://configure.patch;patch=1;pnum=0 \
+ file://mdnsresponder.init"
+LICENSE = "howl"
+
+PR = "r2"
+
+INITSCRIPT_NAME = "mdnsresponder"
+INITSCRIPT_PARAMS = "defaults"
+
+PACKAGES += "libhowl libmdnsresponder"
+
+FILES_${PN} = "${bindir} ${sbindir} ${sysconfdir}"
+FILES_libhowl = "${libdir}/libhowl.so.*"
+FILES_libmdnsresponder = "${libdir}/libmDNSResponder.so.*"
+FILES_${PN}-doc += "${datadir}/howl/help"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/mdnsresponder.init ${D}${sysconfdir}/init.d/mdnsresponder
+ # Debian puts it here, so let's do the same
+ mv ${D}${bindir}/mDNSResponder ${D}${sbindir}
+}
+
+inherit autotools update-rc.d
+