aboutsummaryrefslogtreecommitdiffstats
path: root/packages/howl
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/howl
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/howl')
-rw-r--r--packages/howl/.mtn2git_empty0
-rw-r--r--packages/howl/files/.mtn2git_empty0
-rwxr-xr-x[-rw-r--r--]packages/howl/files/mdnsresponder.init56
-rw-r--r--packages/howl/howl-1.0.0/.mtn2git_empty0
-rw-r--r--packages/howl/howl-1.0.0/configure.patch11
-rw-r--r--packages/howl/howl-1.0.0/posix.patch20
-rw-r--r--packages/howl/howl_0.9.7.bb5
7 files changed, 92 insertions, 0 deletions
diff --git a/packages/howl/.mtn2git_empty b/packages/howl/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/howl/.mtn2git_empty
diff --git a/packages/howl/files/.mtn2git_empty b/packages/howl/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/howl/files/.mtn2git_empty
diff --git a/packages/howl/files/mdnsresponder.init b/packages/howl/files/mdnsresponder.init
index e69de29bb2..98312dfee1 100644..100755
--- a/packages/howl/files/mdnsresponder.init
+++ b/packages/howl/files/mdnsresponder.init
@@ -0,0 +1,56 @@
+#!/bin/sh
+#
+# mDNSResponder: Starts the mDNSResponder Daemon
+#
+# This is an init script for Debian by Reed Hedges, based on the skeleton by
+# Miguel van Smoorenburg and Ian Murdock, and based on the original mDNSResponder
+# script from Howl.
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/sbin/mDNSResponder
+NAME=mDNSResponder
+DESC="Zeroconf service discovery responder"
+PIDFILE=/var/run/${NAME}.pid
+LOCKFILE=/var/lock/subsys/${NAME}
+CONFIG=/etc/mdnsresponder/mDNSResponder.conf
+
+test -x $DAEMON || exit 0
+
+start() {
+ echo -n $"Starting $DESC: $NAME"
+ start-stop-daemon --start --quiet -u daemon --exec $DAEMON -- -f $CONFIG
+ echo "."
+}
+
+stop() {
+ echo -n $"Stopping $DESC: $NAME"
+ start-stop-daemon --stop --quiet --exec $DAEMON
+ test -f $LOCKFILE && rm -f $LOCKFILE
+ test -f $PIDFILE && rm -f $PIDFILE
+ echo "."
+}
+
+restart() {
+ stop
+ sleep 1
+ start
+}
+
+
+# See how we were called.
+case "$1" in
+ start)
+ start
+ ;;
+ stop)
+ stop
+ ;;
+ restart|force-reload)
+ restart
+ ;;
+ *)
+ echo $"Usage: $0 {start|stop|restart}"
+ exit 1
+esac
+
+exit 0
diff --git a/packages/howl/howl-1.0.0/.mtn2git_empty b/packages/howl/howl-1.0.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/howl/howl-1.0.0/.mtn2git_empty
diff --git a/packages/howl/howl-1.0.0/configure.patch b/packages/howl/howl-1.0.0/configure.patch
index e69de29bb2..a1c0c2b57e 100644
--- a/packages/howl/howl-1.0.0/configure.patch
+++ b/packages/howl/howl-1.0.0/configure.patch
@@ -0,0 +1,11 @@
+--- configure.ac.old 2005-05-20 14:36:48.000000000 +0100
++++ configure.ac 2005-05-20 14:36:54.000000000 +0100
+@@ -25,7 +25,7 @@
+ HOWL_LIB_OBJECTS='posix_salt.lo posix_socket.lo posix_time.lo posix_signal.lo posix_interface.lo notosx_mdns_stub.lo'
+ MDNSRESPONDER_LIB_SUBDIRS="Posix"
+ MDNSRESPONDER_LIB_OBJECTS='posix_mdns.lo'
+- AUTOIPD_EXTRA_OBJECTS='$(top_builddir)/src/autoipd/linux_autoip.lo $(top_builddir)/src/autoipd/posix_main.lo'
++ AUTOIPD_EXTRA_OBJECTS='$(top_builddir)/src/autoipd/linux_autoip.o $(top_builddir)/src/autoipd/posix_main.o'
+ PLATFORM_LIBS=-lpthread
+ HOWL_MAN_PAGES='mDNSResponder.8 autoipd.8 nifd.8'
+ ;;
diff --git a/packages/howl/howl-1.0.0/posix.patch b/packages/howl/howl-1.0.0/posix.patch
index e69de29bb2..f4dd7d349c 100644
--- a/packages/howl/howl-1.0.0/posix.patch
+++ b/packages/howl/howl-1.0.0/posix.patch
@@ -0,0 +1,20 @@
+--- src/lib/howl/Posix/posix_interface.c.old 2005-05-20 14:26:34.000000000 +0100
++++ src/lib/howl/Posix/posix_interface.c 2005-05-20 14:26:35.000000000 +0100
+@@ -37,10 +37,16 @@
+ #include <stdio.h>
+
+ #if defined(__linux__)
+-typedef unsigned long long u64;
++typedef __uint64_t u64;
+ typedef __uint32_t u32;
+ typedef __uint16_t u16;
+ typedef __uint8_t u8;
++
++typedef __uint64_t __u64;
++typedef __uint32_t __u32;
++typedef __uint16_t __u16;
++typedef __uint8_t __u8;
++
+ # include <linux/sockios.h>
+ # include <linux/ethtool.h>
+ #endif
diff --git a/packages/howl/howl_0.9.7.bb b/packages/howl/howl_0.9.7.bb
index e69de29bb2..d798d173b4 100644
--- a/packages/howl/howl_0.9.7.bb
+++ b/packages/howl/howl_0.9.7.bb
@@ -0,0 +1,5 @@
+SRC_URI = "http://www.porchdogsoft.com/download/howl-${PV}.tar.gz"
+LICENSE = "howl"
+
+inherit autotools
+