aboutsummaryrefslogtreecommitdiffstats
path: root/packages/images/angstrom-minimal-image.bb
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-17 18:08:04 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-17 18:08:04 +0000
commitbe45ff7d2ecd063fb2d01e618aef73198f353f0d (patch)
tree19bc2959184c1c3a8567ddf989d6e1bf7b1c6249 /packages/images/angstrom-minimal-image.bb
parent7605d989539a54cb2e6a00fba7cd3943bb9be7ec (diff)
downloadopenembedded-be45ff7d2ecd063fb2d01e618aef73198f353f0d.tar.gz
helloworld: fix broken commit.
Diffstat (limited to 'packages/images/angstrom-minimal-image.bb')
-rw-r--r--packages/images/angstrom-minimal-image.bb18
1 files changed, 15 insertions, 3 deletions
diff --git a/packages/images/angstrom-minimal-image.bb b/packages/images/angstrom-minimal-image.bb
index 54f7ff2c89..90f46a1e01 100644
--- a/packages/images/angstrom-minimal-image.bb
+++ b/packages/images/angstrom-minimal-image.bb
@@ -1,10 +1,22 @@
-# Hello world image
-# gives you a small image with a statically linked
+#Angstrom minimalist image
+#gives you a small images with ssh access
LICENSE = "MIT"
PR = "r0"
-export IMAGE_BASENAME = "helloworld-image"
+ANGSTROM_EXTRA_INSTALL ?= ""
+DISTRO_SSH_DAEMON ?= "dropbear"
+
+DEPENDS = "task-base \
+ ${DISTRO_SSH_DAEMON} \
+ "
+
+RDEPENDS = "task-boot \
+ ${DISTRO_SSH_DAEMON} \
+ "
+
+export IMAGE_BASENAME = "minimalist-image"
export IMAGE_LINGUAS = ""
+export PACKAGE_INSTALL = "${RDEPENDS}"
inherit image