aboutsummaryrefslogtreecommitdiffstats
path: root/packages/images
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-12-16 07:58:04 +0000
committerRod Whitby <rod@whitby.id.au>2007-12-16 07:58:04 +0000
commit0205bafa6959673ef5680dce99c1a3eed37989ee (patch)
tree3801b501b51bd8f4677299da9674d6a59d7c2884 /packages/images
parentc78ae6dfcdb274326a7ee8b2bf2db0c2132cd334 (diff)
downloadopenembedded-0205bafa6959673ef5680dce99c1a3eed37989ee.tar.gz
base-image: New image designed to be a basis upon which you can install any other desired functionality using task packages from feeds.
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/base-image.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/packages/images/base-image.bb b/packages/images/base-image.bb
new file mode 100644
index 0000000000..74b938ba53
--- /dev/null
+++ b/packages/images/base-image.bb
@@ -0,0 +1,54 @@
+# This image is intended to provide a basic configuration that allows
+# you to access a newly flashed device over the network or via the
+# native console, and use ipkg to install (from feeds accessible via
+# the network) any further features you require into internal flash
+# memory or onto attached storage.
+
+# It should be as small as possible, while still achieving that goal.
+
+# The rationale for naming it 'base-image' is that this image is the
+# base upon which you can install any other functionality you desire.
+
+# Key features are:
+
+# 1) Must be able to mount attached storage devices like SD cards, CF
+# cards, internal disks, external USB disks, etc. Should support
+# various filesystem choices, but ext2 at a minimum. The rationale
+# for this is that you need storage to be able to install significant
+# new functionality.
+
+# 2) Must be able to boot from internal flash, or directly from a
+# filesystem stored on the attached storage. The rationale for this
+# is that you will want to boot from attached storage instead of
+# messing around with ipkg-link.
+
+# Although it is only fully tested with the Angstrom distro, this
+# image is intended to be distro-agnostic.
+
+DISTRO_SSH_DAEMON ?= "dropbear"
+DISTRO_PACKAGE_MANAGER ?= "ipkg ipkg-collateral"
+
+DEPENDS = "\
+ task-boot \
+ task-distro-base task-machine-base \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ task-base-usbhost task-base-ext2 \
+ "
+
+IMAGE_INSTALL_TASKS = "\
+ "
+
+IMAGE_INSTALL = "\
+ task-boot \
+ task-distro-base task-machine-base \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ task-base-usbhost task-base-ext2 \
+ ${IMAGE_INSTALL_TASKS} \
+ "
+
+export IMAGE_BASENAME = "base-image"
+IMAGE_LINGUAS = ""
+
+inherit image