aboutsummaryrefslogtreecommitdiffstats
path: root/packages/images
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-12-23 12:01:43 +0000
committerRod Whitby <rod@whitby.id.au>2007-12-23 12:01:43 +0000
commit3c39da0a0121f07f33d1acbfd6e93184f26d987e (patch)
treef856e84d5461107b51f9e5ea56ec445a2cd43f3d /packages/images
parentff560c16413283dfbeed7edc362a2aaca34049f8 (diff)
downloadopenembedded-3c39da0a0121f07f33d1acbfd6e93184f26d987e.tar.gz
nas-server: New task, meta-package, and image for creating a network attached storage server.
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/nas-server-image.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/packages/images/nas-server-image.bb b/packages/images/nas-server-image.bb
new file mode 100644
index 0000000000..d4a012c082
--- /dev/null
+++ b/packages/images/nas-server-image.bb
@@ -0,0 +1,47 @@
+# This image is intended to provide a configuration
+# for a network attached storage server device.
+
+# Key features are:
+#
+# 1) Must be able to mount attached storage devices like
+# internal disks, external USB disks, etc. Should support
+# various filesystem choices, but ext2 at a minimum.
+#
+# 2) Must be able to boot from internal flash, or directly
+# from a filesystem stored on the attached storage.
+#
+# 3) Must be able to share that storage across the network
+# using various protocols like Samba, NFS, etc.
+#
+# 4) Bonus points for being able to support other central
+# network services like a central gateway machine might.
+
+# Although it is tested with the Angstrom distro, it is
+# intended to be distro-agnostic.
+
+DISTRO_SSH_DAEMON ?= "dropbear"
+DISTRO_PACKAGE_MANAGER ?= "ipkg ipkg-collateral"
+
+DEPENDS = "task-boot task-base-apex \
+ task-distro-base task-machine-base \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ task-base-usbhost task-base-ext2 \
+ task-nas-server-everything \
+ "
+
+IMAGE_INSTALL_TASKS = "\
+ task-nas-server-everything \
+ "
+
+IMAGE_INSTALL = "task-boot task-base-apex \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ task-base-usbhost task-base-ext2 \
+ ${IMAGE_INSTALL_TASKS} \
+ "
+
+export IMAGE_BASENAME = "nas-server-image"
+IMAGE_LINGUAS = ""
+
+inherit image