aboutsummaryrefslogtreecommitdiffstats
path: root/packages/images
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-12-16 09:16:15 +0000
committerRod Whitby <rod@whitby.id.au>2007-12-16 09:16:15 +0000
commita4f70f11e2e1ac7c9396289b6324447027778bc1 (patch)
tree461c4174f14bd8b3ddc5de0707823bd241ad5977 /packages/images
parentf2f6ffd02f63a5689cdcf02c9ee5ad548623b5f0 (diff)
downloadopenembedded-a4f70f11e2e1ac7c9396289b6324447027778bc1.tar.gz
base-image: Added more documentation, including criteria for adding and removing packages from the image.
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/base-image.bb54
1 files changed, 38 insertions, 16 deletions
diff --git a/packages/images/base-image.bb b/packages/images/base-image.bb
index 74b938ba53..20a5fd9445 100644
--- a/packages/images/base-image.bb
+++ b/packages/images/base-image.bb
@@ -9,18 +9,9 @@
# The rationale for naming it 'base-image' is that this image is the
# base upon which you can install any other functionality you desire.
-# Key features are:
-
-# 1) Must be able to mount attached storage devices like SD cards, CF
-# cards, internal disks, external USB disks, etc. Should support
-# various filesystem choices, but ext2 at a minimum. The rationale
-# for this is that you need storage to be able to install significant
-# new functionality.
-
-# 2) Must be able to boot from internal flash, or directly from a
-# filesystem stored on the attached storage. The rationale for this
-# is that you will want to boot from attached storage instead of
-# messing around with ipkg-link.
+# See the end of this file for further rationale and policy regarding
+# the contents of this image, and the criteria which are used to make
+# decisions about adding and removing packages from this image.
# Although it is only fully tested with the Angstrom distro, this
# image is intended to be distro-agnostic.
@@ -36,19 +27,50 @@ DEPENDS = "\
task-base-usbhost task-base-ext2 \
"
-IMAGE_INSTALL_TASKS = "\
- "
-
IMAGE_INSTALL = "\
task-boot \
task-distro-base task-machine-base \
${DISTRO_SSH_DAEMON} \
${DISTRO_PACKAGE_MANAGER} \
task-base-usbhost task-base-ext2 \
- ${IMAGE_INSTALL_TASKS} \
"
export IMAGE_BASENAME = "base-image"
IMAGE_LINGUAS = ""
inherit image
+
+# Key features of this image are:
+
+# 1) Must be able to mount attached storage devices like SD cards, CF
+# cards, internal disks, external USB disks, etc. Should support
+# various filesystem choices, but ext2 at a minimum. The rationale
+# for this is that you need storage to be able to install significant
+# new functionality.
+
+# 2) Must be able to boot from internal flash, or directly from a
+# filesystem stored on the attached storage. The rationale for this
+# is that you will want to boot from attached storage instead of
+# messing around with ipkg-link.
+
+# Rationale and policy:
+
+# 'base-image' is the smallest possible image which allows you to ssh
+# into a device via it's native network interface, and install
+# packages from feeds across the network into internal flash or onto
+# an attached storage device.
+
+# It is "larger" than minimal-image (which is strictly only that which
+# is required to boot and get ssh access to the device, and nothing
+# else), but is "smaller" than console-image (which has a whole lot of
+# stuff in it which could easily be ipkg installed after boot rather
+# than being in the initial rootfs).
+
+# It is required to always be small enough to fit in the internal
+# flash rootfs partition of an NSLU2 (as an example of the smaller end
+# of flash sizes that OE supports), and features will be removed from
+# the image to ensure that this is always the case. Any feature that
+# can be installed over the network using the package manager after
+# the first boot is always fair game for removal at any time, and
+# patches are welcome to make base-image as small as possible while
+# still retaining the ability to subsequently install that feature.