aboutsummaryrefslogtreecommitdiffstats
path: root/packages/initrdscripts
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2008-02-21 14:23:12 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2008-02-21 14:23:12 +0000
commitc66cbffccb5b3089a053552718433f521d6f8dca (patch)
treeb9ac8fa2745aa03ff397ca616bce392ef05fd487 /packages/initrdscripts
parent5b9cbe47537c68b54a08eb626c902bd02dc03200 (diff)
downloadopenembedded-c66cbffccb5b3089a053552718433f521d6f8dca.tar.gz
applied changes from 5b39dd5751765304c0257f1ce36b2fb246b5cbaa
through de1d4506659e4a712c794b322f19ea295057d8c0 initramfs-module-check-modules: An initramfs module to check modules consistency. (PaulS, Koen)
Diffstat (limited to 'packages/initrdscripts')
-rw-r--r--packages/initrdscripts/files/90-check-modules.sh24
-rw-r--r--packages/initrdscripts/initramfs-module-check-modules_1.0.bb12
2 files changed, 36 insertions, 0 deletions
diff --git a/packages/initrdscripts/files/90-check-modules.sh b/packages/initrdscripts/files/90-check-modules.sh
new file mode 100644
index 0000000000..2423d7f8c5
--- /dev/null
+++ b/packages/initrdscripts/files/90-check-modules.sh
@@ -0,0 +1,24 @@
+#!/bin/sh
+# Check that modules for the current kernel exist, error out otherwise
+
+uname=`cat /proc/version`
+ver=`expr "x$uname" : 'xLinux version \([^ ]\+\) '`
+
+if [ -n "$BOOT_ROOT" -a ! -d "$BOOT_ROOT/lib/modules/$ver" ]; then
+ echo -e "\033[1m===================="
+ echo "ERROR!"
+ echo "There are no modules for this kernel"
+ echo "version ($ver) in the root file "
+ echo "system, which will lead to boot failure or"
+ echo "broken functionally. If you performed"
+ echo "a kernel upgrade, make sure that version"
+ echo "installed in root filesystem matches"
+ echo "version used in bootloader."
+ echo -e "====================\033[0m"
+ echo
+
+ echo "System halted"
+ while true; do
+ sleep 10000
+ done
+fi
diff --git a/packages/initrdscripts/initramfs-module-check-modules_1.0.bb b/packages/initrdscripts/initramfs-module-check-modules_1.0.bb
new file mode 100644
index 0000000000..6986316a6f
--- /dev/null
+++ b/packages/initrdscripts/initramfs-module-check-modules_1.0.bb
@@ -0,0 +1,12 @@
+SRC_URI = "file://90-check-modules.sh"
+PR = "r0"
+DESCRIPTION = "An initramfs module for checking that kernel modules exist in rootfs"
+RDEPENDS = "initramfs-uniboot"
+
+do_install() {
+ install -d ${D}/initrd.d
+ install -m 0755 ${WORKDIR}/90-check-modules.sh ${D}/initrd.d/
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} += " /initrd.d/* "