aboutsummaryrefslogtreecommitdiffstats
path: root/packages/initrdscripts
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-07-19 21:11:07 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-07-19 21:11:07 +0000
commitd25cb314d2672973d3eed42e736e681a3e3a4337 (patch)
tree157fe1bd9886244a1d7511e266b41b022efe2c4a /packages/initrdscripts
parent576e89d4b3fbf612cb85bca4cf830ac76b1a8ba6 (diff)
downloadopenembedded-d25cb314d2672973d3eed42e736e681a3e3a4337.tar.gz
initramfs-module-nfs: Make it actually mount NFS by using the same option as kernel does.
Diffstat (limited to 'packages/initrdscripts')
-rw-r--r--packages/initrdscripts/files/nfsboot.sh7
-rw-r--r--packages/initrdscripts/initramfs-module-nfs_0.1.bb2
2 files changed, 7 insertions, 2 deletions
diff --git a/packages/initrdscripts/files/nfsboot.sh b/packages/initrdscripts/files/nfsboot.sh
index 62a044267a..5129a53ebb 100644
--- a/packages/initrdscripts/files/nfsboot.sh
+++ b/packages/initrdscripts/files/nfsboot.sh
@@ -1,6 +1,11 @@
#!/bin/sh
if [ "$ROOT_DEVICE" = "/dev/nfs" ]; then
+
+ # These correspond to what kernel itself uses
+ # DO NOT CHANGE!
+ NFS_OPTIONS="-o nfsvers=2,nolock"
+
for arg in $CMDLINE; do
echo $arg
optarg=`expr "x$arg" : 'x[^=]*=\(.*\)'`
@@ -33,6 +38,6 @@ if [ "$ROOT_DEVICE" = "/dev/nfs" ]; then
)
echo "booting from NFS: $nfsroot"
- mount -t nfs $nfsroot /mnt
+ mount -t nfs $NFS_OPTIONS $nfsroot /mnt
BOOT_ROOT=/mnt
fi
diff --git a/packages/initrdscripts/initramfs-module-nfs_0.1.bb b/packages/initrdscripts/initramfs-module-nfs_0.1.bb
index 90b80a31b1..9f4436a26b 100644
--- a/packages/initrdscripts/initramfs-module-nfs_0.1.bb
+++ b/packages/initrdscripts/initramfs-module-nfs_0.1.bb
@@ -1,5 +1,5 @@
SRC_URI = "file://nfsboot.sh"
-PR = "r0"
+PR = "r1"
do_install() {
install -m 0755 ${WORKDIR}/nfsboot.sh ${D}/initrd.d/nfs