aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ipkg-utils
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-04-04 22:15:55 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-04 22:15:55 +0000
commit7a05d5e17437e0010a7b68de5979e6965a4fe204 (patch)
tree3ceb57fb6ec0dc304db894484331ae540ab60fda /packages/ipkg-utils
parentf6d5785f33bcec280086c2e5fbd8bee727578f74 (diff)
downloadopenembedded-7a05d5e17437e0010a7b68de5979e6965a4fe204.tar.gz
ipkg-utils/ipkg-link: Add patch from .oz354x
Diffstat (limited to 'packages/ipkg-utils')
-rw-r--r--packages/ipkg-utils/ipkg-link/.mtn2git_empty0
-rw-r--r--packages/ipkg-utils/ipkg-link/link-vfat-libs.patch34
-rw-r--r--packages/ipkg-utils/ipkg-link_1.6+cvs20050404.bb5
3 files changed, 37 insertions, 2 deletions
diff --git a/packages/ipkg-utils/ipkg-link/.mtn2git_empty b/packages/ipkg-utils/ipkg-link/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ipkg-utils/ipkg-link/.mtn2git_empty
diff --git a/packages/ipkg-utils/ipkg-link/link-vfat-libs.patch b/packages/ipkg-utils/ipkg-link/link-vfat-libs.patch
new file mode 100644
index 0000000000..7f495f9f4c
--- /dev/null
+++ b/packages/ipkg-utils/ipkg-link/link-vfat-libs.patch
@@ -0,0 +1,34 @@
+--- ipkg-utils/ipkg-link.orig 2006-04-05 00:08:28.518992136 +0200
++++ ipkg-utils/ipkg-link 2006-04-05 00:08:40.399186072 +0200
+@@ -58,6 +58,31 @@
+ `ln -s "$PREFIX$line" "$line"`
+ fi
+ fi
++
++ # The next function checks whether the _source_ file (ie: /media/card/something)
++ # does actually exist. If it doesn't, it could by a library symlink (ie: libsomething.0.1 -> libsomething.0)
++ # Since VFAT & friends do not support symlinks, these library links would not exist after installation
++ # and trying to symlink them into the rootfs with ipkg-link results in unconnected symlinks in the rootfs.
++ # So we use the real lib file in /media/card/whatever and create all needed symlinks in the rootfs
++ # using the real file as source.
++
++ if [ ! -e "$PREFIX$line" ]; then
++ if ( echo "$line" | grep -q "lib" ) ; then
++ libsearchfile=$(echo $line | sed -e "s#[a-z0-9/.]*/##g")
++ libfoundfiles=$(find $PREFIX -name "$libsearchfile*")
++
++ for liblinkfile in $libfoundfiles; do
++ echo "Linking $line to $liblinkfile"
++ # link will be pointing to nowhere
++ if test -L $line; then
++ rm -f $line
++ fi
++ ln -s $liblinkfile $line
++ done
++ else
++ echo "WARNING: Source file [$PREFIX$line] is missing!"
++ fi
++ fi
+ done
+ }
+
diff --git a/packages/ipkg-utils/ipkg-link_1.6+cvs20050404.bb b/packages/ipkg-utils/ipkg-link_1.6+cvs20050404.bb
index 826a9fbdb6..35e5ba1086 100644
--- a/packages/ipkg-utils/ipkg-link_1.6+cvs20050404.bb
+++ b/packages/ipkg-utils/ipkg-link_1.6+cvs20050404.bb
@@ -3,9 +3,10 @@ DESCRIPTION = "Itsy Package Manager utilities link script"
LICENSE = "GPL"
CONFLICTS = "ipkg-utils"
SRCDATE = "20050404"
-PR = "r3"
+PR = "r4"
-SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils"
+SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils \
+ file://link-vfat-libs.patch;patch=1"
S = "${WORKDIR}/ipkg-utils"