aboutsummaryrefslogtreecommitdiffstats
path: root/packages/iputils
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-07-10 02:46:22 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-10 02:46:22 +0000
commitc06b6204c20c1624dbe4d0dfd113309332fadbcc (patch)
tree218131ad7090ff993dac7487fe3735c1aea31df3 /packages/iputils
parent6b1e91be1a11a991edb6b46c3454eb4fdc4cfd02 (diff)
downloadopenembedded-c06b6204c20c1624dbe4d0dfd113309332fadbcc.tar.gz
iputils 20020927: Add support for building with glibc 2.4. In glibc 2.4
several of the IPv6 constants were reanmed - this changes to using the new versions but also redefines them to the old versions when being used on glibc < 2.3 or uclibc.
Diffstat (limited to 'packages/iputils')
-rw-r--r--packages/iputils/files/glibc-2.4-compat.patch78
-rw-r--r--packages/iputils/iputils_20020927.bb8
2 files changed, 83 insertions, 3 deletions
diff --git a/packages/iputils/files/glibc-2.4-compat.patch b/packages/iputils/files/glibc-2.4-compat.patch
new file mode 100644
index 0000000000..736d660c3d
--- /dev/null
+++ b/packages/iputils/files/glibc-2.4-compat.patch
@@ -0,0 +1,78 @@
+This patch renames the ICMP6 variables to the new names, as used in glibc
+2.4. It also provides a header which will define the new names to the old
+names - as used in glibc < 2.4 and uclibc, so that it'll build on
+uclibc, glibc < 2.4 and glibc 2.4.
+
+--- iputils/ping6.c 2006/07/10 02:23:05 1.1
++++ iputils/ping6.c 2006/07/10 02:30:06
+@@ -71,6 +71,7 @@
+ #include <netinet/in.h>
+ #include <netinet/ip6.h>
+ #include <netinet/icmp6.h>
++#include "glibc_compat.h"
+
+ /* define to specify we want type0 routing headers */
+ #define IPV6_SRCRT_TYPE_0 0
+@@ -86,7 +87,6 @@
+ #define HAVE_SIN6_SCOPEID 1
+ #endif
+
+-
+ uint32_t flowlabel;
+ uint32_t tclass;
+ struct cmsghdr *srcrt;
+@@ -781,7 +781,7 @@
+ case ICMP6_DST_UNREACH_ADMIN:
+ printf("Administratively prohibited");
+ break;
+- case ICMP6_DST_UNREACH_NOTNEIGHBOR:
++ case ICMP6_DST_UNREACH_BEYONDSCOPE:
+ printf("Not neighbour");
+ break;
+ case ICMP6_DST_UNREACH_ADDR:
+@@ -827,13 +827,13 @@
+ case ICMP6_ECHO_REPLY:
+ printf("Echo reply");
+ break;
+- case ICMP6_MEMBERSHIP_QUERY:
++ case MLD_LISTENER_QUERY:
+ printf("MLD Query");
+ break;
+- case ICMP6_MEMBERSHIP_REPORT:
++ case MLD_LISTENER_REPORT:
+ printf("MLD Report");
+ break;
+- case ICMP6_MEMBERSHIP_REDUCTION:
++ case MLD_LISTENER_REDUCTION:
+ printf("MLD Reduction");
+ break;
+ default:
+--- /dev/null 2006-07-03 23:05:35.026189000 +1000
++++ iputils/glibc_compat.h 2006-07-10 12:30:04.000000000 +1000
+@@ -0,0 +1,26 @@
++/*
++ * glibc 2.4 renamed some of the IPv6 related constants.
++ *
++ * We use the new names and rename them back the old names if the new names
++ * are not definied anyway.
++ */
++#ifndef GLIBC_COMPAT
++#define GLIBC_COMPAT
++
++#ifndef ICMP6_DST_UNREACH_BEYONDSCOPE
++#define ICMP6_DST_UNREACH_BEYONDSCOPE ICMP6_DST_UNREACH_NOTNEIGHBOR
++#endif
++
++#ifndef MLD_LISTENER_QUERY
++#define MLD_LISTENER_QUERY ICMP6_MEMBERSHIP_QUERY
++#endif
++
++#ifndef MLD_LISTENER_REPORT
++#define MLD_LISTENER_REPORT ICMP6_MEMBERSHIP_REPORT
++#endif
++
++#ifndef MLD_LISTENER_REDUCTION
++#define MLD_LISTENER_REDUCTION ICMP6_MEMBERSHIP_REDUCTION
++#endif
++
++#endif
diff --git a/packages/iputils/iputils_20020927.bb b/packages/iputils/iputils_20020927.bb
index ac3c3d31a8..79a7021b5a 100644
--- a/packages/iputils/iputils_20020927.bb
+++ b/packages/iputils/iputils_20020927.bb
@@ -1,9 +1,10 @@
SECTION = "console/network"
DESCRIPTION = "Utilities for the IP protocol, including traceroute6, \
tracepath, tracepath6, ping, ping6 and arping."
+SECTION = "console/network"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
LICENSE ="BSD"
-PRIORITY = "optional"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.tux.org/pub/people/alexey-kuznetsov/ip-routing/iputils-ss020927.tar.gz \
file://debian-fixes.patch;patch=1 \
@@ -11,7 +12,8 @@ SRC_URI = "http://www.tux.org/pub/people/alexey-kuznetsov/ip-routing/iputils-ss0
file://standard-header-types.patch;patch=1 \
file://tracepath6-mtu-opt.patch;patch=1 \
file://remove-glibc-headers.patch;patch=1 \
- file://iputils-retvals.patch;patch=1"
+ file://iputils-retvals.patch;patch=1 \
+ file://glibc-2.4-compat.patch;patch=1"
S = "${WORKDIR}/iputils"
PACKAGES = "${PN}-ping ${PN}-ping6 ${PN}-arping ${PN}-tracepath ${PN}-tracepath6 ${PN}-traceroute6 ${PN}-doc"