aboutsummaryrefslogtreecommitdiffstats
path: root/packages/irssi
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/irssi
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/irssi')
-rw-r--r--packages/irssi/irssi_cvs.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/packages/irssi/irssi_cvs.bb b/packages/irssi/irssi_cvs.bb
index e69de29bb2..f1a2bc6f7c 100644
--- a/packages/irssi/irssi_cvs.bb
+++ b/packages/irssi/irssi_cvs.bb
@@ -0,0 +1,69 @@
+DESCRIPTION = "Irssi is a modular IRC client with Perl scripting."
+HOMEPAGE = "http://irssi.org/"
+SECTION = "console/network"
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DEPENDS += "ncurses glib-2.0"
+PV = "0.8.9+cvs${CVSDATE}"
+PR = "r2"
+
+PACKAGES += "${PN}-common"
+FILES_${PN} = "${bindir}/irssi"
+FILES_${PN}-common = "${datadir}/irssi ${sysconfdir}"
+RDEPENDS_${PN} += "${PN}-common"
+
+inherit autotools
+
+SRC_URI = "cvs://anonymous:@cvs.irssi.org/home/cvs;module=irssi \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/irssi"
+
+EXTRA_OECONF = "--enable-ipv6 \
+ --disable-ssl \
+ --disable-glibtest \
+ --without-socks \
+ --with-textui \
+ --without-bot \
+ --without-proxy \
+ --without-glib1 \
+ --with-glib2 \
+ --with-perl=no \
+ --with-glib-prefix=${STAGING_LIBDIR}/.. \
+ --with-glib-exec-prefix=${STAGING_LIBDIR}/.. \
+ --with-ncurses=${STAGING_LIBDIR}/.."
+
+do_configure () {
+ # create help files
+ echo "Creating help files..."
+ perl syntax.pl
+
+ files=`echo docs/help/in/*.in|sed -e 's,docs/help/in/Makefile.in ,,' -e 's,docs/help/in/,!,g' -e 's/\.in /.in ?/g'`
+ cat docs/help/in/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/in/Makefile.am
+
+ files=`echo $files|sed 's/\.in//g'`
+ cat docs/help/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/Makefile.am
+
+ # .HTML -> .txt with lynx
+ # echo "Documentation: html -> txt..."
+ # lynx -dump -nolist docs/faq.html|perl -pe 's/^ *//; if ($_ eq "\n" && $state eq "Q") { $_ = ""; } elsif (/^([QA]):/) { $state = $1 } elsif ($_ ne "\n") { $_ = " $_"; };' > docs/faq.txt
+ > docs/faq.txt
+
+ autotools_do_configure
+}
+
+do_stage () {
+ find . -name \*.h | for h in `cat`; do
+ install -d ${STAGING_LIBDIR}/../irssi/`dirname $h`
+ install -m 0644 $h ${STAGING_LIBDIR}/../irssi/$h
+ done
+ find . -name lib\*.a | for l in `cat`; do
+ install -d ${STAGING_LIBDIR}/../irssi/`dirname $l`
+ install -m 0644 $l ${STAGING_LIBDIR}/../irssi/$l
+ done
+ install -m 0644 irssi-config ${STAGING_LIBDIR}/../irssi/
+}
+
+do_install () {
+ autotools_do_install
+ rm -f ${D}${docdir}/irssi/faq.txt
+}