aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp425-eth
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-06-17 06:36:43 +0000
committerJohn Bowler <jbowler@nslu2-linux.org>2005-06-17 06:36:43 +0000
commit07a813e818671678290cd0f2b58b693cabc83945 (patch)
treea93e0561cc665a243b3d7636f6ce046dc3763b68 /packages/ixp425-eth
parent17eda4148261ba29cc23c949c0e2da2a70030336 (diff)
downloadopenembedded-07a813e818671678290cd0f2b58b693cabc83945.tar.gz
Add SA_SAMPLE_RANDOM to those request_irq calls which
correspond to packet driven (as opposed to timer driven) ethernet interrupts. This provides genuine random input to the kernel random driver. BKrev: 42b26f7bNoumAACylLJQfYG5oSQoOw
Diffstat (limited to 'packages/ixp425-eth')
-rw-r--r--packages/ixp425-eth/files/intdriven.patch55
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.1.bb2
2 files changed, 56 insertions, 1 deletions
diff --git a/packages/ixp425-eth/files/intdriven.patch b/packages/ixp425-eth/files/intdriven.patch
index e69de29bb2..af3452f652 100644
--- a/packages/ixp425-eth/files/intdriven.patch
+++ b/packages/ixp425-eth/files/intdriven.patch
@@ -0,0 +1,55 @@
+--- ixp425-eth-1.1-r4/ixp425_eth.c 2005-06-16 00:47:55.360598896 -0700
++++ ixp425-eth-1.1-r4/ixp425_eth.c 2005-06-16 18:42:09.840377651 -0700
+@@ -1636,6 +1636,7 @@
+ return 0;
+ }
+
++#if 0 /* UNUSED - used for polling */
+ /* The QMgr dispatch entry point can be called from the
+ * IXP425_INT_LVL_QM1 irq (which will trigger
+ * an interrupt for every packet) or a timer (which will
+@@ -1686,7 +1687,7 @@
+ */
+ if (request_irq(IXP425_INT_LVL_QM1,
+ dev_qmgr_os_isr,
+- SA_SHIRQ,
++ SA_SHIRQ | SA_SAMPLE_RANDOM,
+ DRV_NAME,
+ (void *)IRQ_ANY_PARAMETER))
+ {
+@@ -1710,6 +1711,7 @@
+ }
+ return 0;
+ }
++#endif
+
+ /* Enable the MAC port.
+ * Called on do_dev_open, dev_tx_timeout and mtu size changes
+@@ -2234,7 +2236,7 @@
+ */
+ if (request_irq(IXP425_INT_LVL_QM1,
+ dev_qmgr_os_isr,
+- SA_SHIRQ,
++ SA_SHIRQ | SA_SAMPLE_RANDOM,
+ DRV_NAME,
+ (void *)IRQ_ANY_PARAMETER))
+ {
+@@ -2669,6 +2671,10 @@
+
+ TRACE;
+
++#if 0 /* DISABLE polling */
++ /* Enable Interrupt driven driver
++ * see http://www.nslu2-linux.org/wiki/OpenSlug/StabilizeEthernetDriver
++ */
+ if (no_csr_init == 0) /* module parameter */
+ {
+ /* The QMgr dispatch entry point is called from the IXP425_INT_LVL_QM1 irq
+@@ -2681,6 +2687,7 @@
+ return res;
+ }
+ }
++#endif
+
+ TRACE;
+
diff --git a/packages/ixp425-eth/ixp425-eth_1.1.bb b/packages/ixp425-eth/ixp425-eth_1.1.bb
index 40e7f19f54..568f6bd97c 100644
--- a/packages/ixp425-eth/ixp425-eth_1.1.bb
+++ b/packages/ixp425-eth/ixp425-eth_1.1.bb
@@ -7,7 +7,7 @@ SRC_URI = "http://www.intel.com/design/network/swsup/ixp400LinuxEthernetDriverPa
file://intdriven.patch;patch=1 \
file://pollcontroller.patch;patch=1 \
file://mm4.patch;patch=1"
-PR = "r3"
+PR = "r4"
S = "${WORKDIR}"