aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp425-eth
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-21 00:12:31 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-21 00:12:31 +0000
commit0c751c19a7e2899fb7e5ef19a05fda53b91fb899 (patch)
tree4ddc44c23e1c4adb9ff1f4e02d5b313e8b946ad8 /packages/ixp425-eth
parent8c9e9a740a81d8433c64242d499768972f31bbdd (diff)
downloadopenembedded-0c751c19a7e2899fb7e5ef19a05fda53b91fb899.tar.gz
ixp400-eth: correct the maclist handling in 1.5
Diffstat (limited to 'packages/ixp425-eth')
-rw-r--r--packages/ixp425-eth/ixp400-eth-1.5/mac-address.patch2
-rw-r--r--packages/ixp425-eth/ixp400-eth_1.5.bb9
2 files changed, 5 insertions, 6 deletions
diff --git a/packages/ixp425-eth/ixp400-eth-1.5/mac-address.patch b/packages/ixp425-eth/ixp400-eth-1.5/mac-address.patch
index 1845dd3089..471967fc68 100644
--- a/packages/ixp425-eth/ixp400-eth-1.5/mac-address.patch
+++ b/packages/ixp425-eth/ixp400-eth-1.5/mac-address.patch
@@ -109,7 +109,7 @@
+ /* fix dev_max_count to maclist_count - the actual number of
+ * available MACs
+ */
-+ if (dev_max_count <= 0)
++ if (dev_max_count <= 0 || (dev_max_count > maclist_count() && maclist_count() > 0))
+ dev_max_count = maclist_count();
+ if (dev_max_count <= 0)
+ dev_max_count = 1;
diff --git a/packages/ixp425-eth/ixp400-eth_1.5.bb b/packages/ixp425-eth/ixp400-eth_1.5.bb
index c14580248f..8833b850ec 100644
--- a/packages/ixp425-eth/ixp400-eth_1.5.bb
+++ b/packages/ixp425-eth/ixp400-eth_1.5.bb
@@ -4,6 +4,10 @@
MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
HOMEPAGE = "http://www.intel.com/design/network/products/npfamily/ixp420.htm"
LICENSE = "GPL"
+PR = "r7"
+
+DEPENDS = "ixp4xx-csr"
+RDEPENDS = "ixp4xx-csr"
SRC_URI = "ftp://aiedownload.intel.com/df-support/9519/eng/GPL_ixp400LinuxEthernetDriverPatch-1_5.zip"
SRC_URI += "file://2.6.14.patch;patch=1"
@@ -20,11 +24,6 @@ SRC_URI += "file://debug.patch;patch=1"
SRC_URI += "file://Makefile.patch;patch=1"
SRC_URI += "file://modprobe.conf"
-PR = "r6"
-
-DEPENDS = "ixp4xx-csr"
-RDEPENDS = "ixp4xx-csr"
-
S = "${WORKDIR}"
COMPATIBLE_HOST = "^arm.*-linux.*"