aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp425-eth
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-26 23:43:09 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-26 23:43:09 +0000
commit1a36187e9247abbd324a87342a912c2f5098e0c5 (patch)
treef0694ed249056cfcc415013e222c0a9e2d7299a2 /packages/ixp425-eth
parentb85ec984acd1fdaca259b09b024ece42ee1b869e (diff)
downloadopenembedded-1a36187e9247abbd324a87342a912c2f5098e0c5.tar.gz
ixp4xx-kernel: clean up maclist code in 2.6.15
ixp400-eth: merge clean up to maclist_read in 1.5 - maclist_read is now (void), it always succeeds
Diffstat (limited to 'packages/ixp425-eth')
-rw-r--r--packages/ixp425-eth/ixp400-eth-1.5/mac-address.patch19
-rw-r--r--packages/ixp425-eth/ixp400-eth_1.5.bb2
2 files changed, 12 insertions, 9 deletions
diff --git a/packages/ixp425-eth/ixp400-eth-1.5/mac-address.patch b/packages/ixp425-eth/ixp400-eth-1.5/mac-address.patch
index 471967fc68..e23eaf5f2b 100644
--- a/packages/ixp425-eth/ixp400-eth-1.5/mac-address.patch
+++ b/packages/ixp425-eth/ixp400-eth-1.5/mac-address.patch
@@ -1,3 +1,8 @@
+Patch to use maclist - get the MAC to use from the board level
+MAC repository based on the device portId.
+
+Signed-off-by: John Bowler <jbowler@acm.org>
+
--- ixp400-eth/ixp400_eth.c 1970-01-01 00:00:00.000000000 +0000
+++ ixp400-eth/ixp400_eth.c 1970-01-01 00:00:00.000000000 +0000
@@ -23,10 +23,10 @@
@@ -32,7 +37,7 @@
#endif
#ifndef CONFIG_IXP400_NAPI
-@@ -621,21 +624,6 @@ static phy_cfg_t default_phy_cfg[] =
+@@ -614,21 +617,6 @@ static phy_cfg_t default_phy_cfg[] =
#endif
};
@@ -54,7 +59,7 @@
/* Default mapping of NpeImageIds for EthAcc Ports
* Default is
* IX_ETH_PORT_1 -> IX_ETH_NPE_B
-@@ -3337,28 +3325,13 @@ static int __devinit dev_eth_probe(struc
+@@ -3325,28 +3313,10 @@ static int __devinit dev_eth_probe(struc
/* Defines the unicast MAC address
*
@@ -70,10 +75,7 @@
- *
+ * The code reads from the maclist API.
*/
-+ if (maclist_read((u8(*)[6])&ndev->dev_addr, priv->port_id) ||
-+ !is_valid_ether_addr(ndev->dev_addr))
-+ random_ether_addr(ndev->dev_addr);
-
+-
- memcpy(ndev->dev_addr,
- &default_mac_addr[priv->port_id].macAddress,
- IX_IEEE803_MAC_ADDRESS_SIZE);
@@ -84,11 +86,12 @@
- if (is_valid_ether_addr(ndev->dev_addr))
- {
- P_WARN("Use default MAC address %2.2x:%2.2x:%2.2x:%2.2x:%2.2x:%2.2x for port %d\n",
++ maclist_read((u8(*)[6])&ndev->dev_addr, priv->port_id);
+ P_INFO("Use MAC address %2.2x:%2.2x:%2.2x:%2.2x:%2.2x:%2.2x for port %d\n",
(unsigned)ndev->dev_addr[0],
(unsigned)ndev->dev_addr[1],
(unsigned)ndev->dev_addr[2],
-@@ -3366,7 +3339,6 @@ static int __devinit dev_eth_probe(struc
+@@ -3354,7 +3324,6 @@ static int __devinit dev_eth_probe(struc
(unsigned)ndev->dev_addr[4],
(unsigned)ndev->dev_addr[5],
priv->port_id);
@@ -96,7 +99,7 @@
/* Set/update the internal packet size
* This can be overriden later by the command
-@@ -3584,12 +3556,15 @@ static int __init ixp400_eth_init(void)
+@@ -3562,12 +3531,15 @@ static int __init ixp400_eth_init(void)
TRACE;
diff --git a/packages/ixp425-eth/ixp400-eth_1.5.bb b/packages/ixp425-eth/ixp400-eth_1.5.bb
index 8833b850ec..e54077460b 100644
--- a/packages/ixp425-eth/ixp400-eth_1.5.bb
+++ b/packages/ixp425-eth/ixp400-eth_1.5.bb
@@ -4,7 +4,7 @@
MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
HOMEPAGE = "http://www.intel.com/design/network/products/npfamily/ixp420.htm"
LICENSE = "GPL"
-PR = "r7"
+PR = "r8"
DEPENDS = "ixp4xx-csr"
RDEPENDS = "ixp4xx-csr"