aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp425-eth
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-11 07:09:54 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-11 07:09:54 +0000
commit3333852bd0bc5b926374b919a6fd2794fbadffd6 (patch)
treefab3192bc108ec0bdaa76b0ddf1bd8ddfdb03caa /packages/ixp425-eth
parentc103910fd158f991efa64e1aefd0b267552b6767 (diff)
downloadopenembedded-3333852bd0bc5b926374b919a6fd2794fbadffd6.tar.gz
slugos-image: remove spurious DEPENDS in conf
- this upgrades slugos-image to the new RDEPENDS only world, some missing (R)dependencies are corrected slugos-init: remove virtual/ixp-eth in 0.10 - this stuff is no longer necessary and the modprobe.conf has been moved to the ixp-eth module rather than having it incorrectly introduced in a non-dependent module.
Diffstat (limited to 'packages/ixp425-eth')
-rw-r--r--packages/ixp425-eth/files/modprobe.conf3
-rw-r--r--packages/ixp425-eth/ixp400-eth-1.4/modprobe.conf3
-rw-r--r--packages/ixp425-eth/ixp400-eth-1.5/modprobe.conf3
-rw-r--r--packages/ixp425-eth/ixp400-eth_1.4.bb6
-rw-r--r--packages/ixp425-eth/ixp400-eth_1.5.bb6
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.1.bb6
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.2.bb6
7 files changed, 29 insertions, 4 deletions
diff --git a/packages/ixp425-eth/files/modprobe.conf b/packages/ixp425-eth/files/modprobe.conf
new file mode 100644
index 0000000000..bfcbf916cf
--- /dev/null
+++ b/packages/ixp425-eth/files/modprobe.conf
@@ -0,0 +1,3 @@
+# Add an alias for eth0 to ixp425_eth to cause the S40networking
+# init script to load the ixp425_eth driver on the first boot
+alias eth0 ixp425_eth
diff --git a/packages/ixp425-eth/ixp400-eth-1.4/modprobe.conf b/packages/ixp425-eth/ixp400-eth-1.4/modprobe.conf
new file mode 100644
index 0000000000..9d579eeac1
--- /dev/null
+++ b/packages/ixp425-eth/ixp400-eth-1.4/modprobe.conf
@@ -0,0 +1,3 @@
+# Add an alias for eth0 to ixp400_eth to cause the S40networking
+# init script to load the ixp400_eth driver on the first boot
+alias eth0 ixp400_eth
diff --git a/packages/ixp425-eth/ixp400-eth-1.5/modprobe.conf b/packages/ixp425-eth/ixp400-eth-1.5/modprobe.conf
new file mode 100644
index 0000000000..9d579eeac1
--- /dev/null
+++ b/packages/ixp425-eth/ixp400-eth-1.5/modprobe.conf
@@ -0,0 +1,3 @@
+# Add an alias for eth0 to ixp400_eth to cause the S40networking
+# init script to load the ixp400_eth driver on the first boot
+alias eth0 ixp400_eth
diff --git a/packages/ixp425-eth/ixp400-eth_1.4.bb b/packages/ixp425-eth/ixp400-eth_1.4.bb
index 94024e9b75..6e14f67c0e 100644
--- a/packages/ixp425-eth/ixp400-eth_1.4.bb
+++ b/packages/ixp425-eth/ixp400-eth_1.4.bb
@@ -10,7 +10,8 @@ SRC_URI += "file://2.6.13.patch;patch=1"
SRC_URI += "file://2.6.14.patch;patch=1"
SRC_URI += "file://ixp400_pollcontroller.patch;patch=1"
SRC_URI += "file://2.6.14-mm.patch;patch=1"
-PR = "r7"
+SRC_URI += "file://modprobe.conf"
+PR = "r9"
DEPENDS = "ixp4xx-csr"
RDEPENDS = "ixp4xx-csr"
@@ -20,6 +21,7 @@ S = "${WORKDIR}"
COMPATIBLE_HOST = "^arm.*-linux.*"
PROVIDES = "virtual/ixp-eth"
+RPROVIDES = "ixp-eth"
inherit module
@@ -53,4 +55,6 @@ do_compile () {
do_install () {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
install -m 0644 ixp400_eth.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/
+ install -d ${D}${sysconfdir}/modprobe.d
+ install -m 0644 modprobe.conf ${D}${sysconfdir}/modprobe.d/eth0
}
diff --git a/packages/ixp425-eth/ixp400-eth_1.5.bb b/packages/ixp425-eth/ixp400-eth_1.5.bb
index f5d2b34070..8d922f81d7 100644
--- a/packages/ixp425-eth/ixp400-eth_1.5.bb
+++ b/packages/ixp425-eth/ixp400-eth_1.5.bb
@@ -18,8 +18,9 @@ SRC_URI += "file://continue-if-qmgr-init-fails.patch;patch=1"
SRC_URI += "file://netdev_max_backlog.patch;patch=1"
SRC_URI += "file://debug.patch;patch=1"
SRC_URI += "file://Makefile.patch;patch=1"
+SRC_URI += "file://modprobe.conf"
-PR = "r3"
+PR = "r5"
DEPENDS = "ixp4xx-csr"
RDEPENDS = "ixp4xx-csr"
@@ -29,6 +30,7 @@ S = "${WORKDIR}"
COMPATIBLE_HOST = "^arm.*-linux.*"
PROVIDES = "virtual/ixp-eth"
+RPROVIDES = "ixp-eth"
inherit module
@@ -84,4 +86,6 @@ do_compile_append () {
do_install () {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
install -m 0644 ixp400_eth.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/
+ install -d ${D}${sysconfdir}/modprobe.d
+ install -m 0644 modprobe.conf ${D}${sysconfdir}/modprobe.d/eth0
}
diff --git a/packages/ixp425-eth/ixp425-eth_1.1.bb b/packages/ixp425-eth/ixp425-eth_1.1.bb
index 7f55bcec3b..53e713178a 100644
--- a/packages/ixp425-eth/ixp425-eth_1.1.bb
+++ b/packages/ixp425-eth/ixp425-eth_1.1.bb
@@ -10,7 +10,8 @@ SRC_URI = "http://www.intel.com/design/network/swsup/ixp400LinuxEthernetDriverPa
file://mm4.patch;patch=1"
SRC_URI += "file://2.6.13.patch;patch=1"
SRC_URI += "file://2.6.14.patch;patch=1"
-PR = "r12"
+SRC_URI += "file://modprobe.conf"
+PR = "r15"
RDEPENDS = "ixp4xx-csr"
@@ -19,6 +20,7 @@ S = "${WORKDIR}"
COMPATIBLE_HOST = "^armeb-linux.*"
PROVIDES = "virtual/ixp-eth"
+RPROVIDES = "ixp-eth"
inherit module
@@ -46,4 +48,6 @@ do_compile () {
do_install () {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
install -m 0644 ixp425_eth.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/
+ install -d ${D}${sysconfdir}/modprobe.d
+ install -m 0644 modprobe.conf ${D}${sysconfdir}/modprobe.d/eth0
}
diff --git a/packages/ixp425-eth/ixp425-eth_1.2.bb b/packages/ixp425-eth/ixp425-eth_1.2.bb
index 9336e1fe6d..3cc9a6c70a 100644
--- a/packages/ixp425-eth/ixp425-eth_1.2.bb
+++ b/packages/ixp425-eth/ixp425-eth_1.2.bb
@@ -8,7 +8,8 @@ SRC_URI += "file://ixp400linuxethernetdriver-1_2-kernel26_hr_20050929.patch;patc
SRC_URI += "file://makefile.patch;patch=1"
SRC_URI += "file://2.6.13.patch;patch=1"
SRC_URI += "file://2.6.14.patch;patch=1"
-PR = "r2"
+SRC_URI += "file://modprobe.conf"
+PR = "r4"
DEPENDS = "ixp4xx-csr"
RDEPENDS = "ixp4xx-csr"
@@ -18,6 +19,7 @@ S = "${WORKDIR}"
COMPATIBLE_HOST = "^armeb-linux.*"
PROVIDES = "virtual/ixp-eth"
+RPROVIDES = "ixp-eth"
inherit module
@@ -46,4 +48,6 @@ do_compile () {
do_install () {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
install -m 0644 ixp425_eth.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/
+ install -d ${D}${sysconfdir}/modprobe.d
+ install -m 0644 modprobe.conf ${D}${sysconfdir}/modprobe.d/eth0
}