aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp425-eth
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 15:40:10 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 15:40:10 +0000
commit5ab4bb661fbbb0b656139c1073598859e16b2484 (patch)
treea93dae102b3d4a654bbe55a75d06bca8ffc16f9a /packages/ixp425-eth
parent3fff43da673534e60500beeb61ff7875f72cdff4 (diff)
downloadopenembedded-5ab4bb661fbbb0b656139c1073598859e16b2484.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/20 10:35:16-05:00 handhelds.org!kergoth Add patcher-native to ixp425-eth's depends. Really, it shouldnt be calling out patcher explicitly in its tasks at all, since the .bb shouldn't have any knowledge of how patches are applied. That said, this should at least get it building again in the meantime. 2005/01/20 10:29:55-05:00 handhelds.org!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into handhelds.org:/home/kergoth/code/openembedded 2005/01/20 10:29:38-05:00 handhelds.org!kergoth Kill off module-init-tools 3.1-pre5. It didn't have the correct set of patches applied, and there's no reason to keep around the old version. BKrev: 41efd0darfDOqFGMjJ_Ozpgb-p9H9g
Diffstat (limited to 'packages/ixp425-eth')
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/packages/ixp425-eth/ixp425-eth_1.1.bb b/packages/ixp425-eth/ixp425-eth_1.1.bb
index e69de29bb2..6e852bed17 100644
--- a/packages/ixp425-eth/ixp425-eth_1.1.bb
+++ b/packages/ixp425-eth/ixp425-eth_1.1.bb
@@ -0,0 +1,47 @@
+DEPENDS = "ixp4xx-csr patcher-native"
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+SRC_URI = "http://www.intel.com/design/network/swsup/ixp400LinuxEthernetDriverPatch-1_1.zip \
+ file://makefile.patch;patch=1 \
+ file://ethhdr.patch;patch=1"
+S = "${WORKDIR}"
+
+COMPATIBLE_HOST = "^armeb-linux.*"
+
+inherit module
+
+do_ixp425_c_patch_fetch () {
+ if test ! -e ${DL_DIR}/ixp425_eth.c.patch.md5; then
+ cd ${DL_DIR}
+ wget -Oixp425_eth.c.patch http://sourceforge.net/tracker/download.php?group_id=74209\&atid=544386\&file_id=90129\&aid=970193
+ md5sum > ixp425_eth.c.patch.md5
+ fi
+}
+
+addtask ixp425_c_patch_fetch after do_fetch before do_unpack
+
+do_ixp425_c_patch_unpack () {
+ install -m 0644 ${DL_DIR}/ixp425_eth.c.patch ${WORKDIR}/
+}
+
+addtask ixp425_c_patch_unpack after do_unpack before do_pre_patch
+
+do_pre_patch () {
+ patcher -p 0 -i ixp425_eth_1_1_update_nf_bridge.patch
+ patcher -f -p 0 -i ixp425_eth.c.patch
+}
+
+addtask pre_patch before do_patch
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake 'KDIR=${STAGING_KERNEL_DIR}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}' \
+ 'EXTRA_CFLAGS=-I${STAGING_INCDIR}/linux/ixp4xx-csr -I${STAGING_KERNEL_DIR}/include'
+}
+
+do_install () {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net
+ install -m 0644 ixp425_eth.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/
+}