aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp425-eth
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-10-05 18:08:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-05 18:08:33 +0000
commit962eb38eb1b819c02545cbc7e7ea15af7856c6b3 (patch)
tree22e1188760a9e7402332b20e46c27e5081048c0c /packages/ixp425-eth
parent07cf0d98b30ce6887993db22608d84d1ad66f522 (diff)
downloadopenembedded-962eb38eb1b819c02545cbc7e7ea15af7856c6b3.tar.gz
ixp4xx,ixp4225-eth: provide virtual/ixp-eth
Also on ixp4xx/ixp4xx-csr_2.0.bb (only) the ixp400.ko driver is now installed in kernel/drivers, not drivers. On all versions ixp-eth now RDEPENDS on ixp4xx (this should happen automatically but probably doesn't because the modules are done as independent module builds).
Diffstat (limited to 'packages/ixp425-eth')
-rw-r--r--packages/ixp425-eth/ixp400-eth_1.4.bb13
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.1.bb6
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.2.bb8
3 files changed, 21 insertions, 6 deletions
diff --git a/packages/ixp425-eth/ixp400-eth_1.4.bb b/packages/ixp425-eth/ixp400-eth_1.4.bb
index 18251b2ddf..dbcb3411d9 100644
--- a/packages/ixp425-eth/ixp400-eth_1.4.bb
+++ b/packages/ixp425-eth/ixp400-eth_1.4.bb
@@ -1,7 +1,6 @@
# This is the Intel GPL IXP4XX ethernet driver (Linux) plus patches
# to make it work on 2.6 kernels.
#
-DEPENDS = "ixp4xx-csr"
LICENSE = "GPL"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
SRC_URI = "ftp://aiedownload.intel.com/df-support/8500/eng/GPL_ixp400LinuxEthernetDriverPatch-1_4.zip"
@@ -9,11 +8,16 @@ SRC_URI += "file://ixp400-le-be.patch;patch=1"
SRC_URI += "file://makefile.patch;patch=1"
SRC_URI += "file://2.6.13.patch;patch=1"
SRC_URI += "file://2.6.14.patch;patch=1"
-PR = "r0"
+PR = "r1"
+
+DEPENDS = "ixp4xx-csr"
+RDEPENDS = "ixp4xx-csr"
S = "${WORKDIR}"
-COMPATIBLE_HOST = "^armeb-linux.*"
+COMPATIBLE_HOST = "^arm.*-linux.*"
+
+PROVIDES = "virtual/ixp-eth"
inherit module
@@ -26,9 +30,12 @@ KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
# This is a somewhat arbitrary choice:
OSAL_DIR = "${STAGING_KERNEL_DIR}/ixp_osal"
+IX_TARGET = "linux${NSLU2_ARCH_TYPE}e"
+
EXTRA_OEMAKE = "'CC=${KERNEL_CC}' \
'LD=${KERNEL_LD}' \
'PWD=${S}' \
+ 'IX_TARGET=${IX_TARGET}' \
'IXP4XX_CSR_DIR=${STAGING_INCDIR}/linux/ixp4xx-csr' \
'OSAL_DIR=${OSAL_DIR}' \
'IX_CFLAGS=-DIX_UTOPIAMODE=0 -DIX_MPHYSINGLEPORT=1' \
diff --git a/packages/ixp425-eth/ixp425-eth_1.1.bb b/packages/ixp425-eth/ixp425-eth_1.1.bb
index cbf7e106ce..79243fa1d3 100644
--- a/packages/ixp425-eth/ixp425-eth_1.1.bb
+++ b/packages/ixp425-eth/ixp425-eth_1.1.bb
@@ -10,12 +10,16 @@ SRC_URI = "http://www.intel.com/design/network/swsup/ixp400LinuxEthernetDriverPa
file://mm4.patch;patch=1"
SRC_URI += "file://2.6.13.patch;patch=1"
SRC_URI += "file://2.6.14.patch;patch=1"
-PR = "r10"
+PR = "r11"
+
+RDEPENDS = "ixp4xx-csr"
S = "${WORKDIR}"
COMPATIBLE_HOST = "^armeb-linux.*"
+PROVIDES = "virtual/ixp-eth"
+
inherit module
# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
diff --git a/packages/ixp425-eth/ixp425-eth_1.2.bb b/packages/ixp425-eth/ixp425-eth_1.2.bb
index fbb8a2f27c..3459291541 100644
--- a/packages/ixp425-eth/ixp425-eth_1.2.bb
+++ b/packages/ixp425-eth/ixp425-eth_1.2.bb
@@ -1,7 +1,6 @@
# This is the Intel GPL IXP4XX ethernet driver (Linux) plus patches
# to make it work on 2.6 kernels.
#
-DEPENDS = "ixp4xx-csr"
LICENSE = "GPL"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
SRC_URI = "ftp://download.intel.com/design/network/swsup/ixp400linuxethernetdriverpatch-1_2.zip"
@@ -9,12 +8,17 @@ SRC_URI += "file://ixp400linuxethernetdriver-1_2-kernel26_hr_20050929.patch;patc
SRC_URI += "file://makefile.patch;patch=1"
SRC_URI += "file://2.6.13.patch;patch=1"
SRC_URI += "file://2.6.14.patch;patch=1"
-PR = "r0"
+PR = "r1"
+
+DEPENDS = "ixp4xx-csr"
+RDEPENDS = "ixp4xx-csr"
S = "${WORKDIR}"
COMPATIBLE_HOST = "^armeb-linux.*"
+PROVIDES = "virtual/ixp-eth"
+
inherit module
# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as