aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp425-eth
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-30 03:05:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-30 03:05:50 +0000
commit9f00cacbccf02db56cb4e134a8dcecb6d13205d9 (patch)
tree1a7ea5199565885e67fbd4a5cbc211847bdcd0f8 /packages/ixp425-eth
parentf0c27346be9b14f69a4fd1424db329d58a505ce7 (diff)
downloadopenembedded-9f00cacbccf02db56cb4e134a8dcecb6d13205d9.tar.gz
linux: fix missing HOST_CC_ARCH in module compilation in kernel/module all
- define TARGET_KERNEL_CC_ARCH to define arch specific compiler options in machine.conf. The default for the kernel is "" (empty), although it should probably be TARGET_CC_ARCH in the future. The default for modules is TARGET_CC_ARCH
Diffstat (limited to 'packages/ixp425-eth')
-rw-r--r--packages/ixp425-eth/ixp400-eth_1.4.bb6
-rw-r--r--packages/ixp425-eth/ixp400-eth_1.5.bb6
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.1.bb6
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.2.bb6
4 files changed, 0 insertions, 24 deletions
diff --git a/packages/ixp425-eth/ixp400-eth_1.4.bb b/packages/ixp425-eth/ixp400-eth_1.4.bb
index 6e14f67c0e..81dc5e9ec0 100644
--- a/packages/ixp425-eth/ixp400-eth_1.4.bb
+++ b/packages/ixp425-eth/ixp400-eth_1.4.bb
@@ -25,12 +25,6 @@ RPROVIDES = "ixp-eth"
inherit module
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
# This is a somewhat arbitrary choice:
OSAL_DIR = "${STAGING_KERNEL_DIR}/ixp_osal"
diff --git a/packages/ixp425-eth/ixp400-eth_1.5.bb b/packages/ixp425-eth/ixp400-eth_1.5.bb
index e54077460b..986d5ddf37 100644
--- a/packages/ixp425-eth/ixp400-eth_1.5.bb
+++ b/packages/ixp425-eth/ixp400-eth_1.5.bb
@@ -33,12 +33,6 @@ RPROVIDES = "ixp-eth"
inherit module
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
# This is a somewhat arbitrary choice:
OSAL_DIR = "${STAGING_KERNEL_DIR}/ixp_osal"
diff --git a/packages/ixp425-eth/ixp425-eth_1.1.bb b/packages/ixp425-eth/ixp425-eth_1.1.bb
index 53e713178a..43330d6de2 100644
--- a/packages/ixp425-eth/ixp425-eth_1.1.bb
+++ b/packages/ixp425-eth/ixp425-eth_1.1.bb
@@ -24,12 +24,6 @@ RPROVIDES = "ixp-eth"
inherit module
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
do_pre_patch () {
patcher -p 0 -i ixp425_eth_1_1_update_nf_bridge.patch
patcher -f -p 0 -i ixp425_eth.c.patch
diff --git a/packages/ixp425-eth/ixp425-eth_1.2.bb b/packages/ixp425-eth/ixp425-eth_1.2.bb
index 3cc9a6c70a..a3587e8064 100644
--- a/packages/ixp425-eth/ixp425-eth_1.2.bb
+++ b/packages/ixp425-eth/ixp425-eth_1.2.bb
@@ -23,12 +23,6 @@ RPROVIDES = "ixp-eth"
inherit module
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
# This is a somewhat arbitrary choice:
OSAL_DIR = "${STAGING_KERNEL_DIR}/ixp_osal"