aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp425-eth
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-11-14 01:02:10 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-14 01:02:10 +0000
commitb36999d27c8d713ae2421c130633a796f4e98f83 (patch)
tree32b03fe7e2aa26b24f8235b2316cefc9218cabd4 /packages/ixp425-eth
parentd531ca2e728e1a3d0d850a3c0c06f908209e8142 (diff)
downloadopenembedded-b36999d27c8d713ae2421c130633a796f4e98f83.tar.gz
ixp400-eth: make building for 2.6.14-mm in 1.4
Diffstat (limited to 'packages/ixp425-eth')
-rw-r--r--packages/ixp425-eth/ixp400-eth-1.4/2.6.14-mm.patch44
-rw-r--r--packages/ixp425-eth/ixp400-eth_1.4.bb3
2 files changed, 46 insertions, 1 deletions
diff --git a/packages/ixp425-eth/ixp400-eth-1.4/2.6.14-mm.patch b/packages/ixp425-eth/ixp400-eth-1.4/2.6.14-mm.patch
new file mode 100644
index 0000000000..b2dfaaa4fe
--- /dev/null
+++ b/packages/ixp425-eth/ixp400-eth-1.4/2.6.14-mm.patch
@@ -0,0 +1,44 @@
+--- ./ixp400_eth.c.orig 2005-11-13 16:17:57.943717806 -0800
++++ ./ixp400_eth.c 2005-11-13 16:29:00.829430574 -0800
+@@ -65,6 +65,10 @@
+ #include <linux/sysctl.h>
+ #include <linux/unistd.h>
+
++#ifndef to_platform_device
++#include <linux/platform_device.h>
++#endif
++
+ /*
+ * Intel IXP400 Software specific header files
+ */
+@@ -2410,7 +2414,7 @@ dev_tx_timeout_work(void* arg)
+ }
+
+
+-
++#if 0
+ static void
+ dev_tx_timeout_task(void *dev_id)
+ {
+@@ -2444,6 +2448,7 @@ dev_tx_timeout_task(void *dev_id)
+
+ up(maintenance_mutex);
+ }
++#endif
+
+
+ /* This function is called when kernel thinks that TX is stuck */
+@@ -3274,9 +3279,12 @@ static struct net_device ixp400_devices[
+
+ int init_module(void)
+ {
+- int res, dev_count;
++ int res;
++#if 0
++ int dev_count;
+ IxEthAccPortId portId;
+ struct net_device *dev;
++#endif
+ int i;
+ TRACE;
+
diff --git a/packages/ixp425-eth/ixp400-eth_1.4.bb b/packages/ixp425-eth/ixp400-eth_1.4.bb
index 623f609d7d..477f3244b9 100644
--- a/packages/ixp425-eth/ixp400-eth_1.4.bb
+++ b/packages/ixp425-eth/ixp400-eth_1.4.bb
@@ -9,7 +9,8 @@ SRC_URI += "file://makefile.patch;patch=1"
SRC_URI += "file://2.6.13.patch;patch=1"
SRC_URI += "file://2.6.14.patch;patch=1"
SRC_URI += "file://ixp400_pollcontroller.patch;patch=1"
-PR = "r5"
+SRC_URI += "file://2.6.14-mm.patch;patch=1"
+PR = "r6"
DEPENDS = "ixp4xx-csr"
RDEPENDS = "ixp4xx-csr"