aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp425-eth
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-10 09:38:16 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-10 09:38:16 +0000
commitdbb8037b26b34df48e7799908a2a47c6cd6e4e8a (patch)
tree43ee221a5e38c0bfc583788ef5f2cc78183d60ed /packages/ixp425-eth
parenta2d7db8f55ea6be119a7ff9be71e6341e76dd618 (diff)
downloadopenembedded-dbb8037b26b34df48e7799908a2a47c6cd6e4e8a.tar.gz
ixp400-eth: gcc4 patch in 1.5
Diffstat (limited to 'packages/ixp425-eth')
-rw-r--r--packages/ixp425-eth/ixp400-eth-1.5/netdev_max_backlog.patch54
-rw-r--r--packages/ixp425-eth/ixp400-eth_1.5.bb3
2 files changed, 56 insertions, 1 deletions
diff --git a/packages/ixp425-eth/ixp400-eth-1.5/netdev_max_backlog.patch b/packages/ixp425-eth/ixp400-eth-1.5/netdev_max_backlog.patch
new file mode 100644
index 0000000000..6891b6b4a9
--- /dev/null
+++ b/packages/ixp425-eth/ixp400-eth-1.5/netdev_max_backlog.patch
@@ -0,0 +1,54 @@
+--- ixp400_eth/ixp400_eth.c~ 2006-01-09 01:03:11.000000000 +1030
++++ ixp400_eth/ixp400_eth.c 2006-01-09 01:05:27.000000000 +1030
+@@ -139,12 +139,12 @@
+ * skbuf to push into the linux stack, and avoid the performance degradations
+ * during overflow.
+ */
+-static int netdev_max_backlog = 290;
++static int ixp400_netdev_max_backlog = 290;
+
+ static int datapath_poll = 1; /* default : rx/tx polling, not interrupt driven*/
+
+-MODULE_PARM(netdev_max_backlog, "i");
+-MODULE_PARM_DESC(netdev_max_backlog, "Should be set to the value of /proc/sys/net/core/netdev_max_backlog (perf affecting)");
++MODULE_PARM(ixp400_netdev_max_backlog, "i");
++MODULE_PARM_DESC(ixp400_netdev_max_backlog, "Should be set to the value of /proc/sys/net/core/netdev_max_backlog (perf affecting)");
+ MODULE_PARM(datapath_poll, "i");
+ MODULE_PARM_DESC(datapath_poll, "If non-zero, use polling method for datapath instead of interrupts");
+ #endif /* CONFIG_IXP400_NAPI */
+@@ -213,7 +213,7 @@
+ * high traffic rates. To measure the maximum throughput between the
+ * ports of the driver,
+ * - Modify /proc/sys/net/core/netdev_max_backlog value in the kernel
+- * - Adjust netdev_max_backlog=n in the driver's command line
++ * - Adjust ixp400_netdev_max_backlog=n in the driver's command line
+ * in order to get the best rates depending on the testing tool
+ * and the OS load.
+ *
+@@ -1997,7 +1997,7 @@
+ /* check if the system accepts more traffic and
+ * against chained mbufs
+ */
+- if ((qlevel < netdev_max_backlog)
++ if ((qlevel < ixp400_netdev_max_backlog)
+ && (IX_OSAL_MBUF_NEXT_PKT_IN_CHAIN_PTR(mbuf) == NULL))
+ #else
+ /* check against chained mbufs
+@@ -3776,13 +3776,13 @@
+ #ifndef CONFIG_IXP400_NAPI
+ /* set the softirq rx queue thresholds
+ * (These numbers are based on tuning experiments)
+- * maxbacklog = (netdev_max_backlog * 10) / 63;
++ * maxbacklog = (ixp400_netdev_max_backlog * 10) / 63;
+ */
+- if (netdev_max_backlog == 0)
++ if (ixp400_netdev_max_backlog == 0)
+ {
+- netdev_max_backlog = 290; /* system default */
++ ixp400_netdev_max_backlog = 290; /* system default */
+ }
+- netdev_max_backlog /= BACKLOG_TUNE;
++ ixp400_netdev_max_backlog /= BACKLOG_TUNE;
+
+ TRACE;
+ #endif
diff --git a/packages/ixp425-eth/ixp400-eth_1.5.bb b/packages/ixp425-eth/ixp400-eth_1.5.bb
index 96287fb3d9..f5d2b34070 100644
--- a/packages/ixp425-eth/ixp400-eth_1.5.bb
+++ b/packages/ixp425-eth/ixp400-eth_1.5.bb
@@ -15,10 +15,11 @@ SRC_URI += "file://mac-address.patch;patch=1"
SRC_URI += "file://int-random.patch;patch=1"
SRC_URI += "file://stop-on-rmmod.patch;patch=1"
SRC_URI += "file://continue-if-qmgr-init-fails.patch;patch=1"
+SRC_URI += "file://netdev_max_backlog.patch;patch=1"
SRC_URI += "file://debug.patch;patch=1"
SRC_URI += "file://Makefile.patch;patch=1"
-PR = "r2"
+PR = "r3"
DEPENDS = "ixp4xx-csr"
RDEPENDS = "ixp4xx-csr"