aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp4xx/ixp-osal-2.1.1/Makefile.patch
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-06-20 11:16:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-20 11:16:41 +0000
commit9d22c00dd63f99a2db8731905f96233cef7949f6 (patch)
tree50e6705ecb997280d7c915abef0c0e2ec8851167 /packages/ixp4xx/ixp-osal-2.1.1/Makefile.patch
parent63685be96ca10cfe0fab542c7a3750efbbc4aa28 (diff)
downloadopenembedded-9d22c00dd63f99a2db8731905f96233cef7949f6.tar.gz
ixp4xx: version 2.1.1 of the access library added - compiles, untested, requires microcode loading support to be written before use.
Diffstat (limited to 'packages/ixp4xx/ixp-osal-2.1.1/Makefile.patch')
-rw-r--r--packages/ixp4xx/ixp-osal-2.1.1/Makefile.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/ixp4xx/ixp-osal-2.1.1/Makefile.patch b/packages/ixp4xx/ixp-osal-2.1.1/Makefile.patch
new file mode 100644
index 0000000000..1558e9cdb3
--- /dev/null
+++ b/packages/ixp4xx/ixp-osal-2.1.1/Makefile.patch
@@ -0,0 +1,30 @@
+ Makefile | 2 +-
+ os/linux/make/macros.mk | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+--- ixp_osal/Makefile 1970-01-01 00:00:00.000000000 +0000
++++ ixp_osal/Makefile 1970-01-01 00:00:00.000000000 +0000
+@@ -185,7 +185,7 @@ endif
+ INCLUDE_DIRS = include $(OSAL_DIRS:%=$(MAIN_INC_PREFIX)/%) $(OSAL_DIRS:%=$(OS_INC_PREFIX)/%)
+
+ ifeq ($(IX_OSAL_MK_HOST_OS), linux)
+-INCLUDE_DIRS += $(LINUX_SRC)/include/asm-arm/arch-ixp425/
++INCLUDE_DIRS += $(LINUX_SRC)/include/asm-arm/arch-ixp4xx/
+ endif
+
+ CFLAGS += $(INCLUDE_DIRS:%=-I%)
+--- ixp_osal/os/linux/make/macros.mk 1970-01-01 00:00:00.000000000 +0000
++++ ixp_osal/os/linux/make/macros.mk 1970-01-01 00:00:00.000000000 +0000
+@@ -88,10 +88,10 @@ AR := $(LINUX_CROSS_COMPILE)ar
+ # Compiler & linker options
+
+ # Compiler flags
+-LINUX_MACH_CFLAGS := -D__LINUX_ARM_ARCH__=5 -mcpu=xscale -mtune=xscale
++LINUX_MACH_CFLAGS := -D__LINUX_ARM_ARCH__=5 -mtune=xscale
+
+ CFLAGS := -D__KERNEL__ -I$(LINUX_SRC)/include -Wall -Wno-trigraphs -fno-common \
+- -pipe -mapcs-32 -mshort-load-bytes -msoft-float -DMODULE \
++ -pipe -msoft-float -DMODULE \
+ -D__linux -DCPU=33 -DXSCALE=33 $(LINUX_MACH_CFLAGS) -DEXPORT_SYMTAB
+
+ # Linux linker flags