aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp4xx
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-11-29 02:46:59 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-29 02:46:59 +0000
commit2765c17b474a765e31206b7a442ba1c9fc8301ea (patch)
tree3980eeaaa1eb1e6096f9d7c9d0e1a4a72b5220c9 /packages/ixp4xx
parent71606ab7069b27f2224efb6f682beaf4846e4aa1 (diff)
downloadopenembedded-2765c17b474a765e31206b7a442ba1c9fc8301ea.tar.gz
ixp4xx-csr: attempt to fix build timestamp problems in 2.1
- The make of the kernel module (.ko) sometimes fails to result in a rebuild of the .ko, probably as a result of it not seeming out of date with respect to the other files. This fix works by explicitly removing the initial (too small) .ko and .mod.o
Diffstat (limited to 'packages/ixp4xx')
-rw-r--r--packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch14
-rw-r--r--packages/ixp4xx/ixp4xx-csr_2.1.bb2
2 files changed, 14 insertions, 2 deletions
diff --git a/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch b/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch
index b90a3d7da4..39ec252a2e 100644
--- a/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch
+++ b/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch
@@ -24,25 +24,37 @@
################################################################
# Rules to check that macros are defined.
-@@ -1321,10 +1323,18 @@ ixp400.o : $(OBJ_DIR)/ixp400.o
+@@ -1321,10 +1323,26 @@ ixp400.o : $(OBJ_DIR)/ixp400.o
ifndef IX_INCLUDE_MICROCODE
$(OBJ_DIR)/ixp400.o: $(COMPONENTS:%=$(OBJ_DIR)/ixp400_%.o) $(OSAL_MODULE)
++ rm -f $(OBJ_DIR)/ixp400.c
+ touch $(OBJ_DIR)/ixp400.c
+ cp Makefile.kmod26 $(OBJ_DIR)/Makefile
+ make -C $(OBJ_DIR)
++ rm -f $(OBJ_DIR)/ixp400.c
++ cp ixp400.c $(OBJ_DIR)/ixp400.c
$(LD) $(LDFLAGS) $^ -o $@
++ rm -f $(OBJ_DIR)/ixp400.ko $(OBJ_DIR)/ixp400.mod.o
+ make -C $(OBJ_DIR)
else
$(OBJ_DIR)/ixp400.o: $(COMPONENTS:%=$(OBJ_DIR)/ixp400_%.o) $(NPE_PRODUCTION_HEADER_OBJ) $(OSAL_MODULE)
++ rm -f $(OBJ_DIR)/ixp400.c
+ touch $(OBJ_DIR)/ixp400.c
+ cp Makefile.kmod26 $(OBJ_DIR)/Makefile
+ make -C $(OBJ_DIR)
++ rm -f $(OBJ_DIR)/ixp400.c
++ cp ixp400.c $(OBJ_DIR)/ixp400.c
$(LD) $(LDFLAGS) $^ -o $@
++ rm -f $(OBJ_DIR)/ixp400.ko $(OBJ_DIR)/ixp400.mod.o
+ make -C $(OBJ_DIR)
endif
+--- ixp400_xscale_sw/ixp400.c 1970-01-01 01:00:00.000000000 +0100
++++ ixp400_xscale_sw/ixp400.c 2005-08-24 22:33:12.000000000 +0200
+@@ -0,0 +1,1 @@
++#error this file must never be compiled
--- ixp400_xscale_sw/Makefile.kmod26 1970-01-01 01:00:00.000000000 +0100
+++ ixp400_xscale_sw/Makefile.kmod26 2005-08-24 22:33:12.000000000 +0200
@@ -0,0 +1,11 @@
diff --git a/packages/ixp4xx/ixp4xx-csr_2.1.bb b/packages/ixp4xx/ixp4xx-csr_2.1.bb
index 6da973b0d7..f8b29f11f1 100644
--- a/packages/ixp4xx/ixp4xx-csr_2.1.bb
+++ b/packages/ixp4xx/ixp4xx-csr_2.1.bb
@@ -34,7 +34,7 @@ SRC_URI += "file://le.patch;patch=1"
DEPENDS = "ixp-osal"
S = "${WORKDIR}/ixp400_xscale_sw"
-PR = "r0"
+PR = "r1"
COMPATIBLE_HOST = "^arm.*-linux.*"