aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp4xx
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-06-25 04:20:16 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-25 04:20:16 +0000
commit65d06317f3624044da9abc872a854136aefd59bd (patch)
treeb400f08afbf728958114c31e93805fa7a6bd8432 /packages/ixp4xx
parent238722e5b137d0ad7ad7b6cc13043744d1274d35 (diff)
downloadopenembedded-65d06317f3624044da9abc872a854136aefd59bd.tar.gz
ixp4xx-csr: Fixed the .bb so that the 2.1.1 patch is actually applied, but unfortunately it now doesn't build.
Diffstat (limited to 'packages/ixp4xx')
-rw-r--r--packages/ixp4xx/ixp4xx-csr-2.1.1/module-param.patch8
-rw-r--r--packages/ixp4xx/ixp4xx-csr-2.1.1/oe-makefile.patch52
-rw-r--r--packages/ixp4xx/ixp4xx-csr-2.1.1/undefined-attribute.patch16
-rw-r--r--packages/ixp4xx/ixp4xx-csr_2.1.1.bb17
4 files changed, 58 insertions, 35 deletions
diff --git a/packages/ixp4xx/ixp4xx-csr-2.1.1/module-param.patch b/packages/ixp4xx/ixp4xx-csr-2.1.1/module-param.patch
index c61fcc00d3..6472ef8b05 100644
--- a/packages/ixp4xx/ixp4xx-csr-2.1.1/module-param.patch
+++ b/packages/ixp4xx/ixp4xx-csr-2.1.1/module-param.patch
@@ -5,10 +5,10 @@ Index: ixp400_xscale_sw/src/oslinux/IxLinuxInit.c
===================================================================
--- ixp400_xscale_sw.orig/src/oslinux/IxLinuxInit.c
+++ ixp400_xscale_sw/src/oslinux/IxLinuxInit.c
-@@ -93,7 +93,11 @@
- /* Module parameters */
- static int livelock_dispatcher = 0;/* default: don't use livelock dispatcher*/
-
+@@ -103,7 +103,11 @@
+ #if KERNEL_VERSION(2,6,0) <= LINUX_VERSION_CODE
+ MODULE_VERSION("2.1.1");
+ #endif
+#if LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,16)
MODULE_PARM(livelock_dispatcher, "i");
+#else
diff --git a/packages/ixp4xx/ixp4xx-csr-2.1.1/oe-makefile.patch b/packages/ixp4xx/ixp4xx-csr-2.1.1/oe-makefile.patch
index 492b1eab03..9f1d253a93 100644
--- a/packages/ixp4xx/ixp4xx-csr-2.1.1/oe-makefile.patch
+++ b/packages/ixp4xx/ixp4xx-csr-2.1.1/oe-makefile.patch
@@ -1,22 +1,30 @@
changes to Makefile required only on OE
---- ixp400_xscale_sw/Makefile 1970-01-01 00:00:00.000000000 +0000
-+++ ixp400_xscale_sw/Makefile 1970-01-01 00:00:00.000000000 +0000
-@@ -1321,10 +1323,26 @@ ixp400.o : $(OBJ_DIR)/ixp400.o
+ Makefile | 11 ++++++++++-
+ Makefile.kmod26 | 11 +++++++++++
+ ixp400.c | 1 +
+ 3 files changed, 22 insertions(+), 1 deletion(-)
+
+Index: ixp400_xscale_sw/Makefile
+===================================================================
+--- ixp400_xscale_sw.orig/Makefile
++++ ixp400_xscale_sw/Makefile
+@@ -1385,9 +1385,10 @@
+
+ ifeq ($(IX_LINUXVER),2.6)
+ ixp400 : $(OBJ_DIR)/ixp400.o
++ cp $(OSAL_MODULE) $(OBJ_DIR)
+ @echo 'EXTRA_LDFLAGS := --whole-archive' > $(OBJ_DIR)/Makefile
+ @echo ' ' >> $(OBJ_DIR)/Makefile
+- @echo 'lib-m := $(COMPONENTS:%=ixp400_%.o) $(OBJ_DIR_EXIT)/$(OSAL_MODULE)'>> $(OBJ_DIR)/Makefile
++ @echo 'lib-m := $(COMPONENTS:%=ixp400_%.o) ixp_osal.o'>> $(OBJ_DIR)/Makefile
+ @echo ' ' >> $(OBJ_DIR)/Makefile
+ @echo 'obj-m := ixp400.o' >> $(OBJ_DIR)/Makefile
+ @echo ' ' >> $(OBJ_DIR)/Makefile
+@@ -1403,7 +1404,15 @@
- ifndef IX_INCLUDE_MICROCODE
$(OBJ_DIR)/ixp400.o: $(COMPONENTS:%=$(OBJ_DIR)/ixp400_%.o) $(OSAL_MODULE)
-+ rm -f $(OBJ_DIR)/ixp400.c
-+ touch $(OBJ_DIR)/ixp400.c
-+ cp Makefile.kmod26 $(OBJ_DIR)/Makefile
-+ make -C $(OBJ_DIR)
-+ rm -f $(OBJ_DIR)/ixp400.c
-+ cp ixp400.c $(OBJ_DIR)/ixp400.c
- $(LD) $(LDFLAGS) $^ -o $@
-+ rm -f $(OBJ_DIR)/ixp400.ko $(OBJ_DIR)/ixp400.mod.o
-+ make -C $(OBJ_DIR)
- else
- $(OBJ_DIR)/ixp400.o: $(COMPONENTS:%=$(OBJ_DIR)/ixp400_%.o) $(NPE_PRODUCTION_HEADER_OBJ) $(OSAL_MODULE)
+ ifneq ($(IX_LINUXVER),2.6)
+ rm -f $(OBJ_DIR)/ixp400.c
+ touch $(OBJ_DIR)/ixp400.c
+ cp Makefile.kmod26 $(OBJ_DIR)/Makefile
@@ -29,12 +37,16 @@ changes to Makefile required only on OE
endif
---- ixp400_xscale_sw/ixp400.c 1970-01-01 00:00:00.000000000 +0000
-+++ ixp400_xscale_sw/ixp400.c 1970-01-01 00:00:00.000000000 +0000
-@@ -0,0 +1,1 @@
+Index: ixp400_xscale_sw/ixp400.c
+===================================================================
+--- /dev/null
++++ ixp400_xscale_sw/ixp400.c
+@@ -0,0 +1 @@
+#error this file must never be compiled
---- ixp400_xscale_sw/Makefile.kmod26 1970-01-01 00:00:00.000000000 +0000
-+++ ixp400_xscale_sw/Makefile.kmod26 1970-01-01 00:00:00.000000000 +0000
+Index: ixp400_xscale_sw/Makefile.kmod26
+===================================================================
+--- /dev/null
++++ ixp400_xscale_sw/Makefile.kmod26
@@ -0,0 +1,11 @@
+obj-m := ixp400.o
+
diff --git a/packages/ixp4xx/ixp4xx-csr-2.1.1/undefined-attribute.patch b/packages/ixp4xx/ixp4xx-csr-2.1.1/undefined-attribute.patch
new file mode 100644
index 0000000000..8a08f862f6
--- /dev/null
+++ b/packages/ixp4xx/ixp4xx-csr-2.1.1/undefined-attribute.patch
@@ -0,0 +1,16 @@
+ src/include/IxEthDB.h | 2 +-
+ 1 files changed, 1 insertion(+), 1 deletion(-)
+
+Index: ixp400_xscale_sw/src/include/IxEthDB.h
+===================================================================
+--- ixp400_xscale_sw.orig/src/include/IxEthDB.h
++++ ixp400_xscale_sw/src/include/IxEthDB.h
+@@ -273,7 +273,7 @@
+ typedef struct
+ {
+ UINT8 macAddress[IX_IEEE803_MAC_ADDRESS_SIZE];
+-} IX_OSAL_ATTRIBUTE_PACKED IxEthDBMacAddr;
++} IxEthDBMacAddr;
+
+ /**
+ *
diff --git a/packages/ixp4xx/ixp4xx-csr_2.1.1.bb b/packages/ixp4xx/ixp4xx-csr_2.1.1.bb
index 0a6cbaa06d..a21f42f018 100644
--- a/packages/ixp4xx/ixp4xx-csr_2.1.1.bb
+++ b/packages/ixp4xx/ixp4xx-csr_2.1.1.bb
@@ -30,31 +30,25 @@ LICENSE_HOMEPAGE = "http://www.intel.com/design/network/products/npfamily/ixp425
SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/BSD_ixp400AccessLibrary-2_1.zip"
SRC_URI += "http://www.intel.com/Please-Read-The-BB-File/BSD_ixp400AccessLibrary-2_1_1.zip"
SRC_URI += "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_1.zip"
-SRC_URI += "file://Makefile.patch;patch=1"
-SRC_URI += "file://ixethdb-header.patch;patch=1"
SRC_URI += "file://bit-macro.patch;patch=1"
-SRC_URI += "file://ixnpemhconfigisr-is-private.patch;patch=1"
SRC_URI += "file://le.patch;patch=1"
SRC_URI += "file://mii-debug.patch;patch=1"
SRC_URI += "file://rtl8201-support.patch;patch=1"
-SRC_URI += "file://gcc4.patch;patch=1"
SRC_URI += "file://oe-makefile.patch;patch=1"
SRC_URI += "file://livelock.patch;patch=1"
SRC_URI += "file://module-param.patch;patch=1"
-SRC_URI += "file://module-use-count.patch;patch=1"
+SRC_URI += "file://undefined-attribute.patch;patch=1"
DEPENDS = "ixp-osal"
S = "${WORKDIR}/ixp400_xscale_sw"
-PR = "r1"
+PR = "r2"
COMPATIBLE_HOST = "^arm.*-linux.*"
inherit module
do_pre_patch () {
- ( cd ${WORKDIR} ; mkdir patches ; mv BSD_ixp400AccessLibrary-2_1_1.patch patches/ ; \
- echo "BSD_ixp400AccessLibrary-2_1_1.patch -p0" >> patches/series ; \
- quilt push )
+ cd ${WORKDIR} ; patch -p0 < BSD_ixp400AccessLibrary-2_1_1.patch
}
addtask pre_patch before do_patch
@@ -77,6 +71,7 @@ CODELETS_COMPONENTS = ""
# the ixp4xx-csr module, this *requires* the IPL_ixp400NpeLibrary-2_1.zip
# to be added to the SRC_URI - see above.
EXTRA_OEMAKE = "'AR=${AR}' \
+ 'IX_LINUXVER=2.6' \
'IX_XSCALE_SW=${S}' \
'IX_TARGET=${IX_TARGET}' \
'${IX_TARGET}_COMPONENTS=${COMPONENTS}' \
@@ -93,7 +88,7 @@ EXTRA_OEMAKE = "'AR=${AR}' \
'OSAL_MODULE=${OSAL_DIR}/${OSAL_PATH}/ixp_osal.o' \
"
-MAKE_TARGETS = "lib/${IX_TARGET}/ixp400.o"
+MAKE_TARGETS = "ixp400"
KCONFIG_FILE = "${STAGING_KERNEL_DIR}/kernel-config"
do_stage () {
@@ -109,7 +104,7 @@ do_stage () {
${CONFIG_MODULE_SRCVERSION_ALL:+-a} \
-i '${STAGING_KERNEL_DIR}/Module.symvers' \
-o '${STAGING_KERNEL_DIR}/ixp400-csr.symvers' \
- ${MAKE_TARGETS} 2>&1 | egrep .
+ lib/${IX_TARGET}/ixp400.o 2>&1 | egrep .
then
echo "MODPOST errors - see above"
return 1